Solution showcase: Learn how to use Nintex CE Platform
Connect with peers and experts to ask questions, share insights, and find solutions for Nintex products.
Recently active
I have a complex workflow that updates a Nintex group to match the membership of a corresponding AD group. It works most of the time, but it runs many steps and for 1 specific group, the workflow terminates, probably because it reaches some limit. I was wondering if you can take a look and see if you can help me optimize this workflow so it won’t run into these problems. Here is my workflow:The inputs are the Name of AD Group & the Name of Nintex Group (which are often the same). Action 1 - Get all the members of the AD group.Action 2 - Get all the Nintex Groups in the tenant (because I don’t yet know a method to get a Nintex Group by name without looping through all the groups).Action 3 - Get all the Nintex users in the tenant (because I don’t yet know a method to get a Nintex user by name without looping through all the users).Action 4 - Loop through each Nintex Group.Action 5 - If one Nintex Group name matches the group name we want, then run this next step:Action 6 - Loop throu
Is this an oversight when releasing this feature? Button (nintex.com) I do not see anywhere in the help documentation where in states the button control is ONLY for start event forms. Our assumption was it’s for form designer for tasks or start events. Can someone look into this???? Form Designer for Start event forms: Form designer for Task forms:
Is there a feature on the roadmap (e.g., under Workflow settings > Workflow publishing) that would allow specific roles or groups to have permission to delete a workflow?Background: In our current support structure, workflow stewardship falls on citizen developers and workflow owners within the business. They proactively manage day-to-day troubleshooting, receive failure alerts, and escalate issues to IT if necessary. Currently, users with workflow owner permissions can delete workflows. However, until Nintex introduces a proper backup and restore feature, we cannot fully hand over management of our 400+ workflows to the business side. The risk of accidental deletion or, in the worst-case scenario, a compromised account resulting in malicious deletion, makes it critical to restrict the ability to delete workflows to certain user groups. This feature would be extremely beneficial.Any idea from best practise point-of-view is welcome :)
Is there a feature that enables alert on instance failure to form initiator?
I have multiple workflows that are erroring with “failed to start” or “failed to run”. I want to know how to write a SQL query to find all of them.
I am attempting to change the instance name to reflect variables in the start form using the 'Set instance name.' I understand that this action should change the instance name in the My Nintex dashboard to the selected variables in the action. This will make the instance easily identifiable by the user. Is the action configured correctly? There is no change in the name reflected in the My Nintex dashboard. See attached screenshots.
Issue DescriptionWhen you start the K2 Service, it stops responding and an error occurs.Error Message:The following error in the Event View occurs: “Application: K2HostServer.exeFramework Version: v4.0.30319Description: The process was terminated due to an unhandled exception.Exception Info: System.NullReferenceExceptionat SourceCode.Hosting.Server.Runtime.HostLoadBalancedServerManager.get_Logger()at SourceCode.Hosting.Server.Runtime.HostLoadBalancedServerManager.Poll()at SourceCode.Hosting.Server.Runtime.HostServerEngine.DBConnectionWorker()” ResolutionThe fix is available in:K2 Five (5.6) Fix Pack 40. Nintex Automation (5.7) Fix Pack 16. Nintex Automation K2 (5.8) Fix Pack 01.Ensure you have the correct K2 version and/or Cumulative update installed. See KB001893 to see what Fix Pack level you have installed. Download the latest Fix Pack using the links in the table above for the version you require. Install the Fix Pack to apply the fix.
Hi, Been doing some training in NLX with SF as a datasource for my models. After about 30 minutes, the connection to SF fails and I get the error below. Losing hours of work. Any help appreciated. The following errors occurred:1. Error retrieving metadata for model(s) associated with data source 'Salesforcev3'. Please check models' properties to ensure they are set correctly. Unable to authenticate to Salesforce. Metadata could not be retrieved. Login has been cancelled
Hello,I want to use the padLeft functionality to change a variable in my NAC workflow.Is it possible to use any functions in the workflow, or are they exclusivly for Nintex Forms?Using Nintex for SharePoint 2019 it was possible to use the functions inside of a workflow likefn-padLeft(txtDocumentID, 5, "0")Is there maybe a workaround to achive this without buildung a custom action for NAC?Thank you and best regardsNiklas
Hi Team, I have been creating some custom formulas and today when wanting to edit one, it had vanished.This is how I have been creating them and what it should look like.But today when going to edit one, it shows this:When I test it in preview it works as intended. I spent a lot of time creating the formula, so I am hoping there is a way for me to recoup the code? Any advice is appreciated. Cheers,Benjamin.
Hi, I have a workflow that is not giving the option to select ‘Current Item’. I need that to loop. below is a output from a ‘Query a List’ . ID’s for records to interrogate I have available coming from SharePoint Online menu item / a notification email shows each ID I need to hit. but in the loop I”m only getting a single record even though appears I am hitting my list through all records.But only get the first tested record to send a run if true email based on conditions. The Output → result is of type file.
I have a simple wizard where I need to copy four columns from excel and paste the values in fields of a web base application.My commands include:**Get worksheet (Excel worksheet actions DAC); Copy from Excel (range of cells into a variable); Get Array Data (using column delimiter, I am separating each column value into a variable, to later ‘input text’ in the application)My problem is when the command for Get Array Data pulls in the last column it also brings in the row delimiter and the value of the first column. The command reads like this: From the array stored in (my variable created from the Copy from Excel) Where items are delimited by $column delimiter$ Get the value of item #4 (since it is column 4). My row delimiter is ***. The value that is pulled in for the last column and stored in the variable reads something like this: 123456***123456789. It pulls in the data in the last column AND the data in the first column of the next row.Any help you have to offer with this w
In a process can I link back to a previous step. Say step 3 in a process to step 2 and step 9 loop back to step 7?
Hi all, We want to use the API for the automatic creation of users.We have used the documentation as a template, but unfortunately we always get the error 403 with the reference to rfc9110#section-15.5.4.Reading the tenant via ‘get users in Tenant’ and deleting users works.Does anyone have any ideas?Thank you Christian Create user in tenant | Nintex Automation Cloud
Hi all,I have looked and cannot see this mentioned elsewhere, apologies if it is.I want to create a simple start event form (well it started simple) just to add a new row to a SharePoint list.I want though to show the existing entries that are already on the list on the form to help stop duplications. Due to spelling differences and differing names cannot use validation. I can link the data and add a drop down. Does anyone know a way of adding a list if entries onto a form from a SharePoint column.Many thanks in advanceJamo
Hi, I am trying to use API to get workflows assigned to a specific user. Is there a way to do it?
After running NWAdmin PurgeHistoryListData and NWAdmin PurgeWorkflowData, the WorkflowProgress table within the SQL database does not get cleaned up. Still old entries reside in the table. This causes the WorkflowProgress table to exceed the threshold of 50.000 datasets. I have even tried to clean up using the stored procedure "dbo.PurgeWorkflowData", but still no luck. Also using the GUI in the Central Administration did make any difference. May I delete these old / not needed entries within the WorkflowProgress table via a T-SQL DELETE statement or will this cause issues? Is there another way to clean up the DB tables? Thank's in advance, any help is highly appreciated 🙂 Used Commands: NWAdmin.exe –o PurgeHistoryListData -siteUrl https://some.site -lastActivityBefore 2022-01-01 -state Completed AND NWAdmin.exe -o PurgeWorkflowData -state All -url https://some.site -lastActivityBeforeUTC 2022-01-01 SQL:USE [My_Nintex_Database_Name_DB1]GODECLARE @return_value intEXEC @return_value = [
I’m using SharePoint 2016 and Nintex on Premises. I would like to force user to enter a different time from the default time value of 12 AM 00 Thanks in advance for all the feedback.
Hi! Question around Process Models - we are trying to move models from one group to another, however cannot find anywhere to do this - models don’t show up in the admin>manage groups screen and there is nowhere in the summary of the model that allows you to edit the group. Surely it is possible to do this and I’m just not seeing it? I’m very concerned the only way to get this done is to export, delete then reimport the model…. Any help would be appreciated!
H, So I have a workflow that is scheduled to run monthly as a first step, next step is to interrogate a target list with a ‘Query List’ action. Problem is I'm getting a first record that hits criteria but its not running through the whole list, It’s hitting the first record/ responding as expected / hits criteria fine and I get a notification email. Problem is that’s the only notification I’m getting, and I know there are more in that list that hit that criteria but are not sending me notifications for them. I believe my list is not being looped through but I'm not sure what’s up. Here is my workflow. The first email disabled is just me making sure I have what I need into the ‘IF TRUE THEN’ and then I only get one email. I then get into the next step, ‘run if true’ but I’m only getting one response from what I believe is a correct hit to send a notification. How do I have the workflow go through all the rest of the records and test / present if any of the other list’s records as
Unable to display a UI field that I have configured in one model with a picklist from another model. Beleive that something is incorrect with the configuring.In my task model, I have configured a UI field which I have called "1st Vehicle Discussed". This field is set up as: - General Tab - Field Id: 1st Vehicle Discussed - Display Type: Combobox - Picklist source: Rows in Model - Return Type: Text - Picklist model - Model: Fund (this is a custom object) - Entry value: {{Bucketed_Fund_Names__c}} - Bucketed_Fund_Names__c field is a picklist field in the Fund object & enabled on Fund Model - Entry label: {{Bucketed_Fund_Names__c}} In the form that displays 1st Vehicle Discussed, I just see a blank drop down. However if I use {{Name}}instead of {{Bucketed_Fund_Names__c}} in the UI field picklist model, I do see the Fund record names inthe dropdown.Is there something that I am missing in configuring the picklist
Users are reporting issues with Nintex forms rules all of a sudden.I have a simple form with a checkbox with a validation rule.The checkbox is connected to a SharePoint list field “DeductFromSalary” of the type YES/NO. The behavior with this rule is just weird. When I check the box… the validation message appears. That should NOT happen as the validation rule is set to display the message when the box is NOT checked. And once it’s displayed… it won’t go away anymore.I can check/uncheck as much as I want… the message stays there.When I remove the “not()” function from the condition, everything seems to be fine. The validation message is displayed when the checkbox is checked and disappears when the checkbox in unchecked. It seems like an issue with the NOT function that is used.We didn’t change anything on the environment. It’s a SharePoint 2019. No updates, no configuration changes, nothing. It has been working up until yesterday… and today it fails. I tried replicating this on a dif
Hi, we have a workflow with an environment variable called “MyWorkflows URL”. this environment variable is used in multiple workflows. I want to check for completed processes / workflows the value for this environment variable. Question 1: Where I can check the environment variable value for a completed process?Question 2: Is there something like a change log for environment variables?
I was wondering if there was a limit to how many workflows on SharePoint can be ran at one time. For instance, I have a workflow that runs on item creation in a SharePoint list. If another resource creates 2400 items in that list, that would mean I have around 2400 workflows running at one time. This appears to be an issue as I do run into many items in that list that show a workflow status of “In Progress” and are stuck with that status for an indefinite amount of time. Any assistance on how to navigate this issue would be greatly appreciated.
Hi,I’m getting an error “request entity too large. [Error Code: IO.AsyncActionExecute.ErrorResponse]” when using Assign a task to multiple users on my workflow.Does anyone know what could be the cause of this error?Regards Mdu
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.