Learn about the latest Nintex capabilities at New at Nintex
All archived community articles, forum posts and groups. Here you will also find older K2 brokers as well as archived Group content.
Recently active
 Symptoms  When people picker control is resolving user, the following error was thrown: "The server is not operational"  Diagnoses  The issue was caused by some LDAP connections configured for the AD Service 2 Service Instance were invalid.  Resolution Correcting invalid LDAP connection strings in AD Service 2 Service Instance resolved the issue.  Â
We are try to publish a simple Nintex workflow but getting the below error for particular web application.Error Message- There is no file with URLNintex workflow version (3.0.8.0)Below is one exampleException calling "PublishFromNWFXml" with "4" argument(s): "Server was unable to process request. ---> <nativehr>0x80070003</nativehr><nativestack></nativestack>There is no filewith URL sitename/NintexWorkflows/__globallyreusable/test/test.xoml' in this Web."At D: estPublishWFPublishNintexWF.ps1:28 char:12+        if($proxy.PublishFromNWFXml($NWFcontent, "" ,$wfName, $true))+           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~   + CategoryInfo         : NotSpecified: (:) [], MethodInvocationException   + FullyQualifiedErrorId : SoapException
Hello, In K2 designer, when i m openning a subview form. I would like to not allow the possibility to maximize the subview form on clic on the top bar of the view form ?It is possible? The second question is i would like the subview form openning in full screen , it is possible ? If i put 100% in the width and height it will stay small and in the center of the screen?  Best regards,
I would like to see a history of my documented support cases is there any easy way to see this. I don't see any offering on the support page.
 Symptoms  I am editing an existing report. I am changing a from clause. I can query and get a result back. When the query window is closed, an error appears stating that it cannot refresh the fields. I cannot build the report thereafter. The error reads "Must declare scalar variable "@ProcessID""  Diagnoses  The issue was related to the Parameter name not being @ProcessID, but just ProcessID. The Parameter value is @ProcessID however, and this out of sync name and value causes the issue.  Resolution The issue was resolved by changing the parameter name from ProcessID to @ProcessID.  Â
 Symptoms  Salesforce is phasing out support for TLS 1.0, with a final cutoff date of March 2017. Our K2 Salesforce broker was originally only built to support TLS 1.0, which will cease to work when TLS 1.0 support is disabled by Salesforce. In 4.7, we added support for TLS 1.1 and higher. This is also available in 4.6.11 as a codefix. There is a KB article (http://help.k2.com/kb001764) that discusses the TLS change, but does not proactively cover some scenarios. Questions needing clarification include: 1. With these changes, will our customers continue to work with no changes when Salesforce updates their production security settings? 2. Or will they need to regenerate their Salesforce proxy and redeploy? 3. When will the new REST broker for Salesforce become available?  Diagnoses  In short, TLS 1.1 support requires .NET 4 (rather than .NET 1 or 2). Our SalesForce service instance generator was originally only built to use .NET 1 and 2. The "fix" (and the change in 4.7) is to include
 Symptoms  Tried to reinstall K2 SharePoint components on SP 2010, but there are WSP files deployment errors.   Diagnoses  Legacy .dll files from a 4.6.11 install were preventing the deployment of new .dll files to the Global Assembly Cache (GAC) in the Web Front End (WFE) servers when the customer attempted to uninstall 4.6.11 and reinstall 4.6.3 in their Staging environment.  Resolution Attempted to uninstall the assembly files manually from the GAC. When this failed, we attempted to delete the registry keys to force the uninstall. This also failed.   Next the Microsoft gacutil.exe was run to remove the assembly files from the servers where errors were reported during the deployment of K2 for SharePoint. This had to be done numerous times, as each time the K2 for SharePoint deployment was run new .dll's were reported as being unable to copy to the server.   Once all components of K2 for SharePoint were deployed, http 503 errors were now being seen on the WFE servers. An IIS reset was
Hello,  I m in K2 designer and i m using subview form . One Datalabel is fill from SMO  My problem is when text is too long the text is cut and not display. I would like that text go automaticly to a new line.. It is possible ?
I've been tasked with developing forms for our school system. I'm a newbie to both sharepoint and K2.  I'm starting out with an IT purchase order form and have most of the views/forms completed and I have begun to work on the workflow steps. As one of the final stages in the workflow my supervisor wants the person who runs the service desk to attach a file that will be emailed to the vendor we are buying the items from. This part has me stumped. I already have the premade attachments view which was autogenerated which I am using to attach bids for the initial approval step. I could have the service desk just use that for the attachment, but them I'm unsure how to pull that specific attachment in on the e-mail step. On a side note I'm also having an issue on the final step which is moving the denied/approved purchase orders to seperate denied/approved lists. The final form is comprised of 3 views: The vendor/requester info, line items, and attachments. When I use the "move list
 Symptoms When saving a form, after Save is Successful, error message is thrown. The remote server returned an error: (401) Unauthorized Diagnoses Url for move method was pointing to the on premise url. Solution moved to SharePoint online site. Resolution Reconfigured the moved method to point to proper url for SharePoint online.Â
 Symptoms  The first time the workflow run for the day and generate the PDF for SmartForms it is not created correctly. Everything is squished to the left.  Diagnoses  SmartForms is in essence an ASP Web Application and as such is affected by IIS Site settings that may recycle application pool/recycle unused worker process due to idling values/overnight recycling settings.   This will usually result in the first access of the site (either over-night/after long in-activity) to be slow and can usually be alleviate with warmup script/iis modules/settings to get the site ready prior to the first access of end-users each days: https://dotnettimes.wordpress.com/2014/03/24/fixing-slow-initial-load-for-iis-web-site/ http://www.wolfsys.net/howto-increase-iis-startup-speed-first-startup/   Some possible changes to warm-up the site prior to first access: http://stackoverflow.com/questions/13386471/fixing-slow-initial-load-for-iis   Perhaps using IIS Application Initialization module: https://www.
Hello,I am looking for suggestions on how to build something for all of our employees to read and acknowledge they have read a subset of company polices with Nintex Forms and/or Workflow 2013. It can be as simple as a check box saying that they have read it.So far, I was thinking of maybe a Nintex form with all of the policies attached. Then maybe a check box next to reach policy. But I am unsure how to attach documents to a new form. Any help would be appreciated.
Hello, I save a file in DB with K2 format ( <file><name>FileName.pdf</name><content>XXXXXXXXX</content>) I would like in K2 deisgn into a view send a email with the pdf file join to  the email. It is possible ?  Thanks in advance,
Is there a way of unlocking a workflow created by someone else? This person is on leave and an issue cropped up that requires urgent fixing. Can a server admin employee unlcok this or is it only the creator that can unlock it?
Hello, is there any way to set up some kind of confirmation page or pop up after a form has been submitted? I would normally just set up a confirmation email with Workflow, but for this particular activity I don't want to inject any workflow tasks for the end user. I just want them to submit the list item through a form and that's it. Any help would be appreciated.Thanks!William
 Symptoms ServerLog out of Sync Issue - [K2].[ServerLog].[ProcInst] Diagnoses When you have 2 process instances in the [K2].[ServerLog].[ProcInst] table, that are in a running state that should not exist. The workitems were deleted from K2 Workspace and the option to delete log data was also chosen. All data in Server and ServerLog were deleted successfully however 2 rows remain in the [K2].[ServerLog].[ProcInst] table. Can you confirm if it is safe to delete these 2 process instances from the database manually?SELECT *FROM [K2].[ServerLog].[ProcInst]where [Status] = 1 Resolution This can occur if a process instance is not deleted correctly. Please contact K2 support to obtain the script to remove this from the K2 DBÂ
 Symptoms 61007 Permanent failure sending message Request Diagnoses When the workflow is sending the emails, the recipients are not receiving the emails. You can send and receive emails via K2 Form Rules -andgt Send an Email,But if you try doing this via K2 Studio workflow and use the Smartobject -andgt AD User.GetUsersByGroup.Name and enter a group name (either by using Context Browser, Group - then choosing the Name property, or by just manually entering a group name windows/lis k2 group) it still doesn't send any emails.You do see the following error via the logs:at SourceCode.MessageBus.Ews.Destination.EwsMessageDestination.Send(String title, MessageExtendedInformation extended, IEnumerable`1 attachments, MessageBodyReader[] messageBodies)","anonymous","0.0.0.0","BlackpearlK2Dev:C:Program Files (x86)K2 blackpearlHost ServerBin","2071476","1f25253e6ef14375a28ac12db1653182","""2071477","2016-10-25 11:24:51","Error","MessageBus","61007","SendMessageException","MessageBusRuntime","6100
 Symptoms PandampD tool is taking many hours to take packages from one of our DEV environments and this is impacting multiple projects Diagnoses PandampD tool is taking many hours to take packages from one of our DEV environments and this is impacting multiple projects. You end up having to leave it running overnight and even then it is not completing. Resolution In regards to this issue their could multiple factors in place that may be impacting this. Firstly check to see if the CPU tends to spike up and down, there could be a process in a looping state. You will need to contact K2 support for scripts to stop the running instance.Furthermore you may try and increase the transaction timeout for smart objects via the sourcecode.smartobject.runtime.config file along with the command timeout to 120s.This should speed up the package and deployment time.Â
 Symptoms Unable to identify reference within a K2 Studio process Diagnoses When creating a package for a particular solution using the P andamp D tool (including dependencies) it includes some dependencies that are apparently referenced within a K2 Studio process.You want to remove these references from the process and have looked in great detail within the process to find these references but they do not seem to be available there.Will it be possible to identify where these references are ? Resolution This is down to a reference from a deleted process, that points to a table within the K2 database. Please do contact K2 support for the script to remove the references from the table.Â
 Symptoms When trying to create a package, the following error is observed:andltWorkflow Nameandgt' Process is referencing the 'andltForm Area Itemandgt' View that could not be found.The source of the error is located in the ?andltEvent Nameandgt? event. Open the workflow and re-run the wizard. Diagnoses Rerun the Event Wizard and redeployed the workflow. This had no effect.The Workflow start event wizard was also rerun with no change.The Event was also deleted and recreated, but the issue still occurred.Checked the Area and AreItem tables in the K2 Database and all the view and form references were correct.The Client Database was obtained and the issue was sent to the Labs Team for further investigation. Resolution The Labs Team confirmed that this is caused by a bug in Package andamp Deployment. A new bug item was logged for the Developers to investigate fully and fix in a future version of K2.The following Workaround was provided:In the Source Environment on the affected Workflow Ev
 Symptoms  When executing the GetDocuments method of a SMO created from the SharePoint Content Broker and entering a number with 7 digits or more into a Decimal Property, no results are returned.  Diagnoses  Executing the GetDocuments method of a SMO created from the SharePoint Content Broker and entering 6 digits or less returns the correct results. Entering 7 digits or more returns no results.  Resolution The specific scenario cannot be logged as a bug because the SharePoint Content Broker is aimed at SharePoint 2010 and not supported with SharePoint 2013.   Please see the following KB Article http://help.k2.com/kb001707 As a workaround, instead of adding the value to the property directly, use a filter with the required value.   For information on setting up K2 for SharePoint 2013, please see http://help.k2.com/product-documentation/k2-for-sharepoint/icg/4.6.11   For information in the SharePoint 2013 content broker, please see http://help.k2.com/onlinehelp/k2forsharepoint/userguide
Lately I've been noticing inconsistencies when it comes to being able to start workflows or not.I've got one case where a user should be able to start a workflow, but can't. But now I've got the opposite. A case where one user shouldn't be able to start one, but is.So we've got 2 sites.Both sites are identical in general structure.Permissions are handled through sharepoint groups.This is about a list where you start a workflow on an item and the workflow then creates a document in a library on the same site.The owners from either site should be able to create a document in their library starting from their list.Now there is a third party. Their task is to edit the documents or the list items on either side. However, they should not be able to create items or start any workflows.To do this we gave that third group of users "edit, no delete, no contribute" rights.The funny thing is...On one site people with those permissions CAN start a workflow, on the other one they can't. (interesting
I have a scenario where I need to cancel an outstanding workflow flexitask. Since it doesn't have an action ID, I can't use the Complete Workflow Task action. From some things I read on the old site, it looked like I needed to use the ProcessFlexiTaskResponse web service. So I have a workflow that get's the ID for the task I need to cancel, then calls the ProcessFlexiTaskResponse web service. Everything complete successfully, however the task is not updated or changed in anyway. I'm assuming the web service will complete the task using the criteria I've input, but maybe that's not what it does. Anyone have any experience using this web service?  Â
 Symptoms  P&D doesn't allow deploy even if all is 'green'   I have tried to re-run the registration wizard on the prod (taget) environment but no change. I've cleared the P&D cache, no change.  Diagnoses  Upon investigating the package in MMC we saw the same behavior. This issue had been seen before on other tickets and we noticed that it usually revolved around a service instance not being configured properly. We viewed all of our Service Instances and the SQL Service Instance "Master Data Management SQL Service instance" showed an error when we right clicked and selected configure.  Resolution Our SQL Service Instance "Master Data Management SQL Service instance" in this package showed an error when right clicking and selecting configure. After going into the configure screen for this service instance we saw that, although on the conflict resolving that we set it to use the existing service instance, our only two options here were to 'Overwrite Service instance' or 'Create N
 Symptoms  We need to uninstall all the K2 components from multiple environments.   Is there documentation for complete uninstall of all K2 components? You may want to see documentation which allows to make sure that uninstall is performed in the right order and removal of all the components will not impact related SharePoint environments assuming you need do uninstall the wollowing:   K2 Blackpearl K2 SmartForms K2 for SharePoint   There are documentation for K2 Blackpearl - KB000216 How to uninstall K2 blackpearl, and Smartforms - Removing K2 smartforms but you may still want to have more guidance/details.  Diagnoses  The above mentioned documentation contains all what K2 recommends for uninstalling blackpearl and smartforms. Nonetheless more specific details on how to uninstall the K2 for SharePoint Components may be required.  Resolution When uninstalling K2 components from your servers it is necessary to make sure that process perfromed in the reverse order to that which you follo
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.