Learn about the latest Nintex capabilities at New at Nintex
All archived community articles, forum posts and groups. Here you will also find older K2 brokers as well as archived Group content.
Recently active
Is it possible to have one task form that can refer to several items (IDs)?I have a list that needs to send a daily request for review for several items. Currently the user has to click each task form and select Yes or No if a date has been rescheduled. If it has a new date needs to be entered. Now the user gets one summary e-mail which is great but still has to click up to 15 links. Is there a way to have all the Yes or No and possible date fields in ONE task form?
Symptoms The client wants to know if a TestUser would need DB owner-rights in order register a service instance and have full properties as the DB owner. For example At this point when registering the SQL service in instance as a testUser the property that is an Autoguid is showing as a normal guid that needs a user to input the guid themselves, its not auto-generated. However when registering the SQL service instance as a DB owner it shows the property as AutoGuid or as an autogenerated value. Diagnoses After investigating the issue and reproduced this behavouir, we came up with the workaround below: by granting permission on view Definition on the table level, Resolution By granting permission on View Definition on the table level on the Database
Dear Experts, some of process instances are showing as running, we are unable to stopdelete the instances from the workspace.Could someone suggest how to delete from backend? RegardsAmar
i have just start using nintex mobile app, i have configure my "Nintex Mobile Phone Layout" having following issues:1) i have apply basic CSS tags of color and background color on a text box through a class which didnt apply on nintex mobile forms. (Note i have create a class in Custom Css int he settings of the form and apply it to a textbox)2) My application gone crash whenever i change the drop down value on nintex mobile forms (Note: there is a rule in my form that if the value of the drop down is equal to a specific value a panel will become visible which consist two repeating section and another panel inside it.)3) i have removed all the controls which nintex mobile app doesnt suppot as mention in this article Forms functionality supported for use with Nintex Mobile but still it gives me this warning please need your support
Hi All, I am going to implement multilingual application using K2 Smartform 4.7. I found K2 Smartforms multilingual solution here http://community.k2.com/t5/K2-blackpearl/Multilingual/ba-p/1049. It looks great. However under 4.7 release note, https://help.k2.com/kb001745. it suggested to create multiple forms for different languages. I believe this approach will be very painful if some functions is required to be updated that will require to update in all forms. Anyone has experience with Multilingual control whether it is working well in 4.7 and is there any performance effect? Appreciate your advise.
Hi I've got a workflow that has a couple of sub-workflow steps. Obviously when the sub-workflows are running the main workflow pauses until they complete and pass control back to the main workflow.One of the sub workflows failed. I've sorted out the issue but if I restart the sub-workflow will the main workflow "un-pause" and continue when this finishes, or do I need to cancel everything and restart the main workflow?ThanksSamo
Symptoms So I have a process that takes an input of a People Picker from SharePoint, copies that to a Process Data field and then assigns that Process Data field doing a Split function on it by the delimiter of a pipe to assign to the Plan Just Once slot of a Task. However, the problem is that if there is more than one person in the field, only the first person ever gets assigned. If there are 2 or 50 people, those other people don't ever get assigned the task and don't get the notification. Diagnoses When using the Plan per slot (no destinations) planning option, make sure to add a Succeeding Rule stating [ActivityDestinationInstance_Status] All = "Completed" Resolution Adding Succeeding Rule stating [ActivityDestinationInstance_Status] All = "Completed" to "Set Reviewers" activity Per this KB, http://help.k2.com/kb000685, and redeploy your process resolved the issue.
Symptoms Picker control resolving user using AD Service2 > GetUsersByGroup method will result in "Object reference not set to an instance of an object" error after upgrade to 4.7. Diagnoses This is a known issue with 4.7. Resolution Coldfix is available. Please contact K2 Support.
Symptoms Just installed k2 4.7 blackpearl and smartform in our new production environment to be and can access management site! Error message "Form 'com.K2.System.Management.Form.Management' could not be found, or is not checked in." Diagnoses Noted that k2 blackpearl and k2 smartform installed without any error or warning messages. Run query on the K2 database SELECT * FROM [K2].[Form].[Form] 'com.K2.System.Management.Form.Management' were not in the Form.Form table nor any other form that k2 installer deploy by default. "K2Sites_Management" folder in that path "C:Program Files (x86)K2 blackpearlK2 smartforms RuntimeStylesThemesPlatinum2" Resolution Make sure that Package and Deployment tool is installed on the server running k2 blackpearl and K2 Smartform setup. Run K2 Blackpearl and K2 Smartform setup using the repair option. Noted that the Management.kspx package deployment messages showed up during the repair process. Issue is resolved after successfully running the repa
Symptoms When attempting to install of 4.7, there are several errors in the Configuration Analysis. "Target did no complete successfully: Management.kspx" And several other kspx files. When attempting to open Package and Deploy, there is another error message. "Access to the path 'C:ProgramDataSourceCodeTempCQ75XSX5 4'WP1 0]{+ 'ETN[P4.models' is denied." Diagnoses Discovered that the the C:ProgramDataSourceCode did not have permisson on this folder Resolution Giving all users full access to the ProgramDataSourceCode folder resolves the issue.
Hello, I would like to know if it is possible to use a html template to customize the reply mail of K2 after answer by mail with a action keyword. Thanks in advance for your reply, Sébastien De : Envoyé : jeudi 17 novembre 2016 12:11À : Objet : RE: You successfully completed the task with the 'Validate' action.
Hi there. I am pretty new to K2, but am learning a lot as I go. The K2 "family" has been outstanding. That said, I have a question...this isn't my first Forum question, but the other one I managed to figure out, so I deleted it before anyone answered. I have a rule something like this: My question is that I'd ultimately like to have a message box come back to the user saying, "XX Files Assigned" (with the XX representing the # of rows that were selected). In addition, I'd love to have a data field that would update with the # of rows selected right on the form when the user selects multiple rows. Bascially looking for some kind of return value that represents the # of items selected on a multiple select list view. I can't seem to find the ability to do this. Any thoughts? I pretty much am limited to SmartForms out of the box technology. I'm not techy enough to write custom code or even stored procedures. Thanks, Rob
Has anyone else had the experience where you are working on your forms in the sharepoint for blackpearl designer and suddenly you can't click to configure actions? You have a "then show a message to the user (configure)"You can't click configure Or you have a confirmation message like "are you sure you woul like to cancel the wizard and losa any unasved information? "and only the No is clickable. This is so frustrating because I have to close the browser and come all the way back in. Any ideas?
Symptoms Last week I was able to view the workflow process of an item from SharePoint. When I tried today with a few different users, none of us were able to see the Workflow Process from the K2 Workflows screen from within SharePoint. There is a box that says "View Flow" but there is nothing underneath it. There used to be an image that you could select to then view a graphical representation of the workflow and where the process was or where errors occurred. I have attached an image of the screen I now see. I was able to view the process by extracting the URL from the source code of the page and going that way, however, that is just a temporary solution. Ideally i would like the image to show up again or to know why it has disappeared. Diagnoses Somehow the image file for that View Flow icon was removed from the WebResources/CSS Bundle. Resolution Clearing the control cache seemed to resolve the issue. Clear the control cache by using the K2 Designer URL and place this on the en
I've created a task. I want to have Approve, Reject, Redirect, Delegate as my actions.I see how to put them as choices, however, I want to use the OOB Redirect and Delegate. The email that is generated has this line:You may also do one of the standard actions:RedirectDelegateSleepSo, how do I access those "standard actions" from within the form that I"m using for the task.
We have a SharePoint 2013 / Nintex Workflow 2013 workflow that we have been using for over a year. There are several steps where we send notifications to a Group email address, with "Send individually addressed notifications" checked.Over the past few days we have been receiving workflow error messages on a particular step that does this. It is actually the second send notification to the same group. The first notification does not give an error. When I look at the detail, I see this message: Failed to send notification. Cannot get the full name or e-mail address of user "c:0+.w|s-1-5-21-2107199734-1188698053-504519907-87171".I don't know why the Send Notification step is putting that odd email address into the To and From, when for the other send notification steps, it shows the expected group name. I tried to create a new Send Notification, selecting the group from the Select People and Groups - Webpage Dialog, and while it appears to be correct when I save the action, if I cli
Symptoms I created a "List" SmartObject based on a SQL stored proc. When i test the smartobject on the K2 server using the SmartObject Service Tester the values returned are correct.I think created a list item view in SmartForms to display the values and they are all multiplied by 1000000000. Bizarre.The language settings of the server appear to match those of my local machine, EN-US. Diagnoses This type of issue could appears if the K2 Service account have a regional setting setup with comma instead of . for the decimal separator or if the web.config have the parameter ExecutionCulture set to EN-GB. Resolution Verify that the Service K2 account has for regional setting parameter (in "Change date, time and number format", click on "Additionl settings ..."). (Dot) as the decimal separator. More generally that it is in a US format.In order to do this check, you must log on to the K2 server with the Service K2 account.And check the value of the "SmartObject.ExecutionCulture" key in the f
Symptoms I would like to use synonym to respond via e-mail, with several actions:TO APPROVE: Use one of the following:YES / OUI / OK / Validate / Approve / GOTO REJECT: Use one of the following:NO / NON / KO / Reject / Refuse /NOGOI try this http://help.k2.com/onlinehelp/k2blackpearl/icg/current/default.htm#Configure/IntCon_SA_Synonyms.htm but this does not workI change the file K2HostServer.exe.config with from thisandlt!-- Common configured actions and allowable alternatives --andgtandlt!--andltaction value="approve"andgtandlt/actionandgtandltaction value="decline"andgtandlt/actionandgtandlt/actionsConfiguredandgt--andgttoandlt!-- Common configured actions and allowable alternatives --andgtandltaction value="approve"andgtandltsynonym value="approved"andgtandlt/synonymandgtandltsynonym value="YES"andgtandlt/synonymandgtandltsynonym value="OUI"andgtandlt/synonymandgtandltsynonym value="OK"andgtandlt/synonymandgtandltsynonym value="Validate"andgtandlt/synonymandgtandltsynonym value="Ap
Symptoms Error during "K2 for SharePoint - App Deployment" when we "Specify a K2 URL":Error: Endpoint cannot be reached:http://{ServerName}/autodiscover/api/metadatadocument/testEnsure that the port is opened and you can browse to the endpoint from this location Diagnoses When we try to access to the url:http://{ServerName}/autodiscover/api/metadatadocument/testWe are not able to download the file. If it's work, we should able to download a json file.In event viewer, after put in place the Audit Failure (https://technet.microsoft.com/en-us/library/cc787567(v=ws.10).aspx) on directory C:ProgramDataMicrosoftCryptoRSAMachineKeys, we saw the following message:2025 Error MarshallingSourceCode.Security.UserCertificateManagementServer.GetK2SigningCertificate, Access Denied....Cryptographic Operation:Operation: Open Key.Returned Code: 0x80090016This type of message should appears if K2 SmartForms has not been installed with the K2 Service account. In the case of the customer, it was a specifi
Hi Folks, I have SharePoint Online environment with Nintex Enterprise edition andBusiness Requirement: One of the customers has a business requirement when a workflow is a triggered and an email on a specific day (mid of month). Workflow should also triggers two days before last working day for monthly report. Research: I found from community that somebody used "Calculate Date" method as shown:However, I tried the same action on Office 365, I was not able to find this “Calculate Date” action:There are following the date functions available on Office 365: Add time to Date. Find Intervals Between DatesPause until Date. Set Time Portion of Date/Time Field. How could I achieve the workflow using Office 365 date function as used above? Can advise anyone which date function used to meet the requirements?Thank you. Cheers, --Sandy
I have a task list where multiple tasks are grouped by project Id and assigned to a user. When I reassign the tasks I have a workflow that sends out an email. The issue is I will update assignment on all tasks for a project and then multiple emails go out as workflow is triggered based on when assignment is changed. Any ideas how 10-20 tasks being reassigned from user a to user b can send out only one email to user b?
Hello,I am trying to figure out the best way to get the link to the Edit form of an item that is in a SharePoint 2013 custom list item.I need to include this link, to the edit form in the custom list, in an email in the workflow that I have created, that goes to the initiator of the item in the custom list when the approver is asking for more information about the item that they are being asked to approve.Hopefully someone can help out.Thanks
Any ideas why this may occur?
Symptoms Using K2 connect for SAP 4.6.11 it was found that when assigning the property to an XML field, you are requested to specify the part of the XML document you want to return. When selecting "connect", which is the top level node listed, the values returned do not contain the andltconnectandgt and andlt/connectandgt tags. If it is then attempted to deserialise the XML (using another SmartObject method built in Visual Studio) we get "Object reference not set to an instance of an object" Diagnoses Reviewing the K2 Connect SmartObjects it was found that the issue is related to the Method type used when setting up the SmartObject Method. Resolution If the SmartObject Method is configured with a Type ? Read, the andltconnectandgt tags are not returned as part of the XML Data when the SmartObject is executed.If the SmartObject Method is configured with a Type ? List, the andltconnectandgt tags are returned as part of the XML Data when the SmartObject is executed.It was confirmed that
Symptoms After copying a SharePoint list from Testing to Production environment using 3rd Party application and deploying a K2 Package with the related SmartForms and Smartobject, the following error is displayed when executing the SMO in Tester Tool: ?Input string was not in a correct format? Diagnoses - Created a new SharePoint Content Service Instance for the Production Environment and generated a new SMO for the list. Same issue occurred on execution.- Migrated the List from Testing to Production environment using SharePoint Template file (.stp) and generated SMO against the new list. SMO executed successfully.- On the affected List Settings, changed the Column type from Currency to Number. Republished the SMO with the same Name and GUID. SMO executed successfully.- On the affected List Settings, changed the Column type from Number back to Currency. Republished the SMO with the same Name and GUID. SMO executed successfully. Resolution Suspect something changed in the definitions o
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.