Learn about the latest Nintex capabilities at New at Nintex
All archived community articles, forum posts and groups. Here you will also find older K2 brokers as well as archived Group content.
Recently active
 Symptoms  Error during upgrade to K2 blackpearl 4.7  Diagnoses  We are getting following errors when upgrading K2 blackperal from 4.6.11 to 4.7. 14:30: ControlUtil.InvokeControlUtil: 14:45:41:andgtandgt Logged Error: Error from controlutil output: RegisterControlTypes Failed: Invalid archive type System.Exception: Invalid archive type at SourceCode.Hosting.Client.BaseAPI.BaseAPIConnection.RemoteCall(String TypeName, String MethodName, Object[] Parameters, Boolean[] NullList, MarshalMessageType CallType) at SourceCode.Hosting.Client.BaseAPI.BaseAPI.RemoteSessionCall(String TypeName, String MethodName, Object[] Parameters, Boolean[] NullList) at SourceCode.Forms.Management.FormsManager.DoSessionCall(String method, Object[] parameters, Boolean[] nullList) at SourceCode.Forms.Management.FormsManager.GetControlTypesInternal() at SourceCode.Forms.Management.FormsManager.GetControlTypes() at SourceCode.Forms.Controls.Web.SDK.Installer.Program.RegisterControlTypes(String assemblyPath, List`1
Hello, I have a scenario where the users would like to have many fields in a view and then be able to scroll left/right.The way I have it now is all necessary fields fit the page but they would like more fields added. The problem I am finding is that if adding another column it shrinks existing columns to fit on the page.  Is there a way to add scroll bars for horizontal scrolling?  Thanks.
Currently we can attach images to the Send Notification action and it works great. If the images are stored locally, how can we design the action so that people outside of the network can see the images so that the email can be branded with our logo? So to clarify, we don't simply want an attachment, but rather have our company logo viewable in the email message to external partners. Thanks
Hi,I've got a 3 separate lists that update a 4th stock list. All of the workflows update the stock list by performing a lookup on a text string in the list.My issue is that when combining variables, sometimes a space isn't actually a space. If you look at the text and string values, they look identical. The only way I finally figured out what the differences were, was to paste the strings into MS Word and turn on the special character mapping. Have a look at the attached image.The first line is what is displayed in SharePoint, Notepad and so on. The second line is if I open the developer tools and copy the text out of the source code.All variables are formated as text strings, all the related columns are text strings, everything is text. I build the variables by either setting a variable to a column value, then a space, a hyphen and a space, and then a second column.This is where it randomly puts a space in which corresponds to the 'degree' symbol in the screenshot. If I build the stri
Hi,I'm working on a Workflow for the HR department. The emails send from Workflow should be encrypted. Is it possible and how?thanks!cheerspascal
We are using a Nintex Workflow to update a managed metadata field in a document library. We can not use the TaxonomyHiddenList because the metadata values aren't tagged somewhere yet. What we need to update the field value is the Term_Label|GUID. For the term below that would be OPG Voorl VS goedgekeurd|628f0e36-e559-4e67-bbda-3b549dd943cc.Problem is that this GUID is different between farms. So here my questions:Is it possible to retrieve the GUID from the term store on the farm the workflow is used?Can you read the possible values that can be chosen in a managed metadata field in a list? When possible, I get them back as Term_Label|GUID and can set them in the managed metadata field.
 Symptoms Dears,We are facing an image issue in the notification email sent in our workflow the source for the image is provided through a data field as per the attached images and this field is configured in the Environment fields, However the image never appears in the email.Appreciate your help.Thanks, Diagnoses Customer used exchange 2007.my last response was :"Will you please have a look at this issue in outlook 2007.https://www.sitepoint.com/microsoft-breaks-html-email-rendering-in-outlook/" Resolution Customer used exchange 2007.my last response was :"Will you please have a look at this issue in outlook 2007.https://www.sitepoint.com/microsoft-breaks-html-email-rendering-in-outlook/"Â
 Symptoms Unable to Execute SharePoint registration wizard due to infinite spinner. Diagnoses When we are attempting to run the K2 SharePoint app registration wizard from within the SP app catalogue Script errors are present in browser debug tools. Resolution Changing the following in the Designer and runtime web.config resolved the issue:andltadd key="UseBundledFiles" value="false" /andgtandltadd key="Forms.PostRenderCombining.Enabled" value="false" /andgtÂ
 I am getting a javasript error, while trying to setup a new development environment. This appears in the browser console when I try to open the K2 app.It gets stuck at the "Working on it..." screen. Uncaught Error: Sys.ParameterCountException: Parameter count mismatch. and also init.js:1 Uncaught RangeError: Maximum call stack size exceeded In the ULS Logs we can see: 11/23/2016 16:46:26.19 w3wp.exe (0x068C) 0x08F8 SharePoint Foundation Claims Authentication amcbl Medium Trusted provider is missing. Provider: '00000003-0000-0ff1-ce00-000000000000' ab40ba9d-3e50-2048-6cac-8c6b253b6e7c  Version:4.16060.2000.1
I have created a form with tabs at the top to separate the form into sections. I used the Choice Control and created a panel for each section. I then added rule to each panel. So far so good, tabs worked as I wanted them to. I only have an issue when I open an item in SharePoint i.e. View Properties. I want it to show the first tab Employee Details but instead it defaults to last tab Treatment & Investigation.Does anybody know how to do this please?
 Symptoms a) sometimes K2 throws error like: "An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full".b) our applications sometimes throw errors like "LDAP server not available" with stack trace pointing to Sourcecode librariesSee screenshot B1 in documentc) users group membership is randomly dissapearing from Identity table - e.g. "domain users" group is sometimes lacking some users this ends up with errors like "xxx user doesn't have permissions to start proces yyy" (we use domain users for "start" permission on a proces)d)update - in the file i've uploaded i see 6556 connections to SQL server (172.16.232.26) with TIME_WAIT status... how we can get rid of these? Diagnoses The client identified issue A and B as infrastructure issues our infrastructure regarding a) and b) from my ticket.Issue C is being handled on the ticket 118805.Provided the below information for the "Time Wait" issue:I have put together some sug
Hi All, I am busy doing a new install for a client and require some input from the community. We are installing K2 4.7 and the infrastructure of the client is a little complex. I have never done a configuration for Office 365 Online exchange so I have no idea what the EWS URL looks like.  So currently I am stuck with the following:Google has revealed that the EWS URL looks the same for all Office 365 Online exchange environments: https://outlook.office365.com/EWS/echange.asmxTrying to Discover the URL doesn't work and only returns with a error stating that the EWS URL could not be discovered.Manually entering the the URL and testing against it makes the installer hang. Has anybody dealt with a situation like this. Any help will be greatly appreciated. Kind regards, Highveld Support.
This is annoying man... I have a form with some text boxes on. For example, text box 1 can take upto 90 characters. I then use the SAVE as PDF control and when the PDF is rendered, it only shows 47 characters in the PDF... Why is that? Whats the point of having a convert to PDF control if it doesn't capture the screen as it is displayed? Any way round this as it's doing my head in
 Symptoms  Unable to login using K2 Mobile app on Android: Username or password incorrect  Diagnoses  K2 Mobile app doesn?t support non-standard ports on Android (standard: HTTP-80, HTTPS-443). The environment was configured to HTTP on port 81.  Resolution This is slated to be fixed on the next version of the K2 Mobile app for Android As a workaround, reconfigure K2 site(s) to follow the standard ports depending on the protocol.    Â
Hi all,I have a situation where I have a flexi task that has a group as the assignee. The flexi task also has reminder emails send to the assignees. However, the business has asked if the reminder emails can be sent to the requestor and the assignees cc'd in the reminder email.As far as I can tell this cannot be done in a flex-task or other workflow action. Does anyone know of another way to send the reminder emails to recipients other than the assignees?
Hi All, I would like to set Vertical and Horizontal Scroll bar in View. is there any way to implement this?  Thanks with advance,JD
 Symptoms  Users unable to approve items as they are not appearing in tasks not seeing user names when trying to add them to roles from Active Directory  Diagnoses  When you have just found out that the User Roles on K2 don?t return any of the users when queried, this effects one of the processes. If the UM user smart object is executed, you are not able to see the results as it stays loading for a long time. Furthermore looking at the logs you can see consistent "UmemptyQueue" throw errors all over the host server logs and this tends to repeat itself consistently. When looking for the user via K2 workspace, you get the return value "System.Byte".  Resolution This error normally boils down to bad domain configuration, especially when trying to add another domain to the current environment. You can follow the documentation below on how to do this:   http://help.k2.com/onlinehelp/k2blackpearl/icg/4.6.11/webframe.html#after_addingmultipledomains.html http://help.k2.com/onlinehelp/k2blackp
I have a list lookup in a form which returns a person field with multiple selections. There is only one field returned, and it is displayed like this: User Name1;User Name2;User Name3; ... etc.Is there a way to make the users display in a drop down:User Name1User Name2User Name3so I can pick one member from the field?
this control uses the Google Visualization API to display charts. follow the link to see examples on what can be created https://developers.google.com/chart/interactive/docs/gallery Please make sure you consent to the terms and conditions at https://developers.google.com/chart/terms V 1.2 - Changes made to work with k2 smartforms 1.0.2 V 1.1 of the control fixes an issue K2 smartforms V1.1 where additional textbox is displayed.
Hey guys,I'm trying to clear individual rows in a Repeating section, but the event doesn't seem to trigger if there is only one row...E.g.1) first row            X2) second row      XIt works OK if I try to delete either of these two rows.But then if I try it again on this:1) first and only row      Xthe event is NOT triggered!Any idea why? is it a bug or a feature??Here's the function I'm using to test this hypothesis:NWF.FormFiller.Events.RegisterRepeaterRowDeleting(function() {   console.log('here');})
Hi everybody,I'm trying to enable/disable a lookup control through Javascript, this code works on text and choice controls://Option 1NWF$("#"+controlID).attr('disabled','disabled');NWF$("#"+controlID).removeAttr('disabled');//Option 2NWF$("#"+controlID).prop("disabled", true);NWF$("#"+controlID).prop("disabled", false);However, the code I posted above doesn't work on lookups.Do you have any idea?I'd also like to know how to check/uncheck a checkbox, I use the following code:NWF$("#"+myCheckID]).prop('checked', true);NWF$("#"+myCheckID]).prop('checked', false);The checkbox is checked/unchecked, but the value doesn't change.I connect the checbox to a calculated control, and the value is always the same (true/false), no matter if the checkbox is checked/unchecked.I work with Nintex Forms 2013 2.9.3.1.Thanks in advance.
We have broken up a large workflow into several smaller workflows. We have one parent workflow that calls child workflows. We use the Nintex Start Workflow action to start the child workflows. For one of the calls we have the option "Wait for the workflow to complete before continuing" enabled. For the last few months this has been working as expected. Recently the parent workflow stalls on the Start Workflow action. The parent workflow calls the child workflow successfully, the child workflow completes successfully, but the parent workflow does not register the child workflow has completed. The OWSTIMER service is running as expected and there are no errors in the workflow history/ SharePoint logs. Any ideas?
Hello Everybody,Is it possible to access User Profile properties from inside NINTEX form using RESTAPI other than using USER Profile component inside workflow? I found there is a endpoint to access Current logged in user's profile properties like Department, LastName etc etc. But is not working from inside NINTEX form...some permission related issue. I also tried to configure the NINTEX Form app to get access of that RESTAPI endpoints but still it's not working.Please let me know if anyone of you have any workaround to call REST API inside from a Form. Remember the requirement is to call REST API inside from NINTEX FORM but not by using workflow component.Thanks,Mani.
Hi everyone i have a little problem that when I try to load the form from the worklist the worklist always pass the parameter with value =0 the link will be as belowhttp://k2/Runtime/Runtime/Form/EdittingMangerApproval/?_State=&Editting_PK=0&SerialNo=12345the Editting_PK=0 should conten the parameter not 0 also when i change the Editting_PK=0 to be Editting_PK=15http://k2/Runtime/Runtime/Form/EdittingMangerApproval/?_State=&Editting_PK=15&SerialNo=12345the data will be loaded so how can i fix this problemÂ
 Hi, Where can I check service accounts that are used in existing K2 ? It is version 4.6.9 which includes K2 Workflow and K2 Smartforms. I found that below link indicate required service accounts.  I am not sure where I can find the existing service account setting in K2.http://help.k2.com/onlinehelp/k2blackpearl/icg/4.6.5/webframe.html#Before_ServiceAccounts.html
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.