Solution showcase: Learn how to use Nintex CE Platform
Connect with peers and experts to ask questions, share insights, and find solutions for Nintex products.
Recently active
My colleague has been having issues with submitting a process for approvals. She has been getting error messages like “Bad Request” or “Contact Nintex support or ProMaster’. She has tried everything and still the issue exists. Can anyone help with this?Kind Regards,
Hello!I'm new to nintex workflows and trying to get some automation in my workflow on sharepoint. In the workflow settings I want to start a workflow only if a certain column equals today. Can I use any function in the start workflow if settings?If not is there a good workaround? Thanks in advance! Richard
Is it possible to access process maps in Process Manager from Microsoft Copilot. The use case would be for a team to ask a question of Copilot, and the answer is provided by a process map. We would answer with a link to the process map.Our backup plan is to export the process maps to PDFs which is manual and could become outdated. Thanks
I have a Process that needs to be archived and it has some Risk Treatment dependencies.From what I've read, I need to remove the Risk Treatment dependencies, submit the changes for approval and then I can archive once approved? But... I can't figure out how to remove the Risk TreatmentsIf someone has advice on how to do this it would be greatly appreciated
HiI need to count the number of attachments in an incoming email and get the number as a variable.I tried save them in a folder but could’nt find a way to count that too…Any ideas?
Issue DescriptionWhen you set up OAuth authentication for integration with the service via the JSSP Broker, Nintex Automation K2 does not refresh the existing Snowflake access token but instead tries to obtain a new one.ResolutionThe fix is available in:Nintex Automation K2 (5.8.1) Fix Pack 05.Ensure you have the correct K2 version and/or Cumulative update installed. See KB001893 to see what Fix Pack level you have installed. Download the latest Fix Pack using the links in the table above for the version you require. Install the Fix Pack to apply the fix.
Issue DescriptionWhen you use SmartActions with Outlook on an Apple MacBook and specify a valid Workflow action, an error occurs.Error Message:The following error occurs: “The K2 server was unable to action the workflow task”ResolutionThe fix is available in:Nintex Automation K2 (5.8.1) Fix Pack 05. Nintex Automation K2 (5.8) Fix Pack 21.Ensure you have the correct K2 version and/or Cumulative update installed. See KB001893 to see what Fix Pack level you have installed. Download the latest Fix Pack using the links in the table above for the version you require. Install the Fix Pack to apply the fix. It is recommended to clear browser cache and refresh the page.
Issue DescriptionWhen you have a SharePoint list with a "Multiple Lines of Text" field storing JSON data, parts of the data or JSON tags may be truncated when executing the List SmartObject getlist method (in both the tester tool and Management), resulting in the data not being returned exactly as it is stored in SharePoint.ResolutionThe fix is available in:Nintex Automation K2 (5.8.1) Fix Pack 05. Nintex Automation K2 (5.8) Fix Pack 21.Ensure you have the correct K2 version and/or Cumulative update installed. See KB001893 to see what Fix Pack level you have installed. Download the latest Fix Pack using the links in the table above for the version you require. Install the Fix Pack to apply the fix.ConsiderationsYou need to:Edit the SourceCode.SmartObjects.Services.SharePoint.dll.config (Service Broker) and change <add key="RemoveSPNoteXMLWrapper" value="false" />
Issue DescriptionWhen you load a Form, disconnect from the network, and then perform an action that triggers a callback to the K2 Server, an error occursError Message:The following error occurs: “Undefined Error”ResolutionThe fix is available in:Nintex Automation K2 (5.8.1) Fix Pack 05. Nintex Automation K2 (5.8) Fix Pack 21.Ensure you have the correct K2 version and/or Cumulative update installed. See KB001893 to see what Fix Pack level you have installed. Download the latest Fix Pack using the links in the table above for the version you require. Install the Fix Pack to apply the fix. It is recommended to clear browser cache and refresh the page.
Issue DescriptionWhen you use the Worklist Control, it may occasionally stop functioning during a search for a specific item, resulting in no results being displayed and both the ‘Load 20 more’ and ‘Search More’ buttons appearing.ResolutionThe fix is available in:Nintex Automation K2 (5.8.1) Fix Pack 05. Nintex Automation K2 (5.8) Fix Pack 21.Ensure you have the correct K2 version and/or Cumulative update installed. See KB001893 to see what Fix Pack level you have installed. Download the latest Fix Pack using the links in the table above for the version you require. Install the Fix Pack to apply the fix. It is recommended to clear browser cache and refresh the page.
Hey all,I have a table in SFX (Edinburgh Update 3 (16.4.5.0) V2) with a drawer on the rows. The drawer contains a calendar component with a number of sources. The before load action on the drawer sets and query’s all the models used as sources and then opens the drawer. In the console I can see that all the data query’s and loads correctly, however the calendar component simply doesn't render. the drawer icon turns and I get a little sliver of space where the drawer should be, but no calendar. Any help would be great, thanks!
Need the web.config entry that fixes Zero-day patch
Uploading Files to Azure Blob Storage via Azure Function from Nintex Workflows While our awesome product team is working on a native capability to upload a file into Nintex Data. In some business automation scenarios, you may need to store files from into Azure Blob Storage. This article explains how to achieve that using an Azure Function with an HTTP trigger and calling it from Nintex as an external web service. Solution OverviewWe will:Create an Azure Function App with an HTTP trigger to receive a Base64-encoded file and store it in Azure Blob Storage. From Nintex, call this function as a web service, passing the filename, base64 and content. The Azure Function will return a SAS URI (secure access link) of the uploaded file.PrerequisitesBefore proceeding, ensure the following are in place:An Azure Subscription – with access to:Azure Blob Storage (Storage Account):This is where all the files will be uploaded.Steps:Go to the Azure Portal. Search for “Storage accounts” and click + Crea
Got a call from a user that there were a bunch of issues with some workflows. Turns out that the access token used in one of the connections in the workflow had expired and needed to re-authenticate. OK --- Easy fix to re-authenticate and get the workflows to start working again. BUTHaving workflows fail for this reason is NOT acceptable. I’m looking for a solution to be proactively notified BEFORE a workflow failure happens that a connection has an expired token. This way I can assume 100% uptime in my workflow by renewing the access token BEFORE there is a workflow failure.The connections screen in NWC only shows the date the connection was created. No where is the expiration date documented. So how is a Nintex admin to know when these things expire?Currently the only solution is to wait for a failure (and some angry customers) and then reactively address it by re-authenticating.This seems like a huge design flaw in this product that should be addressed by the dev team.
Anyone else having issues with SharePoint Online actions this morning? We’ve had workflows in place for years that are suddenly failing this morning with SharePoint Online actions. No changes to authentication, and the lists/files that the actions are supposed to pull are still there. The the “Query A List” action, I can create a new action, successfully retrieve a set of lists in our SharePoint Online, but I’m unable to define any fields in that list to sort or filter by. So it’s at least partially working, which would tell me it’s probably not an authentication issue. I’ve made a case with support, but I’m just trying to get a feel for if anyone else is having problems. Thanks!
Hi Community,I want to integrate Box.com with Nintex K2 (K2 Five) to allow file upload, download, and folder listing via SmartForms or workflows.I’m starting from zero and would really appreciate a step-by-step guide or best practices for: Setting up OAuth2 with Box Connecting Box API to K2 (via REST or other method) Creating SmartObjects to interact with Box files/folders If anyone has done this before, please share your approach or example.Thanks in advance!
We are happy to announce the release of System Manager v1.2.0. With lots of improvements, this release makes upgrading Nintex RPA to the latest version a much better experience. Release note.System Manager v1.2.0 comes as part of a minor release of Nintex RPA - v24.4.4.0. Release note.Available for download from Customer Central.
I am trying to go through and making an inventory list via sharepoint. The main key part that I am missing is that the user will put the name of the product in a form and range of numbers and I need to the product to separate into each individual lines into a sharepoint list. So for example product name: Purse, Quantity: 50. Start number: 1 End number 50 Sharepoint list will look like this: Purse #1, Purse #2, Purse #3 through Purse #50.
Hi Nintex Community,I’m working on a workflow in Nintex Automation Cloud that starts with an item creation in a SharePoint list and involves an approval process. Our goal is for the assigned approver to engage in discussions with the team (in CC) before making a decision. Ideally, the approver would use the initial email to access the Task Form, participate in discussions, and then return to the first email to approve or reject the task.Currently, I’m avoiding sending the usual task approval email by leaving the Assigned Task email blank in the Assign a Task to Multiple Users action. Instead, I'm attempting to include the Task Form URL in a Send an Email action for initial communication. However, I haven’t been able to successfully pass the Task Form URL to the email.Has anyone successfully implemented this, or is there an alternative approach to achieve this functionality? I’d appreciate any guidance or insights on making the Task Form URL available in the email so the approver can bo
I have a Start Form and the first few fields are “First Name”, “Last Name”, “Email” and “Phone Number”. Once these are entered, I basically want a timer to start and if the user hasn’t submitted the form within 2 hours, I want to send an email reminder to them to complete it. After that, I’d also want to trigger another one after 30 days. Is there a way to accomplish this without the user ever actually submitting the start form?
Hi all, We’ve used AI to translate forms into other languages since Nov 2023. It has been a game changer for organisations that have a wide community of users. However, what happens if the person submits their answers in another language? Well, that’s very easy using our new AI language actions. First we want to detect what language they were using and we have two options for that. We could see which language they translated their form into by accessing either of the form variables Language name or Language code. That makes the assumption they switched their form to a different language and also answered in that language which might not always be the case. Maybe they switched their form to French but still answered in English. So the more robust way of checking is to interrogate one of their answers using the new AI detect language action. In my example, I have an enquiry form and one of the fields is called “What is your enquiry”. I pass the value of that field to the detect la
I receive the following message when I access one of the important SharePoints: I don’t know who owns this SharePoint and I do not have access to the owners list to ask if this SharePoint will continue to be accessible to me and all other IOL and third party users. Is there something each user needs to do to be able to access this SharePoint during the migration process?
Why does the Nintex Workflow Schedular timer job keep getting removed from my SharePoint SE farm? It seems that after evey install of the monthly SharePoint SE CU, the Nintex Workflow Schedular timer job is no longer in the list of farm timer jobs. I have to run the command “NWAdmin.exe -o InstallTimerJob -job ScheduledWorkflows -url https://someurl.com” for each web app for it to appear in the timer job list. Why am I having to add it back to the environment every month or every so often? When is this job initially created by Nintex? Why does it keep dissappearing?
After installing Nintex Workflow for SharePoint SE, The Nintex workflow and forms timers jobs are not displayed in the Job Definitions page in Central Admin. The only timer job displayed is the Nintex Forms Purge Job. The Nintex dbs are connected, web applications activated, action settings are set, Nintex forms feature activated on all web applications, Nintex workflow is enabled on the sites. I initially installed version 6.0.7.10 and then upgraded to 6.0.9.0 with the same results. The workflows do run but timer jobs are missing. Any assistance/guidance would be greatly appreciated.
In a NWC Workflow, I am using the "Get members of a SharePoint group" action.My selected Connection is a "SharePoint Online: List and libraries connection" and I am a site collection administrator and member of the owner group of the chosen site. The connection has been established with the same user.If I click on "Retrieve groups", I get an 403 What could cause such an permission issue?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.