Learn about the latest Nintex capabilities at New at Nintex
Access resources, discussions, and tips to design and manage workflows with Nintex Automation K2.
Recently active
Hi AllI am unable to update user properties with DynamicADSO. I receive an error below. All other read and getuser method seems to work fine without any issues.  Can someone please assist? @hoshy @OlivierC  ThanksÂ
I have a workflow (K2 Five 5.3 with FixPack 03). I have an application where user can start a K2 workflow). After applying the Fix Pack, I see this error"The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel."We verify that K2 server allows TLS1.2Here is my code var URL = "https://s....";HttpWebRequest request = WebRequest.Create(URL) as HttpWebRequest;ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12 | SecurityProtocolType.Tls | (SecurityProtocolType)768 | (SecurityProtocolType)3072;ServicePointManager.Expect100Continue = true;ServicePointManager.DefaultConnectionLimit = 9999;// get responsevar response = request.GetResponse();....Thanks in advance.
K2 Five 5.2 Designer We are currently in the midle of building a very complex workflow with several steps. After many successfull deployments, we are now getting this error which prevents deployment. The error message, as always, is quite opaque. Any ideas on what the issue is? What is systemName and why is it null? How can we correct?Â
Hi, i created and deployed custom control with one property MaxValue. <Prop ID="MaxValue" friendlyname="MaxValue" type="string" category="Detail" refreshdisplay="true" mappable="true"><Value>100</Value></Prop> how can i update that value from javascript so that after updating i can see that value from any k2 rule.  i have setproperty function in js but its not working. (after updating showing old value in k2 rule) setProperty: function (objInfo) {//console.log(objInfo);if (objInfo.property == "Style") {CustomControls.Guage.setStyles(null, objInfo.Value, $('#' + objInfo.CurrentControlID));}},Â
At runtime, I need to be able to check if a process instance is active with a specific folio (not necessarily assigned to the current user). At minimum, a true/false response is enough. Is there a way I can query for this in an efficient manner using system smartobjects? Â Note: Calling a list method to return all process instances for a workflow and filtering is not an option since this specific workflow would have thousands of active instances and filtering on the result set is very inefficient.
Hello,I'm trying to implement a "Get confirmation from user" action on a static drop-down list populated with three static values (empty value allowed). Whenever the user changes the DDL value, a confirmation message dialog shows to the user with "Ok" or "Cancel" options. When the user validates, everything works fine, but the issue is when I hit "Cancel". As the message dialog shows on "When View Control is Changed" event, the new value is set behind the message even before hitting "Ok", so even if I decide to hit "Cancel", it doesn't go back and keep the initial value, but it instead keeps the new one. Has anyone faced this problem? Any help would be appreciated 🙂  Thank you, Amine
It is currently a brand new non-domain installation of K2 Five 5.5.When K2 Five 5.5 was installed to the "App Framework Core.kspx" progress, an error occurred, which prevented the installation from continuing.From the error log, it seems to be related to session authentication, but it is not an error at the beginning.Try to implement other related solutions, but did not succeed:KB002419https://community.nintex.com/t5/Technical-Issues/Known-Issue-App-Framework-package-fails-during-upgrade/ta-p/123937KBT146714https://community.nintex.com/t5/How-To/quot-Authentication-Required-for-Session-quot-error-appears-on-P/ta-p/125090I tried to manually install "App Framework Core.kspx" using a different connection string or a different Windows account, and the errors I got are as follows:(Execute K2 Package and Deployment tool deployment on other computers, and get the same error)Runas local Administrator:D:K2K2 Five (5.5) (5.0006.1000.0)Installation>DeployPackage "D:Program FilesK2\SetupApp Fra
We have various forms with list views.we have dynamic queries to return items in the list with a specific sort order.we have an issue when the items are answered/responded to, and the title on the column heading is clicked (to sort) whether it being deliberate or accidently the items sort.Pre Sorted - the items are in specific order So question is, how do i stop the list from being sorted upon clicking of the header in the column on the list top row?
Hi, i downloaded nintex example code for custom control and deployed/register at our server with the below command.controlutil.exe register -assembly:"dll path here" after that i am unable to open designer/management of k2. below error showingServer ErrorCould not load file or assembly 'K2Documentation.Samples.Extensions.SmartForms.CustomControl.ExampleControls' or one of its dependencies. The system cannot find the file specified. i also deregister that control. but still same error showing. i cannot do anything. restated iis and k2 service as well. but still the same.Please help how can i restore my environment. Regards,
hello , after upgrade our environment from 5.5 to 5.6 cannot assign task to Role because workflow add "k2:sps2013" to Role name instead of assign task to users in the Roles.please check the below images .Â
with .net core 2.1 end of live date of later this year, will the k2 5 requirement of having 2.1.7 installed be changed to .net 5? Will updating .net core to 5 on a k2 blackpearl server break K2?
Hello everyone,We have K2 Five (5.4) FP40. For some time we have problem with loading process details in K2 Management. Spinner just keeps on going and there is no info loaded in tabs: Instances, rights, roles, versions. This error is on every workflow. Does anyone know how to fix this?Â
hello,i need to return BathcableActions related to the task so i enabled workflow Rest API and using GetTaskActions but i need the result deserialize please check the below image :Â
Hi, Â how can i create/deploy custom control for k2 smartforms. any tutorial or supporting link will be helpful. Â Thanks & Regards,
Hi, Is there any backend way to force check-in/Close Workflows, Views and Forms.
Hi all, I'm in need of an expression that will force the first letter of a text box contents to uppercase. I've attempted this using different combinations of Left and To Upper operators but can't quite get it to function correctly. For example, if a user types 'uppercase', I would want it to change automatically to 'Uppercase'. Thanks,Jordan
Hi,Is there a way to do Go To Activity for multiple instances on K2 Management? I'm trying to end some instances that were initiated 5 - 6 years ago Kindly assist with this
Hello,i need to import custom JavaScript & Style in order to drag drop image to pdf .my custom code work correctly please check index.zip file that contain original source code . so I created 3 datalabel and I put my code inside datalabel (style ,html code ,scripts) but when run the form no errors appear in console and (custom code also not appear ) also I using style profile method and same issue (custom code also not appear )
Hi Friends, I have upgraded my K2 Development server from 5.3 to 5.5 and when I applying the CU FP, got the K2 Core Installation error.Based on the error, i verified that VS 2015 C++ is installed in my server.And I'm not able to access Designer/Management whatever, getting the errors i have attached. I checked this article https://community.nintex.com/t5/Technical-Issues/Unable-to-open-K2-sites-No-realms-for-SmartForms-Designer/ta-p/204933 at everything is fine as per this. Can i have a resolution, please let me know if you need more details.
Hi,i am change k2 environment from https\:sharepotint-02 to https:\xx.com every things (designer-workspace-management ) work fine with new URL except worklist URL every new tasks still point to old URL please see the below image .
Hi Would anyone be able to advise me on the error below:2001 Error Starting Host Server: System.NullReferenceException: Object reference not set to an instance of an object.at SourceCode.Sync.RuntimeMarshal.SecurityLabelConnector.Init(IServiceMarshalling serviceMarshalling, IServerMarshaling serverMarshaling)at SourceCode.Hosting.Server.Runtime.HostServerEngine.EnrollHostableTypeInstance(IHostableType HostableTypeInstance)at SourceCode.Hosting.Server.Runtime.HostTypeLoader.InitAndEnrollHostableType(String HostedTypeName, String InterfaceName)at SourceCode.Hosting.Server.Runtime.HostTypeLoader.InitAndEnrollHostableTypes(String InterfaceName)at SourceCode.Hosting.Server.Runtime.HostServerEngine.StartHostServer() K2 configuration service is running without any issues. thanks
Good Day Has anybody have any experience with setting up a 2 node(EC2) cluster on AWS using AWS load balancing and target groups?I have set it up and specified stickiness using both application and loadbalancer cookies but the users that's accessing the access controlled UI is bounced between the two nodes as they progressing through the UI pages.Â
Hi all,  I want to upload a video and audio file on k2, How can I achieve this on K2?  Kindly help with this  Thank you
Hi All, A couple of weeks we are observing our development K2 Server is going down twice a day. How to trouble shoot the issue and get this resolved. Â Â
Hello After upgrading to k2 5 facing some formatting issues in the PDF control output file, I tried resolving them by changing different settings but could not. please see below-attached image some rectangle object is coming in the output file.   and list view is not saved in intact format, it's scattered like the attached below.  Â
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.