Learn about the latest Nintex capabilities at New at Nintex
This section contains archived Nintex for Office 365 Knowledge Articles.
Recently active
IssueWhen building a conditional rule with a numeric value, the rule does not work. For example a form with a rule such as: ControlName >= '25,000' can be submitted even when ControlName is greater than 25,000. ResolutionForm rules with number values should not include commas. Update the rule to just use integers. For example, ControlName >= '25000'
ISSUE When attempting to copy a document to a subsite using "O365 Upload File" within a workflow the following error might occur: Details: ServiceNoResponse Description:The list ‘xxxx’ does not exist in web site ERROR CODE RESOLUTION Verify "Destination site URL" is set to the Subsite URL Verify the user has the appropriate permission to the list Verify that the Folder path exists Save and publish the workflow ADDITIONAL INFORMATION RELATED LINKS
IssueWhen using LazyApproval with Nintex for Office 365, if the task assignee has an 'out of office' response, the LazyApproval system sends a second email saying that their response was not valid. ResolutionThis is currently expected behavior within Office 365, as LazyApproval within Office 365 currently does not support LazyApproval. There is a feature request for this functionality which can be found here.
IssueWhen importing a workflow in Nintex Workflow for Office 365, the following error might occur:“The file provided to import is invalid or corrupted” ResolutionCreate a new list. Import the workflow file on the new list. Review the workflow and check on these actions (including disabled actions): If you have a 'Parallel Branch' action, make sure that at least one action exists in all the branches. If you have a 'Run If' action then make sure that at least one action exists under this action. Save the workflow. Export the workflow. Import the workflow into the original List that had the issue.
IssueWhen using the Create List Item action, workflows that are set to start on Item Creation are not started on these items. ResolutionThis is expected behavior with SharePoint 2013 (Workflow Manager) workflows. As a workaround, use the Office 365 Create List Item or Document Set action.
IssueRunning workflow will automatically terminate with the following error: The workflow instance exceeded the CPU usage limit of throttle of 00:00:01.2000000 and could not be unloaded because it was not persistable. Error Code"The workflow instance exceeded the CPU usage limit of throttle of 00:00:01.2000000 and could not be unloaded because it was not persistable." ResolutionResume the suspended workflow instance by clicking Resume for the workflow or by using the SharePoint Workflow Client Object Model after 24 hours have passed. This must occur before the workflow is terminated. Redesign the workflow to follow Microsoft best practices to handle throttling. For more information, see SharePoint 2013 workflow throttling and performance in SharePoint Online and Project Online. Related Linkshttps://support.microsoft.com/en-us/help/3076399/sharepoint-2013-workflow-throttling-and-performance-in-sharepoint-onli
ISSUE When running a workflow, it might stop automatically and an error similar to the following might occur: RequestorId: eXXXXea-1164-652d-0000-000000000000. Details: System.Activities.Statements.WorkflowTerminatedException: The instance has been moved from the Suspended state to the Terminated state because it has expired. The original error which caused it to be Suspended is: The instance has exceeded the outbound http request quota for a 1.00:00:00 time period. The 5000 request limit was reached in 01:23:53.7820143 ERROR CODE "The instance has exceeded the outbound http request quota for a 1.00:00:00 time period. The 5000 request limit was reached in ." Or “RequestorId: eXXXXea-1164-652d-0000-000000000000. Details: System.Activities.Statements.WorkflowTerminatedException: The instance has been moved from the Suspended state to the Terminated state because it has expired. The original error which caused it to be Suspended is: The instance has exceeded the outbound
IssueWhen running a workflow, it might stop automatically and an error similar to the following might occur: RequestorId: eXXXXea-1164-652d-0000-000000000000. Details: System.Activities.Statements.WorkflowTerminatedException: The instance has been moved from the Suspended state to the Terminated state because it has expired. The original error which caused it to be Suspended is: The instance has exceeded the outbound http request quota for a 1.00:00:00 time period. The 5000 request limit was reached in 01:23:53.7820143 Error Code"The instance has exceeded the outbound http request quota for a 1.00:00:00 time period. The 5000 request limit was reached in ."Or “RequestorId: eXXXXea-1164-652d-0000-000000000000. Details: System.Activities.Statements.WorkflowTerminatedException: The instance has been moved from the Suspended state to the Terminated state because it has expired. The original error which caused it to be Suspended is: The instance has exceeded the outbound http request quota f
IssueWhen trying to publish New Responsive Form in Nintex Form for Office 365, you might have the following error:"Something went wrong when publishing your form. Please retry again. " ResolutionVerify that the content type attached to the related List / Library is not Read only. Additional InformationSteps to verify the Read-only setting for a content typeOpen List Settings. Enable content types if not enabled. Click on "Advanced settings". Select "Yes" for "Allow management of content types". Click Ok which will bring you back to List Settings. Click on the content type you are using for the form. Click on "Advanced settings". The value should be "No".Related Links
TopicThis article is applicable to the new Office 365 Tenants that were created after August 25, 2020. When trying to open Nintex Workflow for Office 365 Designer this error may occur:"Oops... something went wrong. Please visit status.nintex.com for the latest status or contact your system administrator to check the health of your Office 365 tenancy" InstructionsResolution 1:Run this script in SharePoint Online Powershell:Set-SPOTenant -DisableCustomAppAuthentication $false Reference: https://docs.microsoft.com/en-us/sharepoint/troubleshoot/workflows/nintex-workflow-fails-to-start Resolution 2:Grant the "Nintex Workflow for Office 365" App Trust. This required Global Administrator permission. Steps:Get the Nintex Workflow for Office 365 App Identifier Navigate to the Root Site that has Nintex Workflow for Office 365 is installed. Then navigate Site Setting > Site App Permission. On this page, the app permissions will be displayed for all apps on your site. Copy the client sect
IssueThe Nintex Workflow and Forms designer and apps do not load when attempting to open them. ResolutionThis suggests that the 'link' between the site and the app has been broken. To resolve this: Uninstall the Nintex apps from the impacted site. Install the apps again. No workflows or forms will be lost due to this reinstall.
ISSUEWhen running a workflow that contains an "Assign a task" action, the workflow might hang on that action and not report any error, even if the user account is valid.ERROR CODERESOLUTIONReview regular expressions for a string field that is empty or has a NULL value and add a "Run If" action so the regular expression runs only if the String value input is not empty. ADDITIONAL INFORMATIONThis issue occurs when the "String" field of a "Regular Expression action" contains a value that is NULL or empty.RELATED LINKS
IssueWhen configuring a form with rules that hide specific fields based on the status of a drop down, the rules do not function with the same behavior across multiple objects on the form. ResolutionEnsure that Inserted References in each rule have not been copied and pasted from another rule. Additional InformationBest practice for Nintex Forms rules is to manually insert every reference while writing a condition.
IssueA workflow is run and suspends with the error System.InvalidCastException: ResolutionAn invalid cast occurs when a source data type is being transformed into a destination data type but the conversion cannot take place because the data types are not compatible. An example would be trying to transform a text string into a date/time.Any action that can do a conversion should be checked to make sure that the data going in is compatible with the data that is required to come out of the action. Error CodeEXAMPLE: RequestorId: 72cd8e33-f740-0000-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.InvalidCastException: String at Microsoft.Activities.GetDynamicValueProperty`1.CheckedRead(String propertyName, DynamicItem value) at Microsoft.Activities.GetDynamicValueProperty`1.Execute(CodeActivityContext context) at System.Activities.CodeActivity`1.InternalExecute(ActivityInstance instance, ActivityExecutor
IssueError "Unable to update XML. An error occurred while parsing EntityName. Line 1, position 116" occurs when updating XML by using Update XML action if the special characters such as an ampersand "&", less-than sign "<" or greater-than sign ">" are included. ResolutionEncode the special characters such as ampersand "&" to "&amp", less-than sign "<" to "&lt;", greater-than sign ">" to "&gt;". Error CodeUnable to update XML. An error occurred while parsing EntityName. Line 1, position 116
IssueWhen configuring the Nintex Sign powered by Adobe Sign action, and setting the Identification Authentication type as equal to "Adobe Sign", the following error may occur:Bad Request {"message":"This workflow does not permit including yourself in some fields"} ResolutionWhen using Identity Authentication as Adobe Sign, you need to have at least 1 Recipient that is not the same account as the account used to create the connection in the Nintex Workflow Cloud (NWC) and not the field Initiator in the Nintex Workflow for Office 365For example:The account used to create or connect to Adobe is AdobeUser@nintex.comThen, the recipient cannot solely be AdobeUser@nintex.com, you need to add at least another 1 recipient that has different email addresses.
IssueDuring Runtime, when clicking a button in Nintex Form for Office 365, the button that has been configured with a 'Confirmation message' which contains an apostrophe " ' " character, will not return a pop-up dialog as expected. The Form will be closed immediately without a confirmation message. ResolutionModify 'Confirmation message' for the button control, and for any apostrophes or any other special character add slash '' before the character. For example:Incorrect value: You've submitted the form. Correct value: You've submitted the form. During the runtime, you will receive this value: You've submitted the form.
IssueWhen responding to a Lazy Approval task notification, the following error might occur:Your response to this task was not able to be interpreted. The following phrase is invalid. ResolutionOnly reply with the valid phrase on a line by itself at the top of the email.
IssueWhen using certain Nintex Forms controls, i.e "People Picker", you may observe the following error:“There are unresolved entries” ResolutionThis occurs when you are using a non-English regional setting, and is a known behaviour. We request users to vote for this change to be implemented via the below link:https://nintex.uservoice.com/forums/218293-4-nintex-forms-for-office-365/suggestions/31337908-missing-auto-generated-translations Additional Information Related Links
IssueNintex Forms for Office 365 is loaded multiple SharePoint sites, it is currently working on every site apart from one. For the one site that Nintex Forms isn't working on, previously the forms designer would load, allowing forms to be created or edited but now just spools at "Obtaining License". ResolutionWhen troubleshooting options have been exhausted, the best course of action is to remove the Nintex Forms app, and re-add it on this site. Additional InformationWhen troubleshooting, creating a new list on the same site and opening the forms designer changes nothing. Removing the app won't delete the forms, however they will be unpublished. They'll be saved on their respective lists, but you will have to manually republish all forms on each list (including task forms inside of workflows). When you have removed the app and attempt to add it again, if you see a second "ghosted" version of Nintex Forms for Office 365 still in the process of removal, stop the new app from installing
IssueWhen a list, content type, site or site collection is deleted if there were Nintex Forms associated to any of the lists or content types etc they will still appear in the Nintex Mobile application. ResolutionFor Office 365 the local storage will need to be deleted from the settings in the Nintex Mobile Application and the forms re-downloaded.For on-premise installations the first thing to try is to find the form in the NM_Form table in the Nintex Forms database and change the IsDeleted column from 0 to 1.If the form still appears in the Nintex Mobile app the only other option is to delete the whole row in the Nintex Forms Database for the form. Additional InformationThe reason that this issue occurs is because Nintex is a third party application and SharePoint does not tell Nintex when one of its forms is deleted.To avoid this issue all together Nintex Forms should be deleted by opening them in the Nintex Forms designer and then clicking delete form before the SharePoint asset is
IssueWhen try to start a List workflow using Start Workflow action in Nintex Workflow for Office 365, this error might occurs:Item does not exist. It may have been deleted by another user ResolutionThe workflow that need to be started must have Start Manually setting is enabled. Related LinksWorkflow Setting Help File
ISSUEWhen using action "Office 365 Create List Item or Document Set" by configured the action to get List Lookup value from another site, this error might occurs:List does not exist.The page you selected contains a list that does not exist. It may have been deleted by another user.ERROR CODERESOLUTIONThe issue has been identified and has been fixed on the latest Apps of Nintex Workflow for Office 365. Make sure the Nintex Apps has been updated into latest version. Manually Update O365 Apps. Drag and drop a new "Office 365 Create List Item or Document Set" to the workflow designer. ADDITIONAL INFORMATIONRELATED LINKS
IssueWhen using a workflow that inserts data into a SharePoint List, the resulting data might contain an unexpected numeric value of 403. ResolutionUse {Current Item:Encoded Absolute URL} and update the user name and password with a Global account that has the correct permissions. Additional InformationWithin the Web request the fir field URL {Current Item: URL} was being used. This was receiving a 403 forbidden error.
ISSUEWhen running a workflow with a Send an Email action, the workflow might fail with the following error: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 400ERROR CODERESOLUTIONDelete the current Send an Email action from the workflow and create a new one. Open action to configure it. Select the 'External Recipients' check box. Input desired email addresses. Save workflow and publish.ADDITIONAL INFORMATIONThis error occurs when the Send an Email action is configured incorrectly. This error will appear if the recipient emails in the 'To' field is populated before selecting the 'External Recipient' check box first.RELATED LINKS
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.