Learn about the latest Nintex capabilities at New at Nintex
All archived community articles, forum posts and groups. Here you will also find older K2 brokers as well as archived Group content.
Recently active
Hi Folks,I have a panel that is conditionally visible. It has nothing behind it in the design window but when it is visible at run-time, the buttons in the panel show up on top of some other controls (see below). Does anyone know what would cause this behavior?In the designer...Rendered at run-time...Thanks for any advice that you can give,Patrick Kelligan
I have a workflow that Escalates to another person after 12 business days. It has been working great for many months and just noticed it has stopped working. Any ideas?
Hi all, I have an issue where I am getting multiple flexi task emails for one flexi task.workflow settings are as followsThese are how I have them set for a few forms and it is only this one I have duplicates for.Has anyone seen this behavior before? is there a setting somewhere I should change?ThanksJon
Hello. So I am trying to create a site workflow that will run daily. It is looking at another list specifically a particular date field on that list. When that date field equals today I want the site workflow to send and email to the person that created that line in the list. In the site workflow I'm using query list and filtering by Current Time but when I execute it's coming up blank. Any ideas Thanks so much
Hi together,at the moment, we have a strange behavior, when we look at the workflow status.If we use "workflows" in the context menu of an item, we see one running workflow and three completed workflows.If we us "View workflow history" in the context menu, we see no running, 4 completed and one cancelled/errored workflow.I have started NWAdmin.exe -o SyncTerminatedWorkflows -url http://..... for the site collection, but the different status views still exists. Why is this? What to do?Thanks, Lutz
Hi Expert, after i upgrade K2 server from 4.6.11to 4.7. K2 studion and K2 Designer for Visual in my client PC object browser show connecting. In K2 Studio, whenever press on refresh, a error message appear. While for K2 Designer for Visual it show invalid archive. Any Idea?
Hi all,I'm creating a travel expense claim form which captures an employees total miles and parking in a pay period. This is done using calculated fields. This function works as intended. There will be times when the form owner will have to edit it after it has been saved. In my testing, when I edit the form, all of the calculations resolve to zero's. The fields will only recalculate when I place my cursor in the form field and click out of it. What I'm trying to do is have the form show the calculated totals when the form is edited or at the very least recalculate the totals when any form field is edited. I've ensured I'm using named controls in my calculated fields (Eric Harris). I did find a possible solution on a post by using javascript but the example uses the date difference and I can't seem to replicate the javascript to work with my problem - likey because my javascript skills are as good as my Nintex skills. I've done a quick video to show what I'm talking about. Any help
Hi, Migrated a form over to another server with process and smartobjects + data. When i run the form and submit it, i'm getting this error in Workspace: Message: Object reference not set to an instance of an object.; ServiceName: ADService2; ServiceGuid: 83ac8762-cd63-4e86-8ac8-964e8729b735; InnerExceptionMessage: ; The workflow is supposed to send the request to be authorised, but it's not working.Workflow destination : AD User.GetUsersByGroup.Name and then i use an AD group. I created a seperate simple email process and created an instance which ran fine and sent emails, so why would this migrated form not work?Bit worried, because this is a test form, i have the real live forms to do at some point. Any ideas? Thanks
Good Morning Guys,I am having some issues with my workflow, lately my workflow is changing the status of my items from completed to empty or null, I don t know what happen because these items were processed and completed 1 month ago and now I am getting that status is empty. Please let me know your comments about the possible issue. Thank you.
Hello togehter, first i have to say, that im a beginner in K2 and you can correct or discuss with me when i make some mistakes. Now to my questions:I understand it so, that in report designer, the Primary Data Source is the Main Source (kind of fields) with which i can build my report and get the informations. And the related data is the date which i choose from the primary data and finally (can) use in my report. But i dont understand the difference between Activity Data und Activity Instance. Both have the Activity Instance ID implemented, but when i generate my report with activity data i dont geht any result, but when i use the activity instance i get all results i want to. What is the main difference between Data and Instance? good would be an answer with an example, for better understanding. And what is activity data slot , activity slot xml, activity xml?I think its the same with event and process. There are a lot of Related Data which i can use, process statistics graph, proces
I currently have a workflow that will loop through a list using the Query List Action, and use a combination of a For Each Loop and Collection operation to send contents from list items to a user specified in a list column.what I'm trying to accomplish is send a single email to a specified user, with a collection of list items. After much searching, and experimentation I have been unsuccessful in creating this functionality.here is the current configuration
Symptoms We are currently having intermittent errors when deploying packages to our testing environments, and are unsure what the cause of the errors are. It seems to occur in the Post-Deployment section, with an error message of: Dependency could not be created: System.Exception: Dependency could not be created. Parent does not exist in this environment. Check Data property of exception. at SourceCode.Hosting.Services.DependancyService.VerifyObjects(List`1 parents) at SourceCode.Hosting.Services.DependancyService.CreateDepenancyBatch(Dictionary`2 depenancyBatch) Diagnoses This is a known issue which usually happens when the source environment contains some tables that are not in the target environment. Please execute the smartobject being referenced using SmartObjects Service Tester tool and see if you will get an error. If you have multiple smartobjects that your trying to deploy please execute each one of the using the tester tool until you find one with an error. Additional inf
Good morning. After starting DEV license after 2 hours, the program is stopping automatically. Anybody knows could be the cause? Thank you
Symptoms I created a new user and granted direct Admin permissions to K2 Management and added the user to a SharePoint Group with Form Designer permissions, but when the user clicks the K2 Application Icon from the ribbon to access the Artifacts page, the below error displays. This user can access K2 Management, as well as the Designer from the K2 for SharePoint App Page and make changes to the applications, but cannot access the artifacts pages on any apps.The error reads: "Access Denied To design K2 applications you must be a member of a group that has K2 Solution Designer permissions." Diagnoses Verified Group membership and group permissions. Determined that all users of those two groups could not access the artifacts - not just the new user. Learned that subsite administrators have to be site collection administrator on main site collection as well. Resolution The ticket owner was added as a Site Collection Administrator to the main site.
We are on version 2.9.1.20 of Nintex Forms 2013. We have a form that has five cascading lookups: Division -> District -> System -> Facility -> County. The lookups worked up to the System level. But when it got to the Facility, the dropdown is blank. This used to work in version 2.3.4.0.
We have the sharepoint webpart for items worklist. Now we have a requirement from the client to disable the actions drop-down list. On the workflow configuration, we’ve already disabled “approve” and “reject” actions. However, we want disable the entire menu, including redirect, sleep, and all the other options. Can anyone help us? How can we do this?
Symptoms When opening a given worklist item for a process the user was being navigated to a form "hosted" on an http site. This created problems as there was no http site for smartforms on the environment, only https. Diagnoses The root cause of this was that the workflow itself was built in an environment that only used http and deployed into one that only used https meaning that under all circumstances http was used by the process. Whenever a process assigns a task (client event) with a form it will commit an entry to the Server.WorklistItemHeader table which contains a link to the form of the worklist item. To construct that URL the Smartforms Runtime URL is used and while there is a default URL that can be manipulated in the environment library there is also an option to change this URL when building a given SmartForms client event. In this case there was not another option apart from http because the process was built in an environment that only had that. Resolution In this c
I am curious to know if there is a way to use a rule to check for the use of non-alphanumerical characters. All I want is [a-z A-Z 0-9] to be used and no special characters. I considered using "If an advance condition is true" condition as it allows me to check for contains but I'm not sure how to code it. Or if there is a better way to handle this. Thanks in advance.
Symptoms CRUD (Create, Update, Delete) methods are not exposed for newly created SQL Service SmO while target table(s) has primary key. Diagnoses Primary key is compulsory to have CRUD (Create, Update, Delete) methods. As per K2 documentation: "Service Objects for Tables that contain a Primary Key column will contain all the CRUD (Create, Read, Update, Delete) methods, as well as LIST. If there is no primary key on the table then only a List method will be created." In case when your table has primary key but CRUD methods are still not exposed, then it most likely can be caused by "." in a table name. To resolve this remove "." from table name and refresh your service instance and SmOs. Resolution This issue can be caused by absence of primary key on the table or by "." in the table name. In case of "." in table name this can be resolved by renaming table with subsequent SI/SmO refresh.
we are currently on 4.6.9 and would like to Upgrade our k2 versionis it a good idea to upgrade to 4.6.11 or 4.7 which is newest version any good or bad experience anyone experienced after upgrading?
Symptoms At some point you may run into question of moving existing K2 installation (and database(s)) to a new server(s). Sample scenario may be that you are going to move your entire K2 environment to new servers/hardware. This article outlines the process for such migration. NOTE: You have to have qualified K2 platform specialist in house working closely with other IT departments (e.g. infrastructure) to perform such complex migration. In case you are lacking internal expertise it is recommended to work with K2 professional services for implementing such changes. Diagnoses To move K2 server itself it is much easier to do a clean install from media of all K2 components on your new server. Large portion of your settings as well as workflow related data resides in K2 DB, and connection strings stored in configuration files are being generated/updated by K2 setup manager during installation process. Additional consideration here are patches/coldfixes (if you have any) you will also n
Hi,I have created a workflow/ form using Nintex. It's working pretty well but I'm having trouble dealing with how I should deal with attachments.A new item is created in my list through a Nintex form in "View 1" That kicks of the workflow. This runs through a process that can send out up to 10 or so different "forms" (through flexi/ approval tasks etc).To deal with attachments I have put a link on every form inside the workflow that links back to the original list form in "View 2"- which basically all fields disabled except the attachments section so everyone can see/ add attachments to the main list form. This works well enough.Now, in all of my flexi-tasks I have ticked the box "add attachments to email" because all reviewers etc. will want to see the attachments. Then only those people that want to add attachments have to click the link to the main form. Most can just review and complete their tasks- Again works great.But what happens when someone wants to add a 20MB attachmen
So I have been searching for a solution where I can set a "clean/readable" link to the workflow history for each List Item in a SharePoint list.I have been following the instructions found on this site....https://habaneroconsulting.com/insights/the-truth-about-history-when-using-nintex-workflow#.WBuSGE0zU-U...and I am trying to make the Workflow Log URL to be readable instead of something like the below....https://MyWebApp.com/sites/Site/test/_layouts/15/NintexWorkflow/WorkflowLog.aspx?ListId=10a4254d-af72-4f33-bc00-d65d05443070&ItemId=23&WorkflowId=bf5a1fdd-0e14-4da7-8045-43976f6ad9f2&InstanceId=a13e49d0-4346-4b26-84e6-24555da1dd91The code <a href=Workflow Log URL>View History</a> does not seem to work in my environment. Is there a way to put the URL into a variable? Or how is best to clean up the Workflow Log URL link?Thank you for your time and thoughts.
Symptoms Overall slowness of K2 applications accompanied by high CPU usage on K2 sever. K2 host server log shows the following exceptions: SourceCode.Diagnostics.Log: Failed to log entry: Exception=System.IO.IOException: The requested operation could not be completed due to a file system limitation at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)at System.IO.FileStream.WriteCore(Byte[] buffer, Int32 offset, Int32 count)at System.IO.FileStream.FlushWrite(Boolean calledFromFinalizer)at System.IO.FileStream.Dispose(Boolean disposing)at System.IO.Stream.Close()at System.IO.StreamWriter.Dispose(Boolean disposing)at System.IO.TextWriter.Dispose()at System.IO.File.InternalAppendAllText(String path, String contents, Encoding encoding)at SourceCode.Diagnostics.Log.LogWorker(Object state)SourceCode.Diagnostics.Log: Failed to log entry: Category=SourceCode.Diagnostics, Message=YYYY-MM-DD THH:MM:SS SourceCode.Diagnostics: OnFirstChanceExceptionException:System.IO.IOExceptio
Symptoms on this K2 server in my DMZ, the k2 service is stuck on starting and the only error I see on all logs is as follows, 0 System.Data.SqlClient.SqlException (0x80131904): Procedure or function 'hServerUpdate' expects parameter '@EnvironmentGUID', which was not supplied. at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose) at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Booleanandamp dataReady) at System.Data.SqlClient.SqlDataReader.TryConsumeMetaData() at System.Data.SqlClient.SqlDataReader.get_MetaData() at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.