Learn about the latest Nintex capabilities at New at Nintex
This section contains archived Nintex for Office 365 Knowledge Articles.
Recently active
IssueWhen using the List Lookup control on Nintex Mobile that is connected to an Office 365 list, it will only return a total of 2000 items, regardless of the number of items on the list.ResolutionMake sure the Nintex forms and Nintex Mobile are all updated to the latest version. This has been resolved on the latest version of the product.
IssueWhen using Document Generation action in a workflow the following error is produced:An error occurred downloading a file from a URL (https://Tenant-Name.blob.core.windows.net/docgen ....) Error Code RequestorId: aa5eeb05-22ff-78a5-0000-000000000000. Details: An error occurred downloading a file from a URL (https://tenant.blob.core.windows.net/........). (ResourceInvalid) (ErrorId: dea86c39-aaaa-44e7-ab55-7b9e715ebff3) Resolution - Ensure that the Output filename field does not contain special characters in the Document Generation action settings.- If using a workflow variable or a reference, ensure that value is clear from any special characters. Additional Information When using a workflow variable or a reference like "Username" or "URL" as the output file name, the action will fail to generate the document due to the fact that the name includes special characters in the value of the filename.
IssueWhen opening a Nintex Form using Incognito mode in Chromium based browser (Chrome browser or Chromium based Edge),this following error may occurs in Developer tools:Uncaught SecurityError: Failed to read the 'localStorage' property from 'Window': Access is denied for this document. ResolutionThis exception is thrown when the "Block third-party cookies and site data" checkbox is set in Content Settings. This needs to be disabled or an Exceptions needs to be added to the Sharepoint site.To find the setting, open Chrome settings, type "third" in the search box, click the Content Settings button, and view the fourth item under Cookies. Related LinksPlease see the original site for further details:https://www.chromium.org/for-testers/bug-reporting-guidelines/uncaught-securityerror-failed-to-read-the-localstorage-property-from-window-access-is-denied-for-this-document
IssueWhen using "Query List" action in Nintex Workflow for Office 365 and using the Filter current date variable that set up using "Add Time to Date" to compare with one of the current item list with data type is Date only, the result is null because the current date variable has a Date and Time instead of Date only. ResolutionUser "Set Time Portion of Date/Time field" to get the current date and configured the hours and minutes of the action into zero (0).
IssueWhen attempting to copy a document to a subsite using "O365 Upload File" within a workflow the following error might occur:Details: ServiceNoResponse Description:The list ‘xxxx’ does not exist in web site ResolutionVerify "Destination site URL" is set to the Subsite URL Verify the user has the appropriate permission to the list Verify that the Folder path exists Save and publish the workflow
IssueWhen trying to publish New Responsive Form in Nintex Form for Office 365, you might have the following error:"Something went wrong when publishing your form. Please retry again. " ResolutionVerify that the content type attached to the related List / Library is not Read only. Additional InformationSteps to verify the Read-only setting for a content typeOpen List Settings. Enable content types if not enabled. Click on "Advanced settings". Select "Yes" for "Allow management of content types". Click Ok which will bring you back to List Settings. Click on the content type you are using for the form. Click on "Advanced settings". The value should be "No".Related Links
IssueWhen running a workflow, it might stop automatically and an error similar to the following might occur: RequestorId: eXXXXea-1164-652d-0000-000000000000. Details: System.Activities.Statements.WorkflowTerminatedException: The instance has been moved from the Suspended state to the Terminated state because it has expired. The original error which caused it to be Suspended is: The instance has exceeded the outbound http request quota for a 1.00:00:00 time period. The 5000 request limit was reached in 01:23:53.7820143 Error Code"The instance has exceeded the outbound http request quota for a 1.00:00:00 time period. The 5000 request limit was reached in ."Or “RequestorId: eXXXXea-1164-652d-0000-000000000000. Details: System.Activities.Statements.WorkflowTerminatedException: The instance has been moved from the Suspended state to the Terminated state because it has expired. The original error which caused it to be Suspended is: The instance has exceeded the outbound http request quota f
IssueRunning workflow will automatically terminate with the following error: The workflow instance exceeded the CPU usage limit of throttle of 00:00:01.2000000 and could not be unloaded because it was not persistable. Error Code"The workflow instance exceeded the CPU usage limit of throttle of 00:00:01.2000000 and could not be unloaded because it was not persistable." ResolutionResume the suspended workflow instance by clicking Resume for the workflow or by using the SharePoint Workflow Client Object Model after 24 hours have passed. This must occur before the workflow is terminated. Redesign the workflow to follow Microsoft best practices to handle throttling. For more information, see SharePoint 2013 workflow throttling and performance in SharePoint Online and Project Online. Related Linkshttps://support.microsoft.com/en-us/help/3076399/sharepoint-2013-workflow-throttling-and-performance-in-sharepoint-onli
ISSUE When running a workflow, it might stop automatically and an error similar to the following might occur: RequestorId: eXXXXea-1164-652d-0000-000000000000. Details: System.Activities.Statements.WorkflowTerminatedException: The instance has been moved from the Suspended state to the Terminated state because it has expired. The original error which caused it to be Suspended is: The instance has exceeded the outbound http request quota for a 1.00:00:00 time period. The 5000 request limit was reached in 01:23:53.7820143 ERROR CODE "The instance has exceeded the outbound http request quota for a 1.00:00:00 time period. The 5000 request limit was reached in ." Or “RequestorId: eXXXXea-1164-652d-0000-000000000000. Details: System.Activities.Statements.WorkflowTerminatedException: The instance has been moved from the Suspended state to the Terminated state because it has expired. The original error which caused it to be Suspended is: The instance has exceeded the outbound
TopicThis article is applicable to the new Office 365 Tenants that were created after August 25, 2020. When trying to open Nintex Workflow for Office 365 Designer this error may occur:"Oops... something went wrong. Please visit status.nintex.com for the latest status or contact your system administrator to check the health of your Office 365 tenancy" InstructionsResolution 1:Run this script in SharePoint Online Powershell:Set-SPOTenant -DisableCustomAppAuthentication $false Reference: https://docs.microsoft.com/en-us/sharepoint/troubleshoot/workflows/nintex-workflow-fails-to-start Resolution 2:Grant the "Nintex Workflow for Office 365" App Trust. This required Global Administrator permission. Steps:Get the Nintex Workflow for Office 365 App Identifier Navigate to the Root Site that has Nintex Workflow for Office 365 is installed. Then navigate Site Setting > Site App Permission. On this page, the app permissions will be displayed for all apps on your site. Copy the client sect
IssueThe Nintex Workflow and Forms designer and apps do not load when attempting to open them. ResolutionThis suggests that the 'link' between the site and the app has been broken. To resolve this: Uninstall the Nintex apps from the impacted site. Install the apps again. No workflows or forms will be lost due to this reinstall.
ISSUEWhen running a workflow that contains an "Assign a task" action, the workflow might hang on that action and not report any error, even if the user account is valid.ERROR CODERESOLUTIONReview regular expressions for a string field that is empty or has a NULL value and add a "Run If" action so the regular expression runs only if the String value input is not empty. ADDITIONAL INFORMATIONThis issue occurs when the "String" field of a "Regular Expression action" contains a value that is NULL or empty.RELATED LINKS
ISSUEWhen using a state machine action in a workflow, the workflow processes actions after the change state action, instead of changing states.ERROR CODERESOLUTIONReorganize the workflow so that change state actions occur as the last actions in the state machine.ADDITIONAL INFORMATIONThis is expected behavior for a state machine. The state machine will continue to the end of its logical loop prior to trying to change states. At the end of the loop it evaluates to which state it should change. If there are multiple places with change states it will change to whatever state it was last set.RELATED LINKS
ISSUEWhen running a workflow that is configured to send an email, the workflow suspends with the following error: RequestorId: 6fdb72dd-529e-e60f-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 400 {"error":{"code":"-2130242040, Microsoft.SharePoint.SPException","message":{"lang":"en-US","value":"The e-mail message cannot be sent. Make sure the e-mail has a valid recipient."}}}ERROR CODERequestorId: 6fdb72dd-529e-e60f-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 400 {"error":{"code":"-2130242040, Microsoft.SharePoint.SPException","message":{"lang":"en-US","value":"The e-mail message cannot be sent. Make sure the e-mail has a valid recipient."}}}RESOLUTIONWhen trying to send to an email that is not associated with an account within SharePoint Online, ensure that t
IssueWhen using an Office 365 Upload File action to upload a file to the list that has a special character as the list name (i.e : (Nintex) List Sample), the following error may occur: The list '<List Name>' does not exist in web site '<Site URL>' ResolutionThe issue has been fixed on the latest version of Nintex Workflow for Office 365 Apps that is being released by the end of August 2018. Make sure that the site has the latest version of Nintex Apps.
IssueWorkflow instance fails with the error: System.Activities.Statement.WorkflowTerminatedException: Error Code: -2146232060, Microsoft.SharePoint.SPException, Message: Exception from HRESULT: 0x80131904 ResolutionPlease open a support ticket with Microsoft SharePoint Online support, as this issue will fall outside the control of Nintex on the SharePoint Online platform. Error Code-2146232060, Microsoft.SharePoint.SPException, Message: Exception from HRESULT: 0x80131904 Additional InformationThis error is caused by a failure within the SQL database system of the SharePoint Online environment.
ISSUEWhen using an email action such as Send email or Assign Flexi Task, and using {Workflow Context: Current Item Url} in the body of the email, the hyperlink is broken in the email sent to the recipients.ERROR CODERESOLUTIONOption 1Remove any spaces in the list name and run the workflow. Option 2 Click on Insert link in the body of the email. Enter the URL { Workflow Content: Current Item Url}. Enter the hyperlink text - "Hyper link text to be displayed in the email body".ADDITIONAL INFORMATIONDepending on the email client, this might be displayed as a clickable hyperlink. If there is a space in the link, then it might be broken after the space, if the email client cannot handle the space. Outlook will try to resolve this text as a URL, but Outlook Web Access will display it as text and not a URL.RELATED LINKS
ISSUEWhen creating a new workflow in Nintex Workflow for Office 365, a "For development use only" message appears in the background.ERROR CODERESOLUTIONThis is by design. Workflows will be marked as 'For development use only' until the workflow has been assigned to production on publishing. For more information, see How to Designate a Production or Development Workflow in O365.ADDITIONAL INFORMATIONRELATED LINKS
IssueWhen using Google Chrome version 72 (was released on the 29th of January 2019), the Nintex Task Form cannot be modified in the Responsive Form designer. As well as: To Add a new control onto Nintex Task Form Designer. Drag and drop controls in the Nintex Task Form Designer. ResolutionClose all instances of the Chrome browser. Navigate to the directory where the Chrome browser has been installed. This is either C:Program Files (x86)GoogleChromeApplication or C:Program FilesGoogleChromeApplication. . Then Run the following command from command prompt: - chrome.exe --disable-features=VizHitTestSurfaceLayer,VizHitTestDrawQuad,VizDisplayCompositor Additional InformationThe Chromium team has confirmed this issue on Google Chrome version 72 and they are working towards a permanent fix for the next released of Google Chrome.
IssueWhen trying to add an attachment into a form within a workflow in Office 365, the new comments don't appear and delete that comments that appeared in the comment history section that appeared before. ResolutionResolution steps:1- Go to List Settings2- Choose the column "multiple line of text" type and change the "Append Changes to Existing Text" into No in order to avoid clearing off any comments and/or attachments added.
IssueThe Shrink and Expand button are disabled in the New Responsive Designer. ResolutionThe Shrink and Expand buttons are only enabled if there is more than 1 control in the same row. The buttons are disabled if only 1 control in the same row.
IssueWhen uploading a document to a document library in SharePoint Online that has a Nintex Form published, Internet Explorer presents a window that states "This content cannot be displayed in a frame". Resolution In Internet Explorer, please navigate to Settings (Cog in top right) > Internet Options > Security > Trusted Sites > Sites and add the following sites:*.office.com*.microsoftonline.comYou may need to close and reopen Internet Explorer for this to take affect. Error Code"This content cannot be displayed in a frame" Additional InformationThis appears to only occur when there is a SharePoint Column that is 'Required'.
IssueWhen publishing a component workflow in Nintex Workflow for Office 365, the following error may occur:The name of Component workflow has been used. Please choose another name ResolutionVerify that there is no other workflow with the same name under the same Office 365 tenancy because the workflow name is unique on the Tenancy level.
SUMMARYA mail-enabled security group is not receiving notifications when the group is a recipient of an email within the 'Send an Email' action. Individual users on the BCC or CC line are receiving these notifications. The workflow will run through without error. SOLUTIONUse one of the following methods to configure Exchange Admin Center for this account:Select the option to accept mail from "Senders inside and outside of my organization". Add individual senders to the approved senders list. The users named on this list will be the only ones who can send to the group, so be cautious if you require multiple people within the org to send to this SG. Additionally, the following accounts will need to be included: reply@workflownotification.com no-reply@sharepointonline.com
ISSUEWhen creating a save button in a task form, the button cannot be used without one of the task outcomes being selected.ERROR CODERESOLUTIONThis is expected behavior. As a workaround, try the following:Create an additional outcome (Incomplete or In Progress etc). Set the new outcome as the default value for the outcome control Create a hide / disable rule on the 'Save & Submit' button for when the outcome is equal to the value created earlier. For example: taskoutcome=="Incomplete" This would allow the save button to be used, but would prevent anyone from submitting the form until the outcome field has been set to one of the expected out of the box fieldsADDITIONAL INFORMATIONRELATED LINKSHow to ignore Decision validation when save button clicked in Flexi Task Nintex Form
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.