Learn about the latest Nintex capabilities at New at Nintex
This section contains archived Nintex for Office 365 Knowledge Articles.
Recently active
IssueWhen an external email address is configured in a Assign a Task workflow action, the following error occurs:Sorry, we're having trouble reaching the server ResolutionConfigure the Assign a Task action with an email address within the Office 365 tenancy. Additional InformationEmail recipients in Assign a Task action are restricted to those with email accounts in the Office 365 tenancy. Related LinksHelp File - Assign a Task
IssueThe conditional criteria, for a conditional start workflow are no longer visible from the workflow setting. This occurs after the Workflow designer is reopened, after modifying the conditional criteria. ResolutionThe issue has been fixed on the latest version of Nintex Workflow for Office 365 Apps that was released on 21th November 2018. Make sure that the site has the latest version of Nintex Apps
IssueWhen using a Nintex Form to edit Properties of a Document inside of a Document Set, you are presented with "Sorry, something went wrong - An Unexpected Error has occurred" upon submission. The changes to the document's properties are still properly saved. ResolutionThis issue was resolved in the February 2019 update for Nintex Forms for Office 365.
IssueWhen trying to update the Nintex for Office 365 apps from within SharePoint Online, the 'Get It' button is missing from the SharePoint Online Store page after selecting 'An update for this app is available.' ResolutionThe steps below are to resolve the issue for Nintex Workflow for Office 365, if the issue is also occurring with Nintex Forms for Office 365, please repeat them for that app as well:Open SharePoint Admin Center Select Apps > Manage Licenses > Nintex Workflow for Office 365 Under 'License Managers' select 'add manager' and add an active Admin account Return to the Site Contents and attempt to re-update the Nintex for Office 365 app Additional InformationIf there are expired/deactivated user accounts under License Managers it is recommended to remove these accounts from the list of license managers.
IssueWhen opening an existing Nintex Forms Office 365 for editing in the Nintex Forms designer the form does not load and the designer is stuck on the spinner.The existing form works and can be used for new, edit and view but the form cannot be opened in the designer. ResolutionIt is possible that the form has been edited and saved in the designer but a file has become corrupted.To get back to the previous form follow these steps. 1. Open SharePoint designer (https://www.microsoft.com/en-au/download/details.aspx?id=35491) and go to the site > All Files > Lists > ListName > Item. In this folder you will see 2 XML files. Export a copy of NFForm.xml. This is the current form that loads when you select new item. We will use the export of the file to import back into the designer in a later step. 2. The file that is loaded when you edit and save in the designer is found using a web browser at https://<tenanturl>/site/NintexFormXml You will need to find the file that co
QuestionHow often do O365 actions retry if they fail to connect to the O365 tenant. AnswerEach query execution has a timeout of 1.5 minutes. The default timeout of the SharePoint SDK (CSOM) is what is usedAll Office 365 actions have the same retry behavior. Additional InformationTo add functionality to the the O365 workflow engine Nintex's Office 365 actions call outside of the tenant to Nintex Infrastructure. The Nintex infrastructure then logs back into the tenant to perform the required activity. Sometimes there can be issues with connecting to the tenant due to a range of issues between Microsoft, Nintex and the Internet. As this is the case Nintex has retry functionality built in so that the workflow does not immediately suspend.
IssueIn a Nintex Responsive Form for Office 365, the line break was missing between the data in a multiple lines of text column. ResolutionChange the column type from plain text to Enhanced rich text (Rich text with pictures, tables, and hyperlinks) and republish the form.
IssueWhen running a workflow, the workflow completes successfully for some users, however other uses encounter an Access Denied error. ResolutionEnsure that the affected user accounts have Contribute permissions on: List where the workflow is running Any list that the workflow interacts with (query, update, etc.) Task list associated with the workflow Workflow History list for the site at https://[TenantName].sharepoint.com/sites/[SiteName]/Lists/Workflow%20History/AllItems.aspx To minimize guessing, identify which list the error is regarding by doing the following: 1. Refer to the error itself as the list ID is mentioned in the error message (in bold below).2. On any list within the same site, navigate to List Settings; notice that the URL references the list by the ListID.3. In the URL, replace the current list ID with the list ID mentioned in the error. For example: https://tenant.sharepoint.com/sites/MySite/_layouts/15/listedit.aspx?List=87d30f08-7f60-4b17-b144-a100bfab2dfb 4. Afte
IssueWhen connecting to Nintex Mobile with an Office 365 account, user authentication fails with the error: "Access Denied. You do not have permission to perform this action or access this resource" ResolutionVerify that the site being connected to has the Nintex Forms for Office 365 app installed. Error CodeAccess Denied. You do not have permission to perform this action or access this resource
IssueWhen using an 'Update List Item' action in Nintex Workflow for Office 365, to update a number field with the option show as percentage checked, the result is the input value is multiply by 100. Example: Input value : 100 Result in SharePoint list : 10,000% ResolutionThis is an expected behavior as this can be replicated with SharePoint Designer. To avoid any confusion, Nintex has also updated the description for the "Update List Item" action in Nintex Workflow for Office 365 The added description is: This item is configured to show as a percentage. Enter a value between 0 and 1. For example, enter .5 to show as 50%.
IssueWhen using a Lookup control as the 'value to filter on' within the Lookup runtime function of a Calculated Value control, the Calculated Value control returns a blank value, even when the function works as expected with a hard-coded value to filter on. ResolutionNest the Lookup control reference within the Lookup function inside of a parseLookup runtime function. For example, instead of this function:lookup("list title", "column to filter on", value to filter on, "output column")Use this:lookup("list title", "column to filter on", parseLookup(value to filter on), "output column") Additional InformationThis is caused by the fact that Lookup controls do not actually return the value shown within the control. If the item 'Testing' was selected within a Lookup control, and 'Testing' has an ID of 3 on the source list, the Lookup control would return the following: 3;#TestingThe parseLookup runtime function parses out the Testing portion of that output, which in turn can be used as a r
IssueWhen using the action 'Set Field in Current Item' or 'Update List Item' in Nintex Workflow for Office 365, it automatically sets the list column that has the data type Multiple line text to blank, even though this column is not part of the field that is being updated, in the action configuration. ResolutionThe root cause of this issue is because the Multiple lines of text column has a field 'Append Changes to Existing Text' that has been set into 'Yes'.If this is not the business requirement, then set the 'Append Changes to Existing Text' into No. If this is the business requirement, then make sure that the action to update list item is configured to set the value of the Multiple lines of text column to avoid overriding into blank value.'
IssueNintex Workflow for Office 365 is stuck in progress on an action that needs authorization.One of these actions is Nintex Sign powered by Adobe Sign. ResolutionWhen the action runs, an email with the below content is sent to the email address selected for the Authorizing user.From: notification@nintexlive.comSubject: Contains phrases "Nintex Live" and "Request authorization".Contents: Contains links to authorize or deny the operation.When the link to provide authorization is clicked the user is prompted to do the following:Log in to the external service. Allow Nintex Live to access the external service. Option to stop receiving future authorization requests for the service. Additional Informationhis article applies to all the Nintex Workflow for Office 365 actions that required authorization. Please check the help file of each action for the details regarding the Authorization process.
IssueWhen using the Task action in Nintex Workflow for Office 365 with the "Auto-complete task" setting being activated, the user finds the "task date completed" is the same date when the task created, this can be confusing as to when the Task was actually completed. ResolutionMake sure to get the information on the task last date modified from the task itself (via workflow task list) and not from the item related to the task. Additional InformationUse the Query List action by supplying the Task ID from the Task action output, to get the information details of the completed Task.
IssueWhen running Nintex Workflow for Office 365, the following message appears in the Workflow status history page:Some parameters failed the validation check. - [InputDestinationSharePointUrl] : Destination URL is invalid ResolutionThe error is shown when the 'Destination site URL' field has either been entered in manually or copied and pasted from a similar account. To resolve the issue, you will need to do the following:1. Clear the existing text for the field 'Destination site URL'2. Place cursor in the 'Destination site URL' field3. Expand 'Workflow Context' section on the right4. Click on 'Current site URL' to add this information to the 'Destination site URL' field
IssueWhen trying to export a Nintex Workflow or Form a dialog appears with the error Export Fail. ResolutionIncrease the Site storage limit and try again. Error CodeExport Fail Related LinksManage site storage Limits : Manage site storage limits
ISSUEWhen trying to publish a Nintex workflow within Office 365, the workflow fails to publish and the following error occurs:Error publishing workflow. The request message is too big. The server does not allow messages larger than 2097152 bytes.ERROR CODERESOLUTIONRemove any unused actions within the workflow design. If there are no unused actions within the workflow design, the workflow will need to be split into multiple parts.ADDITIONAL INFORMATIONRELATED LINKSSplitting large or complex workflowsUpload large files sample add-in for SharePoint
IssueA trial customer that has paid the Office 365 subscription still have a trial notification when opening the Nintex Workflow or Form designer. ResolutionThe licensing team has to generate a new license and to verify that the PPT ID must have a valid GUID format including dash symbol.
IssueWhen running Nintex Workflow for Office 365, the following message appears in the Workflow status history page:The list '{Workflow Context:List Name}' does not exist in the web site ResolutionThe error is shown when the 'List name' field has either been entered in manually or copied and pasted from a similar account. To resolve the issue, you will need to do the following:1. Open the Workflow Designer2. Open the Office 365 Live action3. Clear the existing field for 'List name'4. Place cursor in the 'List name' field5. Expand 'Workflow Context' section on the right6. Click on 'List Name' to add this information to the 'List name' field
ISSUEWhen accessing workflows in Office 365, the following error might occur: Some workflows may not be shown. We are unable to reach the workflow service ERROR CODESome workflows may not be shown. We are unable to reach the workflow serviceRESOLUTIONContact Microsoft to verify the Workflow Manager service is functioning correctly.ADDITIONAL INFORMATIONRELATED LINKS
IssueWhen clicking on a task link from a mobile device the task may open up in a browser depending on associations on the device.If the task opens in a browser a SharePoint task form will be presented in either View or Edit mode regardless if a Nintex Responsive form has been added to the task or the appropriate layout has been added to a Nintex classic Form. ResolutionThe SharePoint Task form showing is not a bug but a limitation. Additional InformationA workaround for this issue is to insert a custom link in the email notification.Click "Link" from the Insert tab ribbon and add a custom link as per the example below.fn-Replace(&quot;{Common:ApprovalUrl}&quot;, &quot;Lists/Workflow%20Tasks&quot;, &quot;_layouts/15/NintexForms/Mobile&quot;)&amp;List=<TaskListId>Note: Change Workflow%20Tasks to your Task Name and <TaskListId> to your task list id GUID.The idea for this approach is to use Approval Url which is similar to <SiteURL>/Lists/Work
IssueWhen publishing a workflow, the following error might occur:Error publishing workflow. Workflow XAML failed validation due to the following errors: Activity 'FormatString' has XX arguments, which exceeds the maximum number of arguments per activity (50). Activity `FormatString` has 59 arguments, which exceeds the maximum number of arguments per activity (50). (...). The remote server returned an error: (400) Bad Request. ResolutionReduce the number of field entries to be render into and the error should disappear and the publish should work. Additional InformationSharePoint Workflow Manager has a limitation of 50 references for a 'FormatString' Activity. This can surface either in Log to History Actions (if the character limitation is not reached first) or by trying to render those in an action such as a "Send Email" or "Assign Task".
IssueDuring a data center migration the customer receives the following error when publishing a workflow.“Workflow starting based on conditions cannot be saved or published until migration is complete”. Error CodeWorkflow starting based on conditions cannot be saved or published until migration is complete ResolutionThere are multiple steps to a data center migration and one of them is to migrate workflow start condition subscriptions.Each start condition requires a subscription in the list that they are being published on.Each list can hold a total of 100 subscriptions.If these subscriptions are taken up by other applications such as Microsoft Flow the customer will receive this error.Resolutions.1. The customer will need to manually delete subscriptions from the list to make room.2. The customer can remove all start conditions from the workflow and then publish.3. Worst case scenario is that DevOps can remove the subscriptions from the source data center so that they do not need to b
IssueThe Save button is disabled and user unable to Save the Task action configuration. ResolutionCheck the Content Type in use, if custom content type is utilized then try to remove the existing content type and use the default instead. If the issue with Custom Content Type, then make sure that the custom content type has been configured properly.
IssueWhen replying to a Lazy Approval email with a valid outcome the email does not seem to be received by the O365 tenant and the Task remains in the status of Not Started. ResolutionThere are many reasons why this issue can occur but these are the basic things to check.1. Navigate to the Nintex status page and check for any incidents concerning Lazy Approval.2. Make sure that the Email infrastructure is not changing the domain for outgoing emails as the task can only be completed if a reply is received from the email address that it was sent to.3. Make sure that the Email infrastructure is not altering the subject line of the email and altering the Lazy Approval token. Related LinksNintex Status Page : Nintex Services
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.