Learn about the latest Nintex capabilities at New at Nintex
This section contains archived Nintex for Office 365 Knowledge Articles.
Recently active
IssueWhen using a Managed Metadata term value within a text field, such as an email body, or Log To History action, the term displays as 'Value | TermIdGUID'Example: 'Nintex Engineer | b664989e-0ac2-4d49-9a89-d6f7bf092fe1' ResolutionThis is expected behavior when converting a Managed Metadata term to a string. You can use the Regular Expression action with the following configuration to strip out the GUID:String: {Variable:OriginalManagedMetadataTerm} String operation: Replace Pattern: |(.*) Replacement String: Output: {Variable:UpdatedManagedMetadataTerm}
IssueWhen a user clicks on a URL for a Nintex Form in SharePoint Online in Internet Explorer, an error page states 'The query string "redirect_uri" is missing or invalid'. ResolutionUse the Classic SharePoint 'New Item' URL in your Web Part:Navigate to your list where your Nintex Form is published. Select 'Return to classic SharePoint' (bottom left) Right-click 'New Item' Select 'Copy Shortcut' You now should have a URL that looks like: https://tenant.sharepoint.com/sites/MySite/_layouts/15/listform.aspx?PageType=8&ListId=%7BD82805CA%2D30A3%2D4CFD%2D941C%2D76EF40AF62E7%7D&RootFolder= Place this URL in your Web Part Error CodeThe query string "redirect_uri" is missing or invalid Additional InformationThis issue most commonly occurs when clicking on a Nintex Form URL that is stored in a Web Part in SharePoint Online. Using the Classic SharePoint 'New Item' URL allows SharePoint Online to navigate to the 'New Item' form which automatically redirects to your published Nintex Form,
IssueWhen accessing task form as a user who did not initiate the workflow, the error "Item does not exist. It may have been deleted by another user." pops up instead of loading the task form. ResolutionNavigate to List Settings > Advanced Settings on the affected list. Under Item-level Permissions, make sure "Read all items" and "Create and edit all items" are selected. Error Code"Item does not exist. It may have been deleted by another user." Additional InformationNintex task forms check item-level permissions when allowing access to the task form. If access isn't set to all items, then only the workflow initiator will have access and everyone else will receive the error message.
IssueWhen using Nintex Workflow for Office 365 Document Generation action, some of the items properties that have been tagged in the Document Template do not generate a value on the document generated. ResolutionBelow are some Verify the item property tag on the document template and make sure that the tagger has a space with another word on the template. Example: (1)<<ItemProperty_Title>> ==> This will not work because there is no space between character ) and <<. The valid tagged is:(1) <<ItemProperty_Title>> ==> Add one space between (1) and <<ItemProperty_Title>>
IssueWhen using 'Set Workflow Variable' in Nintex Workflow for Office 365, this error might occur during workflow runtime:RequestorId: <GUID>. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.InvalidCastException ResolutionMake sure that variable type and the value used to set the workflow variable matches. For example: A Date/Time type of variable would not match with Number value.
IssueNumbers entered in Nintex form are being registered with comer in SharePoint when the Nintex form control is connected to a SharePoint column with the “Number” data typeThis is for all platforms of Nintex Form and SharePoint ResolutionThis is a know issue in SharePoint, this is not a Nintex issue.There are workarounds1, Use a text column and not an number column data type2, Create a calculated column and use the formula = TEXT([Column Name], "0")
ISSUEWhen running a workflow that uses the "Start workflow" action to start another List workflow, the selected workflow does not start even though the master workflow does not return any error. ERROR CODERESOLUTIONConfigure "Workflow type" value in "Start workflow" action with "List Workflow". ADDITIONAL INFORMATIONRELATED LINKSStart workflow
IssueA Send an Email action sent a blank email to the recipients when a workflow triggered by an imported workflow even though the body of the email has a text. ResolutionRemove the current item reference in the email body. Re-insert the current item reference Publish the workflow. Additional InformationFor a workflow that has been imported from an exported workflow file, the Current Item: Insert References on the email body needs to be re-configured.
IssueWhen using a web part in a Nintex form, the web part might fail to load with the following error:Sorry, we had some trouble accessing your site. ResolutionIn Internet Explorer, go to Options > Security and add the following entries to the Trusted Sites: *.microsoftonline.com https://auth.nintex.com
ISSUEWhen opening Nintex Forms, the following error occurs:Index was outside the bounds of the arrayERROR CODERESOLUTIONReview all site column names and remove any special characters, for example: / : * ? " # % < > |, two consecutive periods (..), or special characters such as a tab.ADDITIONAL INFORMATIONRELATED LINKS
IssueSetting a date/time value to a date/time workflow variable outputs the wrong time at workflow execution. ResolutionThis is by design. SharePoint will adjust the time stored in the workflow variable to GMT (UTC+0), plus add time to account for daylight savings. SharePoint does not know the time zone of the date/time value being saved to the workflow variable, so the time is adjusted based on regional settings when used in a workflow. We recommend using the "Add Time to Date" action to adjust the date/time workflow variable to the correct time.
IssueWhen creating a form in Nintex Forms for Office 365 designer, using Chrome browser, and clicking the Create Column icon from the ribbon, the dialog window to create the column is blank. ResolutionUse another browser, such as Internet Explorer or Firefox. Additional InformationThis issue occurs due to an update in Chrome: Version 60.0.3112.113 (Official Build) (64-bit)
IssueWhen sending an email to a large group of recipients, the recipients receive duplicate emails and the workflow fails to continue. ResolutionEnsure that the batch of recipients being submitted to the action is below 200. Additional InformationThe issue can be caused by the number of user accounts being referenced by the action.
IssueThe below error occurs when attempting to publish a Nintex workflow that contains a conditional start event.Error message:Error publishing workflow. Conditions could not be published and the workflow will not be able to start conditionally. Please try publishing again. ResolutionPublishing a Nintex conditional workflow will use 1 subscription per published workflow. SharePoint only allows 100 subscriptions on a custom list and it is possible that the list has reached the maximum number. Other third party products can also use subscriptions for example Microsoft Flow.Options:1. Recreate the SharePoint list.2. Contact Microsoft Support to assist with removing subscriptions from the SharePoint list. Error CodeError publishing workflow. Conditions could not be published and the workflow will not be able to start conditionally. Please try publishing again.
IssueWhen updating a personal connection in Nintex Workflow for O365 the new password is entered and saved but the "Last modified" date on the "Available Connections" page is not updated and neither is the password. Resolution1. Make sure that the user who owns the personal connection is logged in.2. Use Internet Explorer to do the update.3. If another browser is being used make sure the user is logged in properly especially when using Multi Factor Authentication.
IssueWhen completing a Nintex Task Form associated with a Nintex Workflow, SharePoint displays the error message "Unexpected error occurred." ResolutionMake sure the task form has the "Task Outcome" control present or SharePoint will throw an error message when closing the form. Error CodeFrom the GUI: Unexpected error occurred. If the problem persists, contact your support team with the following information: Correlation ID: xxxxxx Tenant ID: xxxxxx Time (UTC): YYYY-MM-DD HH:MM:SS From Logs: - Task Outcome Control 'outcomeCtrl' is not found in form - Nintex.Forms.SharePoint.Exceptions.UserException: Error in task. Input string was not in a correct format. - Exception caught by error page. => Nintex.Forms.SharePoint.Exceptions.UserException: Error in task. Input string was not in a correct format. - Application_Error => System.Web.HttpUnhandledException (0x80004005): Exception of type 'System.Web.HttpUnhandledException' was thrown.
IssueAn Office 365 workflow becomes suspended and the only error message in the workflow history is 'Forbidden.' ResolutionGrant access to write to the Workflow History list for the SharePoint site to the user account running the workflow. This will allow the workflow to display the true error which can then be used to resolve the underlying issue. Additional InformationWhen an O365 subscription has less than 30 days to the end of the subscription a message is written to the Workflow History list advising of this.This message is written using the permissions of the workflow Initiator. If the workflow has an action set as the first action configured to run with elevated permissions the message will still be written with the Initiators account. If the Initiator does not have access to the Workflow History list in this scenario the workflow will suspend with an access error.
ISSUE After installing the Nintex Document Tagger Add-in, the following error message occurs when opening the add-in:Your System Administrator Has Blocked Add-ins From The Office Store. RESOLUTION Update Active Directory Group Policy to allow add-ins for Office applications. ADDITIONAL INFORMATION This restriction is managed by internal IT teams. For more information reach out to Microsoft Support.
IssueNintex O365 Workflow does not start automatically ResolutionThere are few possible solutions to this issue:- ensure that group members are allowed to see each other - ensure members and group are added to the Nintex History list with Contribute permission- ensure App permission is activated at the root site and the sub-site level
IssueWhen a workflow has an Action Set configured to "Run contained actions at elevated app permissions," the workflowfails for all users, regardless of permission level, upon entering the action set. Without the Action Set configured to "Run contained actions at elevated app permissions," the workflow works without issue. ResolutionNavigate to Site Settings > Manage site features Deactivate "Workflows can use app permissions" Re-activate the same feature
Issue Nintex Workflow for Office 365 is stuck in progress on an action that needs authorization.One of these actions is Nintex Sign powered by Adobe Sign. Resolution When the action runs, an email with the below content is sent to the email address selected for the Authorizing user.From: notification@nintexlive.comSubject: Contains phrases "Nintex Live" and "Request authorization".Contents: Contains links to authorize or deny the operation.When the link to provide authorization is clicked the user is prompted to do the following: Log in to the external service. Allow Nintex Live to access the external service. Option to stop receiving future authorization requests for the service. Additional Information his article applies to all the Nintex Workflow for Office 365 actions that required authorization. Please check the help file of each action for the details regarding the Authorization process.
IssueAfter adding a confirmation message within the Advanced section inside of a form control configuration, the confirmation message fails to appear on button click. ResolutionEnsure that there are no special characters in the confirmation message. This will include characters such as apostrophes (‘).
IssueWhen using Office 365 update Item Permission action, it give an output of the List item URL that can not be use afterward. The URL format return by the List item URL as below: ["https://site_url/Lists/list_name/DispForm.aspx?id=2"] ResolutionConvert the List item URL that has a Collection data type into single text by utilize action "Get Item From Collection". Additional InformationThe details of "Get Item From Collection" can be found here. Related LinksHelp file "Get Item From Collection"
IssueWhen publishing a workflow that has a task action configured, in Nintex Workflow for Office 365, the workflow fails to publish and the following error occurs:Error publishing workflow. A duplicate content type "Nintex Task Outcome Content Type" was found. Error CodeError publishing workflow. A duplicate content type "Nintex Task Outcome Content Type" was found. If the problem persists, contact Nintex support, and quote: Correlation ID: Tenant ID: Time (UTC): ResolutionOpen Site Settings and determine if a Nintex Task Outcomes content type is listed under both Nintex Forms for Office 365 and Nintex Workflow for Office 365. Navigate up to the site from which these content types are inheriting. This is likely the top level site of the Site Collection. Remove all of the Nintex Task content types.Note: This may require deleting workflow tasks from the Workflow Task list, these can be restored after the bad content types have been removed.Once all Nintex Task content types have been re
IssueWhen trying to update the Nintex for Office 365 apps from within SharePoint Online, the 'Get It' button is missing from the SharePoint Online Store page after selecting 'An update for this app is available.' ResolutionThe steps below are to resolve the issue for Nintex Workflow for Office 365, if the issue is also occurring with Nintex Forms for Office 365, please repeat them for that app as well:Open SharePoint Admin Center Select Apps > Manage Licenses > Nintex Workflow for Office 365 Under 'License Managers' select 'add manager' and add an active Admin account Return to the Site Contents and attempt to re-update the Nintex for Office 365 app Additional InformationIf there are expired/deactivated user accounts under License Managers it is recommended to remove these accounts from the list of license managers.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.