cancel
Showing results for 
Search instead for 
Did you mean: 

Workflow failed to publish due to non-FIPS compliant algorithms

Issue

When attempting to publish a Nintex Workflow, the workflow fails to publish and presents an error regarding Federal Information Processing Standards (FIPS).

 

Resolution

This is a SharePoint limitation. According to Microsoft, SharePoint is not FIPS-compliant due to its use of encryption algorithms that do not comply with Federal Information Processing Standards. The non-compliant encryption algorithms are used for processing purposes (i.e. unique identifiers) and are not used for security.
 
To disable FIPS, please do the following on each SharePoint Server within your environment:
 
  • Open Registry Editor (regedit.exe)
  • Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\FIPSAlgorithmPolicy
  • Within FIPSAlgorithmPolicy, right-click on the record named 'Enabled' > Modify...
  • Set the 'Value Data' field to 0 (zero).
  • Click 'Ok'
 

nicksha_0-1597695165798.png

 

Error Code

soap:ServerServer was unable to process request. ---> Failed to publish workflow: <Error><CompilerError Line="-1" Column="-1" Text="Compilation failed. This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms." /></Error>

 

Additional Information

From Microsoft's Security and protection for SharePoint Server 2010:

"SharePoint Server 2010 uses several Windows encryption algorithms for computing hash values that do not comply with Federal Information Processing Standard (FIPS) . . . These algorithms are not used for security purposes; they are used for internal processing. For example, SharePoint Server 2010 uses MD5 to create hash values that are used as unique identifiers."
 

 

Related Links

 

Version history
Revision #:
19 of 19
Last update:
‎12-02-2020 09:28 AM
Updated by:
 
Contributors