Code Fix: Multiple errors logged incorrectly in HostServer log after deleting a User or Group from Active Directory
KB001926
PRODUCT
Issue Description
When deleting a User or Group from Active Directory, multiple errors are logged in the HostServer log file.
Cause
This is caused by the identity cache receiving information that the user or group no longer exists. Only one error should be logged.
Error
The error message states:
"3601861","2016-08-17 08:28:12","Error","IdentityService","64005","ResolvingException","IdentityService.ProviderCacheIdentity:RoleProvider.GetGroup","64005 Failed to resolve 'K2:DENALLIXgroupTest3': Failed to translate name: DENALLIXgroupTest3.","anonymous","0.0.0.0","dlx:C:Program Files (x86)K2 blackpearlHost ServerBin","3601861","3d05ab5ddefb492a8f6d8b83475c63e3",""
Resolution
- Ensure you have K2 4.7 installed.
- Download and Install the K2 4.7 May 2017 Cumulative Update from K2 Partner and Customer Portal.
- Get the K2 4.7 May 2017 Cumulative Update FP4 from Regional Support.
- Install the K2 4.7 May 2017 Cumulative Update FP4 to apply the fix.