Code Fix: After upgrading to K2 4.7 an error occurs when deploying or activating the K2 for SharePoint App

  • 16 February 2021
  • 0 replies
  • 10 views

Badge +6
 

Code Fix: After upgrading to K2 4.7 an error occurs when deploying or activating the K2 for SharePoint App

KB001923

PRODUCT
K2 blackpearl 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

 

Issue Description

After upgrading to K2 4.7, when you deploy the K2 for SharePoint App from the App Catalogue to a site collection or activate the app on a site collection, a warning Red exclamation mark is displayed but contains no error message. In debug mode a Protocol Violation error is thrown.

 

 

Error Message

The following error message occurs:
<Exception ExtendedDetail="T" Title="Error" Description="An exception has occurred."><Type Name="Type">SourceCode.SmartObjects.Client.SmartObjectException</Type><Message Name="Message">The server committed a protocol violation. Section=ResponseStatusLine

 

 

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and Install the K2 4.7 May 2017 Cumulative Update from K2 Partner and Customer Portal.
  3. the K2 4.7 May 2017 Cumulative Update FP3 from Regional Support
  4. Install the K2 4.7 May 2017 Cumulative Update FP3 to apply the fix.

Considerations

Set your Host Server logging level to warning as Retry logic has been built in. Retries are logged as warnings.

 


0 replies

Be the first to reply!

Reply