Cannot update SmartObject via Sharepoint list

  • 24 February 2022
  • 0 replies
  • 0 views

Userlevel 4
Badge +16




 








Cannot update SmartObject via Sharepoint list































This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.






LEGACY/ARCHIVED CONTENT


This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.




Issue



A SharePoint list has been previously 'appified'.



When selecting the K2 App in the ribbon, the following error appears: 



 



"Thread 1: Exception of type 'SourcecoCode.SmartObjects.Client.SmartObjectException' was thrown"



 



Image



Symptoms



The following steps did not resolve the issue:



- Clear browser cache



- Restart K2 Blackpearl service



- Retest using other users on other devices.



Troubleshooting Steps



- To resolve this issue, open the K2 setting hidden list on the SharePoint site collection by appending _layouts/15/start.aspx#/Lists/K2%20Settings/AllItems.aspx to the Site Collection URL.



Eg. https://portal.denallix.com/_layouts/15/start.aspx#/Lists/K2%20Settings/AllItems.aspx



- You will see two entries: "Solution_Designers" and "Soultion_Participants".



Take note of their values.



- Clear out the entries one at a time, then see if you can access the K2 for SharePoint App from the list.



 



This issue can occur if there is a change in the SharePoint domain name after the K2 for SharePoint App has been registered.










0 replies

Be the first to reply!

Reply