After changing the port number that the K2 Server uses, "Error receiving buffer" appears

  • 24 February 2022
  • 0 replies
  • 1 view

Userlevel 4
Badge +16




 








Error receiving buffer































This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.






LEGACY/ARCHIVED CONTENT


This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.




Issue



After changing the port number that the K2 Server uses, you can no longer edit workflows in K2 Studio. An "Error Receiving Buffer:Invalid Packet Header Received" message appears.



 



The following image is an example of the error:



 



 





 



 



Symptoms



This occurs once the K2 server has been changed and the set up manager has been run to change the port number. However, there are environment fields that still point to the old port number.

Troubleshooting Steps



Check the environment fields in K2 Studio. This can be done by navigating to the right-hand side via the context browser. It may be best to have a look at K2 Workspace to check that the Workflow Management server, Workflow and SmartObject server fields are pointing to the right port



 



Once this has been done, redeploy the solution and you there should be no further issues here. 










0 replies

Be the first to reply!

Reply