Learn about the latest Nintex capabilities at New at Nintex
This section contains archived Nintex for Office 365 Knowledge Articles.
Recently active
IssueNintex app(s) are installed on a site and can bee seen in the site contents and are visible on most lists, however they are missing from one list ribbon. ResolutionNavigate to the list If the list is not in Classic view change to Classic view. Click on the cog and select "Edit Page" On the main list web part select "Edit web part" from the top right hand corner black triangle Change the Toolbar Type to "Full Toolbar" Click Apply. From the page tab above the ribbon click stop editing. Icons will now appear on the List ribbon.
IssueWhen an external email address is configured in a Assign a Task workflow action, the following error occurs:Sorry, we're having trouble reaching the server ResolutionConfigure the Assign a Task action with an email address within the Office 365 tenancy. Additional InformationEmail recipients in Assign a Task action are restricted to those with email accounts in the Office 365 tenancy. Related LinksHelp File - Assign a Task
IssueThe conditional criteria, for a conditional start workflow are no longer visible from the workflow setting. This occurs after the Workflow designer is reopened, after modifying the conditional criteria. ResolutionThe issue has been fixed on the latest version of Nintex Workflow for Office 365 Apps that was released on 21th November 2018. Make sure that the site has the latest version of Nintex Apps
IssueWhen using a Nintex Form to edit Properties of a Document inside of a Document Set, you are presented with "Sorry, something went wrong - An Unexpected Error has occurred" upon submission. The changes to the document's properties are still properly saved. ResolutionThis issue was resolved in the February 2019 update for Nintex Forms for Office 365.
ISSUEWhen working with Nintex for Office 365, Nintex keeps creating new Nintex Task Outcomes content types with random numbers after the name.ERROR CODERESOLUTIONThe creation of additional task content types is expected behavior in Nintex for Office 365.ADDITIONAL INFORMATIONEach time that a new 'Custom Outcome' is applied to either a Start A Task Process or Assign A Task action, Nintex will create a new 'Nintex Task Outcome' content type with a GUID appended to the end, so that it can maintain the new 'Custom Outcome' associated with the workflow. For example: Nintex Task Outcomes 0e08932e-a343-4753-925f-220ed22be6cbRELATED LINKS
IssueWhen using a Send an Email action in a workflow created in Nintex Workflow for Office 365, 1.0.4.0, and changing the formatting of any “inserted reference” item, it will create many empty SPAN tags in the HTML. Resolution Additional InformationThis is a known issue that is currently under investigation.
IssueWhen using "Office 365 upload file" action and the file name contains a special character such as {} ~, the following error may occur: Some parameters failed the validation check. - [InputDestinationFileName] : The file name is invalid. ResolutionThis issue has been fixed on the latest version of Nintex Workflow for Office 365.
IssueWhen configuring the Document Generation action, the configuration indicates the document quota has been exceeded, even when no documents have been created. ResolutionContact Sales@Nintex.com. Have Sales verify that the 'Nintex for Office 365' asset and 'Nintex Document Generation' asset are active. If both assets are active, confirm that both assets are on the same contract. Even if both assets are created and live, if they're on separate Salesforce contracts, Document Generation for Office 365 will not work. Additional InformationThis is caused by a mismatch in the licensing with the associated customer account.Looking at the JSON call that is made when the action configuration loads, you will see the following inside of developer tools: {"Total":0,"Used":0,"IsTrial":false,"SubscriptionStartDate":"0001-01-01T00:00:00","SubscriptionEndDate":"0001-01-01T00:00:00","OverUsage":0,"QuotaOverageAllowance":0,"ErrorType":400,"IsSuccess":false,"ErrorPayload":null,"Info":null,"Subscripti
IssueOffice 365 Nintex workflows are triggering multiple instances. ResolutionOpen the Nintex workflow causing issues in the Nintex Workflow designer. Navigate to the workflow settings in the designer ribbon and check the workflow start conditions. It possible the workflow is configured to start when a item is updated or when a specific condition is met. The workflow is most likely meeting multiple start conditions, causing the workflow to trigger more then once. Example: The workflow is configured to start when a item is created or modified. The workflow starts and the first action performs an update to the current item. The update causes the workflow to start again based on the workflow start conditions. The workflow start conditions need to be adjusted or the workflow design changed.
IssueWhen using Office 365 query user profile action with connection manager, this error might occur:Unable to reach destination server ResolutionEnsure that "workflows can use app permission" feature has been activated via site settings >> Manage site features If MFA (Multi-factor authentication) has been enabled in tenant then execute the cmdlet Set-SPOTenant -LegacyAuthProtocolsEnabled $true Additional InformationSet-SPOTenant - https://docs.microsoft.com/en-us/powershell/module/sharepoint-online/Set-SPOTenant?view=sharepoint-ps
IssueNintex Form displays blank when item is edited. ResolutionIf a SharePoint column contains illegal characters or non printable characters it may cause an issue opening a Nintex Form for editing. For example, if you copy a table from Excel and paste it in a Multi Line Textbox (Enhanced rich text) and save it, you may have an issue opening that form because it may include illegal characters or non printable characters. For resolution, click edit in the SharePoint list (or click "Quick Edit" button in the list ribbon) and clear the data in the Multiple lines of text column.
TopicWhen trying to start a Component Workflow from another Component Workflow which started from the List Workflow, the following error may occur: "Could not start child workflow" InstructionsThe maximum depth limit when calling component workflows is set to one. The parent-child workflow depth cannot exceed one. Additional Information For example, consider the following scenarios with different depths:Scenario 1: A List workflow is designed to start Component workflow 1 and Component workflow 1 starts Component workflow 2. This workflow will fail in this scenario as the depth exceeds the limit as shown below: List workflow (depth 0) Component workflow 1 (depth 1) Component workflow 2 (depth 2) Scenario 2: Component workflow 1 that starts Component workflow 2 is added to a workflow. The workflow is successful because the depth does not exceed the limit value as shown below: Component workflow 1 (depth 0) Component workflow 2 (depth 1) Related Linkshttps://help.nintex.com/en-US/o
TopicWhen using "Start Workflow" action in the Nintex Workflow for Office 365 to start a workflow in a SharePoint List that has more than 5000 items, the following error may occur: The attempted operation is prohibited because it exceeds the list view threshold enforced by the administrator. InstructionsModify the "Start Workflow" action configuration of the field "Item ID or GUID" to use the Item ID instead of GUID. Additional Information Related Links https://help.nintex.com/en-US/office365/Designer/Actions/StartWorkflow.htm
ISSUEWhen creating a list with geo-location fields, items using those fields cannot be viewed and the following error occurs:Index was outside the bounds of the array. If the problem persists, contact your support team with the following information:ERROR CODERESOLUTIONThis issue is currently under investigation. As a workaround, try the following:Navigate to Site settings. Regional settings. Select the Time zone and change it to something other that what is shows and wait for changes to take place. Once the time zone is set, set it back to your current time zone. Once you have confirmed its changed back, go back to the list and form and try to access the item again.ADDITIONAL INFORMATIONRELATED LINKS
IssueWhen trying to use the "Calculated value" control with the fn-Replace function, in the following format: ("textToModify", "replacePattern", "replacement") The result will be different from the one expected. ResolutionResolution:Remove the two quotations that were placed around the 'TextToModify' parameter so that it should be in this format: (textToModify, "replacePattern", "replacement")
IssueWhen using a conditional formatting rule to set the background color for a Multi-line text control, the background color is not changed the way that it is with a Single-line text control with the same rule. ResolutionAdjust the padding of the Multi-line text control through the control configuration to add a slight border to the control. Additional InformationThe difference in behavior between the Single-line text control and the Multi-line text control is due to the size of the "text" area within each control type. The Single-line text control border stretches beyond the "text" area, and already gives the control a slight border. The Multi-line text control has no outline as the "text" area of this control stretches to the edges of the control bounds. The formatting rule actually applies the color change to the background of the controls to which it is applied, not the "text" area itself.
IssueWhen trying to add one of the Nintex for Office 365 apps to a SharePoint site, the app addition fails and the following error occurs:Something went wrong trying to add app. Click to retry. When trying again, the app addition fails again with the same error. ResolutionContact SharePoint Online support and request to have the app site manually cleared from Azure.
IssueWorkflow gets stuck when trying to create documents using custom templates with Create List Item Or Document Set Action. ResolutionSave and close the template document if it has been opened from the SharePoint library. Otherwise this will cause the workflow to become stuck and not progress as the template file is still open by a user.
IssueWhen using the Office 365 workflow actions, the workflow instance suspends with the error: 'Unable obtain security token, authentication failed.' ResolutionVerify that the account being used does not have Multi-Factor Authentication (MFA) enabled, as MFA is not currently supported by Nintex for Office 365 Verify that the action works with an @domain.onmicrosoft.com account vs. an @domain.com account. Success with an @domain.onmicrosft.com account vs a domain account will indicate an issue with ADFS. The Microsoft Remote Connectivity Analyzer can be used to investigate ADFS issues further. Error CodeUnable obtain security token, authentication failed. Additional InformationSteps for testing with Microsoft Remote Connectivity Analyzer: Microsoft Remote Connectivity Analyzer Select Office 365 tab Under Office 365 General Tests select 'Office 365 Single Sign-On Test' Select 'Next' Fill in domain user credentials and the verification captcha Select 'Perform Test' Review results for A
IssueWhen an Office 365 workflow runs after a task becomes overdue, the following error might occur:Workflow was unable to authenticate this request. Detail: Token could not be retrieved; retries exceeded the limit Error CodeError “Workflow was unable to authenticate this request. Detail: Token could not be retrieved; retries exceeded the limit” ResolutionEnsure that the task escalates to a valid user or group account:Open the affected workflow in Nintex Workflow Designer for Office 365. Double-click the Task action that caused the workflow suspension. Navigate to "Escalate and auto-complete options". Check the value from the field "Escalate to". Ensure this User or Group exists within the SharePoint Online environment.Go to Site Setting > People and Group. Find if the user or group from this page. If the User or Group does not exist, either create this account or update the Task action to escalate to a valid account.?
IssueWhen using Quest's Mextalogix Essentials for Office 365, Nintex workflows fail to migrate with an "unauthorized" error. ResolutionEnsure that you have whitelisted https://nintex.onmetalogix.com. You can check the availability of this services URL by visiting https://nintex.onmetalogix.com/nintex/version, and you will see a result similar to the screenshot below:
IssueWhen opening an existing Nintex Forms Office 365 for editing in the Nintex Forms designer the form does not load and the designer is stuck on the spinner.The existing form works and can be used for new, edit and view but the form cannot be opened in the designer. ResolutionIt is possible that the form has been edited and saved in the designer but a file has become corrupted.To get back to the previous form follow these steps. 1. Open SharePoint designer (https://www.microsoft.com/en-au/download/details.aspx?id=35491) and go to the site > All Files > Lists > ListName > Item. In this folder you will see 2 XML files. Export a copy of NFForm.xml. This is the current form that loads when you select new item. We will use the export of the file to import back into the designer in a later step. 2. The file that is loaded when you edit and save in the designer is found using a web browser at https://<tenanturl>/site/NintexFormXml You will need to find the file that co
QuestionHow often do O365 actions retry if they fail to connect to the O365 tenant. AnswerEach query execution has a timeout of 1.5 minutes. The default timeout of the SharePoint SDK (CSOM) is what is usedAll Office 365 actions have the same retry behavior. Additional InformationTo add functionality to the the O365 workflow engine Nintex's Office 365 actions call outside of the tenant to Nintex Infrastructure. The Nintex infrastructure then logs back into the tenant to perform the required activity. Sometimes there can be issues with connecting to the tenant due to a range of issues between Microsoft, Nintex and the Internet. As this is the case Nintex has retry functionality built in so that the workflow does not immediately suspend.
IssueIn a Nintex Responsive Form for Office 365, the line break was missing between the data in a multiple lines of text column. ResolutionChange the column type from plain text to Enhanced rich text (Rich text with pictures, tables, and hyperlinks) and republish the form.
ISSUEWhen using OKTA authentication, the following error occurs for Office 365 Live actions:Error: Direct login to WLID is not allowed for this federated namespaceERROR CODEError: Direct login to WLID is not allowed for this federated namespaceRESOLUTIONNintex does not support OKTA Single Sign on Provider. Use @on.microsoft.com account to resolve this issue. ADDITIONAL INFORMATIONRELATED LINKS
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.