Solution showcase: Learn how to use Nintex CE Platform
This section contains archived K2 blackpearl Knowledge Articles.
Recently active
Error when accessing new Sharepoint UI: "The query string "redirect_uri" is missing or invalid"kbt146005PRODUCTK2 blackpearlTAGSMicrosoft SharePointThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.LEGACY/ARCHIVED CONTENTThis article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.IssueWhen accessing an app using the SharePoint new look and feel, the following error is encountered on appredirect.aspx: Sorry, something went wrong The q
Known Issue: Redirect URI error when browsing to the K2 Appit for SharePoint Application PageKB001868PRODUCTK2 blackpearl SummaryWhen accessing the K2 Appit for SharePoint application page using the SharePoint Online page layout view, the following error occurs: CauseThe new SharePoint Online page layout does not parse in the correct parameter value for the host URL on redirect. Notice the {HostUrl} placeholder in the URL below:".../sites/AppCat/K2AppitforSharePoint/Pages/Settings.aspx?SPSiteURL={HostUrl}&tsapp=1" This is a SharePoint Online issue. WorkaroundRevert to Classic page layout view as described in SharePoint Online User Interface changes.
Accessing K2 Display Form Error - Guid should contain 32 digits with 4 dasheskbt129096PRODUCTK2 blackpearlTAGSMicrosoft SharePointThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.LEGACY/ARCHIVED CONTENTThis article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.IssueView Item on SharePoint 2013 via Generated SmartForms results in Guid Error “Guid should contain 32 digits with 4 dashes”.SymptomsInstead of the Display form rendering y
401.2 Error appears when opening a form on Android Mobile appkbt134820PRODUCTK2 blackpearlTAGSK2 mobile appsThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.IssueA 401.2 error appears when you attempt to open a form within the mobile app when using an Android mobile phone device.SymptomsWhen you access the app to view the form a 401.2 error appears. This error can be see in the error logs from the mobile app.ResolutionThis issue has been resolved in the latest K2 app for Mobile which was released in August 2017 (v1.2.16).
Delete Process Instance Log Data Without Workflow Present KBS100030 PRODUCT K2 blackpearl TAGS K2 Workspace Management Console This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties. Issue A workflow has been deleted without the "Delete all historical (log) data for selected versions" option being ticked to removed the log data with the workflow from an appit environment, this means that there is now orphaned worklow associated log data contained in your K2 database for the removed workflow, and since the workflow has now been removed there is no way to select the option to remove the orphaned log data for the workflow. Symptoms When a workflow is deleted and the option to "Delet
28083 EscalationAction: Unrecognized Guid format errorkbt131906PRODUCTK2 blackpearlThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.LEGACY/ARCHIVED CONTENTThis article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.IssueWhen using an Item Reference > Picker (Person or Group) > Name property in an escalation email event, the escalation will error with: 28083 EscalationAction: Unrecognized Guid formatSymptomsUsing an Item Refere
Permission to deploy package deniedkbt136030PRODUCTK2 blackpearlTAGSManagement ConsoleSecurityAdministratorTroubleshooting DocumentThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.IssueIt is not possible to deploy a package to one of the environments which was working previously. A message appears that prevents you from continuing and you are unable to use the package and deployment feature. SymptomsThe following error appears: "User is not a member of the Package & Deployment Role." It is not possible to add yourself to the role, even though you have full permissions to the K2 server. ResolutionIf the user is added directly to the role, the following error appears: "User can't modify on package and deployment" This issue is resolved in Appit version 5 up
Known Issue: Access denied error when attempting to design K2 applicationsKB001806PRODUCTK2 blackpearlSEE ALSO IssueWhen an application designer attempts to access K2 artifacts on a SharePoint list by selecting K2 Application from the list menu, an error message is displayed:"Access denied: To design K2 applications, you must be a member of SharePoint group that has K2 Solution Designer permissions. If you have recently changed SharePoint group membership, please contact your K2 Administrator to use the Synchronize Groups option".The issue only surfaces after the environment was updated to Appit 1.5 Update 2. SymptomsAn application designer user attempts to access K2 artifacts on a SharePoint list by selecting K2 Application from the list menu. The error message is then displayed.ResolutionTo resolve this issue, use the Configure K2 Permissions link in the K2 for SharePoint site page to grant Solution Designers permission to the SharePoint group of the user attempting to design the
Access Denied Error After Changed Site Collection Namekbt132124PRODUCTK2 blackpearlThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.LEGACY/ARCHIVED CONTENTThis article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.IssueAfter changing the name of a site collection in SharePoint, all users are getting Access Denied errors when attempting to access the Appit application.SymptomsUsers are getting the error: Access Denied To design K2 a
SmartObject Missing From SmartObject Service Tester Categorykbt130573PRODUCTK2 blackpearlThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.IssueIt is possible that sometimes a SmartObject will not be in the original category that it was created in, but still be present in the SmartObject Service Tester under the All SmartObjects category.SymptomsIf the SmartObject is not present in its original location, then there are really two different possibilities: the SmartObject has been moved or the SmartObject has lost its category data.ResolutionTo resolve this issue, you can go into K2 Designer and search for the SmartObject using the search box above the category explorer. Once you have found the SmartObject in question in the search results, you can right-click it
Messages Stuck In QueueKBS100030PRODUCTK2 blackpearlThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.LEGACY/ARCHIVED CONTENTThis article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.Issue Messages are getting stuck in queues. Restarting the K2 Service does process the messages, however with a lot of messages being stuck the service would have to be restarted the same amount of times as the amount of stucked messages that there are
'Documents' Wizard Issues When Deploying via MMC IE 'Get SmartObjects for Service Folders' Method Outputkbt127989PRODUCTK2 blackpearlThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.IssueThe issue stems from the ServiceInstanceXML not being updated when a .kspx file is deployed via MMC that contains document library SmOs, which in turn causes output in regards to available libraries to not reflect all document libraries which should be available via document wizards. This can be tested via 'Get SmartObjects for Service Folders' under the 'Smart Object Service Functions' by passing in the service instance GUID (Service Instance GUID) and 'Document' (Service Object Name) as the parameters for properties in parenthesis and scnull for the remaining three properties
Workflows with "For Each" have disorganized Viewflowskbt134876PRODUCTK2 blackpearlThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.IssueWorkflows with "For Each" have disorganized viewflows after midnight maintenance on Appit environments.SymptomsWhen viewing the viewflow of a workflow, the workflow looks disorganized.ResolutionThis is a known issue and has been identified as a user interface issue. To resolve this issue, please log a support ticket for the K2 Ops team to apply Code Fix 762625: View Flow error in K2 workflow onto your Appit environment. After the fix has been applied, you will be required to perform a cache clear on you browsers, deselect preserve Favorites Website Data and select all other options. Please note you will have to provide your KUI
K2 Smartform viewer Error - "compatibility mode is not supported"kbt130124PRODUCTK2 blackpearlThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.LEGACY/ARCHIVED CONTENTThis article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.IssueWe are running SharePoint 2013 in 2010 compatibility mode. K2 Smartform viewer webpart is not loading SmartForms and an error appears in K2 4.6.11:"Your browser's compatibility mode is not supported"After
K2 Workflow does not open in Appit, a "Working on it" message appearskbt134788PRODUCTK2 blackpearlThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.IssueThis issue is caused by updating the K2 Appit environment and not replacing the updated version of the K2 for Appit Application in the SharePoint App Catalogue. SymptomsK2 Workflow does not open in Appit. A "Working on it" message appears.ResolutionPlease contact K2 Support and get the correct the version of the K2 for Appit App. Upload the correct version to the App Catalog and run the registration wizard on the different Appit Instances as needed. This will allow you to access your K2 Workflow as normal.
Requirement for K2 SharePoint Workflow Integration configured for Content Approval on a SharePoint publishing site.KB001247PRODUCTK2 blackpearlLEGACY/ARCHIVED CONTENTThis article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein. IssueIn the current design for K2 SharePoint Workflow Integration configured for Content Approval, one is able to create K2 SharePoint Workflow Client events in which the Destination Rule is set up to use the Plan Just Once option. SharePoint 2007 and SharePoint 2010 are not single instance aware and in the case where K2 SharePoint Workflows are configured as default Content Approval workflow, SharePoint throws an error when attempt
Deployment of event-based workflow fails with 401kbt129721PRODUCTK2 blackpearlTAGSDeploymentThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.LEGACY/ARCHIVED CONTENTThis article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.IssueDeployment of event-based workflow fails with 401. Only workflows that are set to start based on SharePoint Events (like Item Added) will fail. This affects K2 Designer and P&D deployments of workflows.
Appit - Workflow Error on mail event after deployment on new update with error (System.Object[]' cannot be converted to type 'System.String[])kbt129672PRODUCTK2 blackpearlTAGSEmail EventInline FunctionsThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.LEGACY/ARCHIVED CONTENTThis article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.IssueWorkflow Error on mail event after deployment on new update with error System.Object[]' cannot be
For some users an error appears: "the workflow does not exist on the server" when starting manuallykbt137171PRODUCTK2 blackpearlThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.IssueWhen manually running a workflow, a user will get the below error message stating that the workflow does not exist on the K2 server and it cannot be run: "The selected workflow does not exist on the K2 server. Contact your administrator for more information." This is on the SharePoint Item/Doc > Ellipses > K2 Workflows. SymptomsSome user accounts will get this message while others might not.The user account could have site collection and full control on Sharepoint but this will not change the behavior.The user will also be unable to push the "Start" button for that workflow f
Get Document reference passes 'Modified by' Email as array causing 'System.Object[]' cannot be converted to type 'System.String[]' exception to appearkbt131764PRODUCTK2 blackpearlThis article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.IssueThe following error occurs on Workflows at the set data fields event: Object of type 'System.Object[]' cannot be converted to type 'System.String[]'. The error will always appear at this Workflow event regardless of any input being added on the SharePoint Document.SymptomsThis behavior appears when there is a particular design in place for the Workflow. Refer to the below characteristics that define where this behavior occurs: - The Workflow is configured to create an Item Reference to a document within a SharePoint Document Library
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.