Skip to main content
Nintex Community Menu Bar

Workspace: Protocol Violation

  • July 15, 2008
  • 4 replies
  • 27 views

Forum|alt.badge.img+5

I am getting an error on my dev server when trying to view the process overview, statistics, or user performance in workspace.


"The server committed a protocol violation. Section=ResponseHeader Detail=CR must be followed by LF"


Has anyone seen this error?


Environment -


Win2k3 SP2 server with WSS 3.0/InfoPath Form Services/K2 BP 0803


Win2k3 SP2 server SQL 2005.

4 replies

Forum|alt.badge.img+9
  • Nintex Partner
  • July 16, 2008

Hi Cory.


As per http://forum.dotnetpanel.com/forums/p/2012/11274.aspx, you may consider adding the below node to the Workspace web.config:


<system.net>
<settings>
<httpWebRequest useUnsafeHeaderParsing="true" />
</settings>
</system.net>


 


Forum|alt.badge.img+6
  • July 22, 2008

As it turns out, it is the web.config belonging to the Sharepoint Portal site that needs to be updated.  


 1) Find the correct web.config by navigating in IIS Manager to the Sharepoint Portal virtual server


2) Right-click the Sharepoint Virtual Server > properties > HomeDirectory tab > copy the "Local Path"


3) open the "Local Path" you just copied in explorer > right-click the web.config >  Open With > Notepad


4) at the end before </configuration> add the lines:

<system.net>
<settings>
<httpWebRequest useUnsafeHeaderParsing="true" />
</settings>
</system.net>

 


Forum|alt.badge.img+9
  • Nintex Partner
  • July 22, 2008

Just to clarify, i think there are 2 different scenarios here (but both had the same error message)...


- Cory hit this issue with Workspace reports, so I think the Workspace config file was the correct location to recommend he look.


- Joseph encountered this with an InfoPath Forms Server form.  Thus the reason for the SharePoint config file.


Thus I think the moral of the story is, if you see this error, determine what web site is hosting the offending page and then investigate that specific config file.


Forum|alt.badge.img+5
  • Author
  • July 22, 2008
That is correct Bob. However, it is the same server.