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Symptoms


Issue:

renaming a view broke a workflow. When tried to rename the view back to its original name, I get the following error: "A View with the name 'LimitsChanges_CaseReview.ItemView' already exists in the target category. Either rename the LimitsChanges_CaseReview.ItemView or select an alternate target category."

 

Diagnoses


Diagnosis:

The ticket was linked to an existing Bug item (Bug: K2SF. Rename and Save on view/form results in an error (form already exists).

Tried to repro the issue by:

andgtCreating a new view with the name "Neo Test SQL DB Item"
andgtRenamed the view by editing the view and going to the 'General' tab on the view and renaming the view to "Neo test SQL Item".
andgtAfter renaming the view I went back and tried to rename the view to its old name "Neo Test SQL DB Item" and got the error ""A View with the name 'LimitsChanges_CaseReview.ItemView' already exists in the target category. Either rename the LimitsChanges_CaseReview.ItemView or select an alternate target category."
 

Resolution

Resolution:

Workaround:
After the name change, don?t save the form, click Next and then Finish, open the form or view again and Save it.




 
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