Skip to main content
Nintex Community Menu Bar

Tutorial Deployment error

  • December 20, 2007
  • 13 replies
  • 44 views

Forum|alt.badge.img+2

Hi, 


I've been going through the "K2 [blackpearl] Tutorial", but now I'm stuck at the "Building a Process in the K2 designer for Visual Studio" => Lab 2 => Exercise 1 => Step 9 Build and Deploy the Process.


I have a totally fresh Environment with a separate Blackpearl SP 1 Server machine and my development client machine environment.


 When I try to deploy the process at step 9, I get the following error message:


 Error 1 Task Error: System.Exception: Forms Generation publishing has failed: Please ensure that if you are deploying this project that you are not attempting to do so on client. Deployment package needs to be created and run on the server in order to publish forms correctly. - System.Exception: Forms Generation publishing has failed: Please ensure that if you are deploying this project that you are not attempting to do so on client. Deployment package needs to be created and run on the server in order to publish forms correctly.
   at SourceCode.DeploymentTasks.FormsGeneration.ClientEventDeploymentTask.HasPublishedWebsite()
   at SourceCode.DeploymentTasks.FormsGeneration.ClientEventDeploymentTask.HasPublishedWebsite()
   at SourceCode.DeploymentTasks.FormsGeneration.ClientEventDeploymentTask.Execute()
 C:K2 TutorialsK2 TutorialDenallix Prcess TutorialobjDebugDeploymentDenallix Process Tutorial.msbuild 68 6 Denallix Process Tutorial


I've read the following articles that might have something to do with this:


http://k2underground.com/forums/thread/19379.aspx
http://k2underground.com/forums/thread/20603.aspx
http://kb.k2workflow.com/articles/kb000188.aspx


I have Visual Studio Web Deloyment Projects 2005 installed, but that didn't help either. I've tried to create a Deployment Package, but didn't succeed with the demployment on the server. I get the same error on the target server when MSBUILD is run.


 Anyone else had the same problem?


-Jukka


 

13 replies

Forum|alt.badge.img+4
  • Nintex Partner
  • December 28, 2007
I'm assuming the machine that has the K2 HostServer on it is a Win2003 SP2 machine.  Is the workspace also installed on this box?  Is the machine with Visual Studio also have K2 blackpearl SP1 on it?

Forum|alt.badge.img+2
  • Author
  • December 31, 2007

All the answers to your question are YES.


-Jukka


 


Forum|alt.badge.img
  • January 5, 2008
I have recently gone through the tutorial process as well and have received the same exact error at the same point in the tutorial.

Forum|alt.badge.img
  • January 5, 2008
I have gone through the tutorial and have received the same error at the same exact point. I am working on a Stand Alone  fresh installation of K2 SP1.

Forum|alt.badge.img+1
  • Rookie
  • January 18, 2008
I have gine through the tutorial and I get the same error "deployment package needs to be created and run on the server in order to publish forms correctly system exception forms generation has failed

Forum|alt.badge.img+9
  • Nintex Partner
  • January 19, 2008

I seem to recall that there is a limitation with the web deployment package where it had to be local to the web server that it was deploying to.  i.e. Your K2 designer for Visual Studio needs to be local to the web server and the web deployment package needs to be installed on that machine.  Subsequently, you can copy off the generated web files to another server as needed.


Does this help?


Forum|alt.badge.img
  • January 21, 2008
I got the same error message as well when I try to deploy the tutorial solution. Is anyone able to resolve the error? 

Forum|alt.badge.img+1
  • January 22, 2008

Hi,

I too received the same error so created a deployment package that I copied to the K2 Server, and then ran msbuild against it as described in the http://kb.k2workflow.com/articles/kb000188.aspx article.

It failed on the K2 server with the exact same error.

Regards

Vince
 


Forum|alt.badge.img+4
  • February 25, 2008

Hi Vince and guys,


 Please try this:


(1) Make sure this dll is in the GAC of the K2 Worskpace Server 


SourceCode.SharePoint.Workflow.WebControls.dll


 (if you dont find it, it should be on the machine where K2 MOSS components are installed. just search for it.


 (2) On your the Development machine with VS2005 installed, make sure


SourceCode.WorkFlow.RuntimeServices.Objects.dll is in the GAC


Create Depoyment pacakage on client machine, move that to Workspace Server.


Run the MSBuild and it should be able to deploy well.


Regards,


Marco


Forum|alt.badge.img+2
  • March 26, 2009
Impossible to add assembly SourceCode.Workflow.RuntimeServices.Objects.dll to the GAC because it does not have a strong name....

Forum|alt.badge.img+2
  • March 27, 2009

The problem comes from a different K2 Blackpearl version btw client (with Visual Studio) and server.

I don't have the pb anymore since I upgraded the server.


Forum|alt.badge.img
  • April 15, 2009
You really need to install WebDeploymentSetup.msi on the k2 server.  That finally solved my problem.

Forum|alt.badge.img+1
  • March 24, 2010

I already installed WebDeploymentSetup.msi on the k2 server. and it's still have the same error. can anyone provide me a solution regarding the error?