Hi!
I'm facing some problems with getting a sharepoint process to start...
Background info: everything is installed on a W2K3 server machine, which has a sharepoint installation in it's default website. I made another website registration on port 1024 and installed K2.NET on that website. So now that website on port 1024 has K2V3, with underneath that Workspace, WorkspaceService, InfoPathService, and SharePointProcessService installed.
I made an infopath process, which would simply send me a mail when a form was approved or dissapproved - which worked perfectly.
Then, I got to testing a sharepoint process, and there something goes wrong - I can design a process (which was supposed to send me a mail when a document was deleted from a certain document library), compile it, and export it to the server. The user properties are ok (I am allowed to start the process), server is running, Sharepoint is configured correctly (so events are fired when docs are uploaded, deleted, etc), but whatever I do, the process doesn't start... Although the infopath process still works.
So, I thought maybe the "Office Services" during installation should be installed onto the sharepoint website, not on the website I created for K2.
I removed K2, reinstalled it, but now with "InfopathService" and "SharePointProcessService" on the default (Sharepoint) website (they are both under "Office Web Services" during installation, so it's either both of 'em or nothing), and the other things on the K2 website on port 1024.
But now, the Infopathprocess doesn't work anymore: I get a SOAP CONFIG error when trying to submit the form. As for sharepoint processes, I can't create a Sharepoint process because of an error when entering the K2.net Web Service URL in the wizard - I tried using the default website and the k2 website on port 1024, both didn't resolve anything. I can't browse to the service (on default website) either from IIS - it either gives me a 404 or 403 error.
I thought it might have to do something with the Application Pool my websites are running in: K2-site on port 1024 runs in the DefaultApplicationPool, while Sharepoint runs in it's own ApplicationPool. But changing the application pool settings didn't resolve the problem either. Besides, it should be changed :-)
So, I guess what I want to know is: is my installation correct? Do I have to install all K2 parts onto the website I created for K2 on port 1024, or do I have to install the Infopath and SharepointProcess services onto the Sharepoint website (default website)?
If it's the first option: how come Sharepoint events don't seem to start my process?
If it's the second option: how come the Infopath process gives me a SOAP error, and I can't create a Sharepoint process anymore?
Any clues, anyone? :)
Sharepoint Process not starting + installation on SPS/W2K3
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.