Skip to main content
Nintex Community Menu Bar

Server Error when running Process Information Report

  • October 19, 2007
  • 1 reply
  • 12 views

Forum|alt.badge.img+2

Has anyone ever seen this error?



Server Error in '/K2V3/Workspace' Application.


Validation of viewstate MAC failed. If this application is hosted by a Web Farm or cluster, ensure that <machineKey> configuration specifies the same validationKey and validation algorithm. AutoGenerate cannot be used in a cluster


 


This is the first time we've seen this.


 


Tuff

1 reply

Forum|alt.badge.img+2
  • Author
  • October 25, 2007

Problem was with .Net Framework 2.0.  Here's the resolution as provided from K2 Technical Support.


This is caused by a known bug in .NET Framework 2.0. Teh work around it to add the following to the Workspace web.config:

<system.web>
<pages enableViewStateMac="false" />
</system.web>