Skip to main content
Nintex Community Menu Bar

Kerberos Authentication

  • October 3, 2006
  • 2 replies
  • 28 views

Forum|alt.badge.img+2
Hello Friends

I work in an environment where Kerberos is turned on in DEV, but NTLM is being used in TEST and PROD.

I'd like to homogenize our enviroments and get Kerberos turned on in TEST and PROD.

In all 3 environments, we have 2 front end SPS servers. K2Server is installed on one of those front end web servers.

My supervisor has asked me if Kerberos is going to break anything. Sorry to ask such a broad question - I don't know what I don't know - will turning on Kerberos cause other things (SPS, WSS, InfoPath forms libraries, etc.) to fail?

Thanks in advance, Terry

2 replies

Forum|alt.badge.img+10
  • Nintex Partner
  • October 3, 2006
Hi,

Because Kerberos handles secures communication between all components on a network, it could potentially "break" anything and everything.

Having said that, it is not a permanent break.
Authentication between servers will fail if Kerberos is not successfully set up. That means that K2.net will not be able to communicate with SharePoint and vice versa.

I would advise you to read through:
http://kb.k2workflow.com/Articles/KB000123.aspx and http://www.microsoft.com/technet/prodtechnol/windowsserver2003/technologies/security/tkerbdel.mspx before you attempt to configure anything.

Schedule enough down-time before you configure as well so that you can fix issues if the arise.

Regards,

JohanL

Forum|alt.badge.img+2
  • Author
  • October 3, 2006
Thanks JohanL!

Terry