Symptoms
Issue:
Partner received the following error:
Microsoft.Exchange.WebServices.Data.AutodiscoverLocalException: The Autodiscover service couldn't be located.
Diagnoses
Diagnosis:
We conducted various tests to make sure the partners Exchange was working effectively:
http://help.k2.com/onlinehelp/k2blackpearl/icg/4.7/default.htm#ts/exchange.htm
We also made sure that task notification mails and normal e-mails were working effectively within the K2 Product.
Eventually the developers built us a debug assembly, and we identified the following error:
61012 Exception from message source eSmartAction Email account]: System.NullReferenceException: Object reference not set to an instance of an object.
at SourceCode.MessageBus.Ews.ExchangeWebServicesConnection.OnMessageReceived(MessageType item)
at SourceCode.MessageBus.Ews.ExchangeWebServicesConnection.<>c__DisplayClass29_0.b__2(Object s, FindItemCompletedEventArgs e)
at SourceCode.MessageBus.Ews.ExchangeWebServicesConnection.OnMessageReceived(MessageType item)
at SourceCode.MessageBus.Ews.ExchangeWebServicesConnection.<>c__DisplayClass29_0.b__2(Object s, FindItemCompletedEventArgs e)
Resolution
Resolution:
We identified that the 'MyAnalytics' feature for Office 365 sent automated e-mails to the Smartactions account, and within the K2 Product, we do not cater for those type of e-mails. We asked the partner to disable that feature, and everything worked as expected. We have logged a new TFS item to investigate this further.