Symptoms
Issue: Exchange Error
When Client try to send an email from the Smartforms web application they experience an error that an email cannot be sent :
SourceCode.Workflow.Common.EWS: Autodiscover not available and mail cannot be sent. Reconfigure K2 server with valid Exchange settings.
Diagnoses
Diagnosis:
During meeting with client , client had informed us that personnel from K2 were on their premises and pointed out that the Clients DTC was not enabled which was the cause of the issue.
Informed Client if issue occurs again to please log a new ticket.
Resolution
Resolution:
After enabling the DTC the client has confirmed that the emails have were going through.