Skip to main content
Nintex Community Menu Bar

Error when using K2 Package and Deployment tool and K2 for SharePoint to create a package

  • October 10, 2015
  • 0 replies
  • 7 views

Forum|alt.badge.img+9


 

Symptoms


Getting the following error when trying to create any package:
"34160695","2015-09-15 09:19:01","Error","System","2025","InternalMarshalError","SourceCode.Hosting.Server.Runtime.HostServerBroker.InternalMarshal","2025 Error Marshalling SourceCode.Deployment.Runtime.DeploymentServer.Send, Member 'ItemId' was not found.
at System.Runtime.Serialization.SerializationInfo.GetUInt32(String name)
at SourceCode.Deployment.Management.BeginValidateItemState..ctor(SerializationInfo info, StreamingContext context)
at lambda_method(Closure , SerializationInfo , StreamingContext )
at SourceCode.Runtime.Serialization.FastBinaryFormatter.DeserializationInfo.CreateInstance(Type type, SerializationInfo info, StreamingContext context)
at SourceCode.Runtime.Serialization.FastBinaryFormatter.ReadComplexValue(Stream stream, Type t, Type typeHint, DeserializationTablesand tables)
at SourceCode.Runtime.Serialization.FastBinaryFormatter.Deserialize(Stream stream, Type typeHint, DeserializationTablesand tables)
at SourceCode.Runtime.Serialization.FastBinaryFormatter.Deserialize(Stream serializationStream)
at SourceCode.Deployment.Runtime.DeploymentServer.Send(String sessionName, Byte[] stateBytes)","","","DRTEXWTESTSPK2:F:Program Files (x86)K2 blackpearlHost ServerBin","34160695","609a0988eaad44a5a2c1bfd5566f5b16",""


 

Diagnoses


The error was caused by installing MS Security Update, KB3083185.
 

Resolution

Uninstalling this update resolved the issue.