Skip to main content
Nintex Community Menu Bar

Error deploying K2 Worklist Webpart

  • November 13, 2008
  • 5 replies
  • 27 views

Forum|alt.badge.img+6

I'm getting the following error when I try to deploy the Worklist Webpart in SharePoint.  Anyone have any ideas?



Name:k2worklistwebpart.wsp
Type:Core Solution
Contains Web Application Resource:Yes
Contains Global Assembly:Yes
Contains Code Access Security Policy:No
Deployment Server Type:Front-end Web server
Deployment Status:Error
Deployed To:None
Last Operation Result:Some of the files failed to copy during deployment of the solution.
Last Operation Details:MOSS1 : http://mysite:51003/ : MySites - 51003 :
Error: Cannot add the specified assembly to the global assembly cache: SourceCode.Workflow.TaskList.dll.
Last Operation Time:11/13/2008 12:57 AM

5 replies

Forum|alt.badge.img+6
  • November 13, 2008

Hi Jason,


I believe this is an issue with update 320. Can you confirm the version and update level.


If you are using 320 I suggest you try 330.


 


Forum|alt.badge.img+5
  • November 17, 2008

Fortunately, there is an easy workaround to this:



  • Go to C:WINDOWSassembly (the GAC).
  • Right-click on "SourceCode.Workflow.TaskList.dll" and select Uninstall.
  • Re-deploy the worklist web part.

HTH!


Forum|alt.badge.img
  • May 10, 2009
icon-quote.gifGail:

Fortunately, there is an easy workaround to this:



  • Go to C:WINDOWSassembly (the GAC).
  • Right-click on "SourceCode.Workflow.TaskList.dll" and select Uninstall.
  • Re-deploy the worklist web part.

HTH!



I had exactly same problem on BlackPearl 0807 and fixed it by above. thanks!!


Forum|alt.badge.img+1
  • November 29, 2012

I also got a similar (but different) issue upgrading an 0803 install to 4.5.


My error message was:


Last Operation Result: Some of the files failed to copy during deployment of the solution.


Last Operation Detail: MOSS1 : Error: The copying of this file failed: LAYOUTSK2ClosePage.html. Access to the path 'C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions12TemplateLAYOUTSK2ClosePage.html' is denied.


The cause of the problem for me, was that there were files in the C:Program FilesCommon FilesMicrosoft SharedWeb Server Extensions12TemplateLAYOUTSK2 folder that were marked read-only for some reason.


Clearing the read-only flag on all the files and folders in the above folder solved my issue.


Forum|alt.badge.img
  • June 30, 2014

I experiencing the same issue with the SourceCode.Workflow.TaskList.dll and getting it to deploy.  However, when I sent to the Uninstall it from the GAC as per the directions, it says that it "could not be uninstalled because it is required by other applications".  I have stopped the K2 Black Pearl Server in Windows Services and nothing seems to be running in my task manager.. Can you tell me what could possibly be creating this issue?