Skip to main content
Nintex Community Menu Bar

1.5 Upgrade issue. Management package is failing to deploy.

  • October 25, 2016
  • 0 replies
  • 5 views

Forum|alt.badge.img+6


 

Symptoms


1.4 to 1.5 upgrade is failing with the management package unable to deploy.

Error:
Error %d, Level %d, State %d, Procedure %s, Line %dViolation of PRIMARY KEY constraint 'PK_Form_Field'. Cannot insert duplicate key in object 'Form.Field'. The duplicate key value is (ee81e81a-15bc-49d6-b752-44a4d7859ce1).
Transaction count after EXECUTE indicates a mismatching number of BEGIN and COMMIT statements. Previous count = 1, current count = 0.
 

Diagnoses


Sent the ticket to our developers so that they can investigate this behaviour on upgrading from 1.4 to 1.5 accordingly
 

Resolution


The issue was resolved using a code fix