cancel
Showing results for 
Search instead for 
Did you mean: 
michaelpe
Nintex Newbie

fn-IsMemberOfGroup not working like I think it should

Jump to solution

I have a form that I'm trying to validate off of a usergroup I created:

Capture.PNG

POApprovers is a SharePoint group. No matter what name I put in, it will not accept the name. The goal is to only submit if they type in a name from this group. Is there another way I could do this or am I going about this the wrong way? I seen where some people say it magically started working for them, or deleting the field and re-adding it fixes it, but not for me so far. Thanks everyone!

Labels: (2)
Tags (1)
0 Kudos
Reply
12 Replies
Automation Master
Automation Master

Re: fn-IsMemberOfGroup not working like I think it should

Jump to solution

what sort of field is this on your form?

0 Kudos
Reply
michaelpe
Nintex Newbie

Re: fn-IsMemberOfGroup not working like I think it should

Jump to solution

Sorry, it's a "person or group"

0 Kudos
Reply
Highlighted
Automation Master
Automation Master

Re: fn-IsMemberOfGroup not working like I think it should

Jump to solution

so you're trying to restrict the user seleted in the people picker to be only members of a certain group?  why don't you do that in the list settings, column settings?

Reply
michaelpe
Nintex Newbie

Re: fn-IsMemberOfGroup not working like I think it should

Jump to solution

Hi Cassy, I tried that approach as well but it was acting funny. It would only allow people from that group to use that field. So if you weren't in that group, it wouldn't allow any name to be resolved. I want everyone to be able to use that field, but validate it from a certain group in SharePoint

0 Kudos
Reply
Automation Master
Automation Master

Re: fn-IsMemberOfGroup not working like I think it should

Jump to solution

so you want them to be able to enter anyone in there but then have validation error if the resolved person isn't a member of the group?

Reply
michaelpe
Nintex Newbie

Re: fn-IsMemberOfGroup not working like I think it should

Jump to solution

Correct. Or do you know of an easier way to accomplish this?

0 Kudos
Reply
janeyres
Nintex Newbie

Re: fn-IsMemberOfGroup not working like I think it should

Jump to solution

Hi,

Could you check to make sure your POApprover group settings are like this:

It may be set to Group Members only view.

Jan

View solution in original post

Reply
Automation Master
Automation Master

Re: fn-IsMemberOfGroup not working like I think it should

Jump to solution

ah good shout Jan Eyres

Reply
michaelpe
Nintex Newbie

Re: fn-IsMemberOfGroup not working like I think it should

Jump to solution

Just made this change Jan, but it is still not letting me submit with using someone's name in that group.

0 Kudos
Reply