cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Send notification not working

Jump to solution

I have a Send notification action as a part of the Flexi task process but it is not sending any emails. The email was initially going to Created By in To field and one or two users in the CC field. Since one of those users can be empty I removed them completely leaving only the Created By in the To field. Still not working. Any idea why this notification is not generated? All Flexi task emails work and I also added the Send notification in a different part of the workflow and it also works.

 

nintex-email.png

Labels: (1)
Tags (1)
0 Kudos
Reply
7 Replies
Workflow Hero

Re: Send notification not working

Jump to solution

Weird. Please try the following. Add another flexi , just to test, and add a notification there. Does it work?

In the case it works, create your Flexi again from scratch

0 Kudos
Reply
Workflow Hero

Re: Send notification not working

Jump to solution

So I believe I narrowed it down to the Pause action. I added some notifications and only the one before the Pause worked. Then I removed the Pause and all of the notifications worked... Any idea what is going on?

0 Kudos
Reply
Workflow Hero

Re: Send notification not working

Jump to solution

Probably due to SharePoint Timer Job : in fact problemshould be the same using SharePoint Designer instead of NINTEX !

 

For what I understand, when using the "Pause" action, the workflow continues with different account/permission.

That means :

- the workflow starts with an account (current user) allowed to send emal

- it goes trough the SharePoint Timer Job during the pause

- After this, the rest of the WOrkflow is executed with timer job user credentials, instead of initiator

 

Worth checking Timer Job account permissions....

 

See  http://www.lxway.cc/201511/sharepoint-designer-workflow-email-after-pause-until/  : similar problem without Nintex

Reply
Not applicable

Re: Send notification not working

Jump to solution

Try to fill from address with created by or something.

This issue with all sites or just for this site only?

0 Kudos
Reply
Workflow Hero

Re: Send notification not working

Jump to solution

SP Timer Service runs under the farm account. Where do I check if that account has permissions to send emails?
Thanks!

0 Kudos
Reply
Workflow Hero

Re: Send notification not working

Jump to solution

First, verifiy that this farm account is a member of the local Administrators group on the server.

Then you an use some test script on the server, such as : Intercepting SharePoint Email and Testing Outgoing E-Mail Settings | The Chris Kent

Be sure to use "[Microsoft.SharePoint.Utilities.SPUtility]:Smiley FrustratedendEmail" to be sure your action is executed by SharePoint.

0 Kudos
Reply
Workflow Hero

Re: Send notification not working

Jump to solution

I wasn't able to figure it out in my dev environment but it seems to be working in production. I will keep looking into it. Thanks for your help!

0 Kudos
Reply