cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Publishing Reusable Workflows Correctly?

What is the best practice for publishing reusable workflows that are associated with content types?

When I republish a workflow at the root web on the content type it seems as though all the lists in my sub-sites that are using the content type don't always get the update.

Sometimes the sub-site lists also use a previous version of the template instead of the most current one I just published.

Are there some steps I am missing other than just publishing the workflow?

0 Kudos
Reply
4 Replies
Not applicable

Re: Publishing Reusable Workflows Correctly?

Hi James, We assume that you are not using Content Type Hub. The issue you describe might be because SharePoint didnt push the workflow association down to the sub site list using the same content type. does it work after some time or does stay using the older version? Thanks

0 Kudos
Reply
Not applicable

Re: Publishing Reusable Workflows Correctly?

I am not using the content type hub, but we are using site content types so they are declared in the site collection root web and then used in the lists in the sub sites.

I guess I have never really checked if it takes time and then starts to work. This is all happening on my local dev machine which now may have a suspect install.

I am currently working with support because I have an issue with the RunIf and SetACondition blocks not running properly inside a User Defined Action.

Now that I write it here I suppose it is possible that the publishing is being affected by the state of my dev environment?

0 Kudos
Reply
Not applicable

Re: Publishing Reusable Workflows Correctly?

Hey James,

Did you find an answer? I'm having the same problem on our SP2013 environment.

0 Kudos
Reply
Not applicable

Re: Publishing Reusable Workflows Correctly?

Hey Davy,

Unfortunately I haven't resolved this yet, but that is partially from being moved off the project while I spear head our upgrade to SP2013.

My plan of attack was to create a simple reusable workflow and just keep adding Log in history list blocks to it and see if I consistently get the updates.

The CSR I spoke to said it might simply be a timing issue and that it may take a while to persist to all the subsites where the content type is being used, but there doesn't seem to be anyway to get a "green light" for when the publish has persisted to all sites.

If I come up with anything I will let you know.

0 Kudos
Reply