cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Nintex Workflow is not sending emails

Hey guys,

I hope one of you can help me with this problem.

A nintex workflow has been configured with sending e-mails at certain points. In the test environment (QA) it all works fine but on the Productive system it does not.

The problem on the Prod-System (2 FrontEnds) is that no one is receiving an email, though the workflow says that the e-mails were send properly. There is no error message from the workflow. The SharePoint itself sends emails properly (for alerts, etc.).

Environment:

  • SharePoint 2010
  • Installed version (test and prod): Nintex Workflow 2010 (2.3.7.0)
  • Prod-System -> 2 FrontEnds

   What have we done so far:

  • We retracted and re-deployed Nintex on the SharePoint with no avail.
  • IIS-reset – no avail
  • Checked all mail settings and they are equal on QA and Prod. And on QA it is working
  • Tried another workflow - same problem occurred.

Following Error-Message from the SharePoint occurred:

Failing sending email: GeneralFailure.: System.Net.Mail.SmtpException: Fehler beim Senden von Mail. ---> System.IO.DirectoryNotFoundException:

Ein Teil des Pfades "D:\SMTP Mail\Drop\6e0158e2-642a-4083-ae04-fef82fb5f83b.eml" konnte nicht gefunden
werden.     bei System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)     bei System.IO.FileStream.Init(String path,
FileMode mode, FileAccess access, Int32 rights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)     bei System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)     bei System.IO.FileStream..ctor(String path, FileMode mode)     bei System.Net.Mail.SmtpClient.GetFileMailWriter(StringpickupDirectory)     bei System.Net.Mail.SmtpClient.Send(MailMessage message)     --- Ende der internen Ausnahmestapelüberwachung ---     bei System.Net.Mail.SmtpClient.Send(MailMessage message)     bei Nintex.Workflow.HumanApproval.Message.SendMessage(SmtpClient client, MailMessage msg) (Build:2370)

 

The error message above says: "D:\SMTP Mail\Drop\6e0158e2-642a-4083-ae04-fef82fb5f83b.eml”  - It does describe an error for incoming mails,  doesn´t it?!  But our problem is that the Nintex does not send any email. How is this connected? Furthermore all our SMTP mail configurations are standard on C:\.

 

Thank you in advance!

0 Kudos
Reply
3 Replies
zach_puckett
Nintex Newbie

Re: Nintex Workflow is not sending emails

I would recommend reviewing your Global settings in Central Administration > Nintex Workflow Management to confirm that email is configured correctly. Additionally, if you are using SMTP I would recommend reviewing your settings in IIS on your web front ends to confirm there are no issues. The email address must be the same in SMTP as it is in Central Administration.

If you do continue to have issue please be sure to notify support@nintex.com

Reply
chad_austin
Nintex Newbie

Re: Nintex Workflow is not sending emails

Can you check the IIS SMTP settings on each of the servers that are in the farm and see if any are

configured to use a drop folder? I’m curious to see if somewhere (by mistake) it was changed to use a

drop folder in IIS and the settings are overriding the default SharePoint settings. When checking IIS,

make sure you check both the server, and site settings.iis.png

Reply
simon
Nintex Newbie

Re: Nintex Workflow is not sending emails

Also worth checking that you can send an email using SharePoint Designer workflow.

Is a really quick way of you validating whether it is Nintex Workflow configuration that is the issue here, or more general environmental configuration such as SMTP setup

Reply