cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Nintex Workflow Exception during provision programmatically

I have created  a code to provision workflow pro-grammatically through C# Code.
But i am facing exception as below

"Server was unable to process request. ---> Workflow action 'Nintex.Workflow.Activities.Adapters.NWDocGenAdapter' is not allowed on site Test:11111/sites/test"

I am using below code to provision workflow.

byte[] arrWorkflowFile = System.IO.File.ReadAllBytes(workflow.SourcePath);
SPList list = currentWeb.Lists.TryGetList(workflow.List);
if (list == null)
{
EventLogWriter.Write(LogSeverity.Critical, LogCategory.Configuration, "The target list with the name " + workflow.List + " does not exist in the site. so can not import the nintex workflow.");
}
else
{
workflowService.PublishFromNWF(arrWorkflowFile, workflow.List, workflow.Name, true);

}

Can any one Help me out for this exception ?

Thanks in n advance.

Labels: (1)
0 Kudos
Reply
2 Replies
Workflow Hero

Re: Nintex Workflow Exception during provision programmatically

Hello Dipen,

I am not sure about the cause of the problem, but we have seen it in migrated/newly installed environment. To resolve the problem. have a look at the article: Error: "Workflow action 'Nintex.Workflow.Activities.Adapters.NWStartWorkflowAdapter' is not allowed ...

Error "Workflow action Nintex.Workflow.Activities.Adapters.NWStartWorkflowAdapter is not allowed on ... 

I hope it helps....

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Nintex Workflow Exception during provision programmatically

A also have this error. Have just migrated from SP2013 to SP2016. I'm pretty sure the problems is caused by the fact that in the Nintex Administration for Action Settings, there is no longer support for this adapter (Nintex.Workflow.Activities.Adapters.NWDocGenAdapter). I can see it in the SP2013 env but not in the SP2016 env. Infact I chose to allow all Core actions and Connectors and the error still persists.

Is there anyone that can shed some light on this? Is this feature no longer supported in SP2016 v4.3.2.0.

0 Kudos
Accept as Solution Reply