cancel
Showing results for 
Search instead for 
Did you mean: 
cblackl2000
Nintex Newbie

Nintex Workflow Copy Item Failed, No Error, Workflow Completed

Jump to solution

I have a workflow that is using Copy Item to take from a main SharePoint List A and copy item to List B, and then notifies the initiator that their request has been received.  This works most of the time, but I have a percentage of records that indicate workflow completed and this appears correct in the history detail view, but List B does not have this item.  List A and B are carbon copies of each other for fields, field types, etc.

When this was identified, I pushed the missing records manually and this worked just fine.  I have also confirmed that this is not permissions related as User X has records that copied properly as well as ones that did not.  I am using a variable for NewListItem as ListItemID.

Does anyone know what might be causing this, how to fix it, how to capture that although the workflow thinks it completed, it truly did not perform what was expected.  I am considering a pause and then sending information back from List B to List A, but that seems both complicated and unnecessary.

List A to List B Copy Item Configuration

Labels: (2)
Tags (1)
0 Kudos
Reply
2 Replies
Automation Master
Automation Master

Re: Nintex Workflow Copy Item Failed, No Error, Workflow Completed

Jump to solution

Might be handy to see what is going on around the copy item. Perhaps there's a Commit issue?

View solution in original post

Reply
Highlighted
cblackl2000
Nintex Newbie

Re: Nintex Workflow Copy Item Failed, No Error, Workflow Completed

Jump to solution

Thank you, Ryan.  This pointed me in the right direction.  I have just re-read the post ‌ and it very much appears the Commit will resolve this. 

Reply