Not applicable

Fields are not displaying in order after adding Hide Show Rule

Can anyone tell me why every time I apply Hide Rule on the sections in my forms the fields start changing there order and start overlapping each other. I tried adding empty labels between the fields, but that does not help if I have these fields under Repeating section. I can avoid overlapping using empty labels outside the repeating sections, but inside the section I can't do anything. Please help.

oder1.PNG

oder2.PNG

Tags (2)
0 Kudos
Reply
4 Replies
Not applicable

Re: Fields are not displaying in order after adding Hide Show Rule

Sal,

This is most likely happening due to how you have set up your rules. I recommend you review your rules and ensure there are not overlapping controls in this form.

Cheers,

Andrew Beals

Reply
Not applicable

Re: Fields are not displaying in order after adding Hide Show Rule

I moved the controls in one panel to group them. it worked.

Thanks.

Reply
allan48728
Novice

Re: Fields are not displaying in order after adding Hide Show Rule

Putting them into the same panel is certainly one option. I've also found that the order in which fields are displayed at run-time can be influenced by the order in which the show/hide rules are listed in your "Rules" panel. For example, if you have Section 1 and Section 2, and then you have a show/hide rule for Section 2 listed immediately above the show/hide rule for Section 1, then Section 2 will be displayed above Section 1 in the form at run-time. This can happen even if Section 1 and 2 are displayed correctly in Nintex Forms Designer.

It appears that Nintex Form rules are executed from top to bottom in the order in which they're displayed in the "Rules" panel. This is similar to how Javascript files are read from top to bottom.

Reply
lpnolan
Novice

Re: Fields are not displaying in order after adding Hide Show Rule

I have meticulously reviewed the rules order, control order, and put all controls in a panel.  The overlap still occurs.  Has anyone found a definitive solution to this issue?  We are using Nintex Forms 365 (v. 1.2.3.0)

Reply