cancel
Showing results for 
Search instead for 
Did you mean: 

Error in cascading drop down with filtering by a control’s value

Nintex Newbie
0 11 2,048

I am trying to create a cascading drop down in Nintex Form, but the filtering by a control’s value its not working (the filter works by a specified value).

The control works perfectly on our site, but not at the site of a customer.

 

This is the XML error that occurs when the page loads

<?xml version="1.0" encoding="utf-8"?>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

  <head>

    <title>Request Error</title>

    <style>BODY { color: #000000; background-color: white; font-family: Verdana; margin-left: 0px; margin-top: 0px; } #content { margin-left: 30px; font-size: .70em; padding-bottom: 2em; } A:link { color: #336699; font-weight: bold; text-decoration: underline; } A:visited { color: #6699cc; font-weight: bold; text-decoration: underline; } A:active { color: #336699; font-weight: bold; text-decoration: underline; } .heading1 { background-color: #003366; border-bottom: #336699 6px solid; color: #ffffff; font-family: Tahoma; font-size: 26px; font-weight: normal;margin: 0em 0em 10px -20px; padding-bottom: 8px; padding-left: 30px;padding-top: 16px;} pre { font-size:small; background-color: #e5e5cc; padding: 5px; font-family: Courier New; margin-top: 0px; border: 1px #f0f0e0 solid; white-space: pre-wrap; white-space: -pre-wrap; word-wrap: break-word; } table { border-collapse: collapse; border-spacing: 0px; font-family: Verdana;} table th { border-right: 2px white solid; border-bottom: 2px white solid; font-weight: bold; background-color: #cecf9c;} table td { border-right: 2px white solid; border-bottom: 2px white solid; background-color: #e5e5cc;}</style>

  </head>

  <body>

    <div id="content">

      <p class="heading1">Request Error</p>

      <p>The server encountered an error processing the request. The exception message is 'Object reference not set to an instance of an object.'. See server logs for more details. The exception stack trace is: </p>

      <p>   at Nintex.Forms.SharePoint.WebControls.MultiLookupControlV1.Filter(String fieldName, Object value)

   at Nintex.Forms.SharePoint.FormControls.SharePointLookupFormControl.&lt;GetDataValuesToRender&gt;d__4.MoveNext()

   at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext()

   at System.Linq.Buffer`1..ctor(IEnumerable`1 source)

   at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)

   at Nintex.Forms.SharePoint.FormControls.BaseDataAccessFormControl.GetDataValuesToRenderAsString(FormControlProperties controlProperties, String contextData)

   at Nintex.Forms.SharePoint.FormControls.SharePointLookupFormControl.GetControlData(String controlProperties, String contextData)

   at Nintex.Forms.SharePoint.Services.NfWcfService.GetDataForControlAsync(GetDataBody body)

  at SyncInvokeGetDataForControlAsync(Object , Object[] , Object[] )

   at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]&amp; outputs)

   at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc&amp; rpc)

   at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc&amp; rpc)

   at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc&amp; rpc)

   at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)</p>

    </div>

  </body>

</html>

Can anyone provide some insight to this issue?

Thanks,

Tags (1)
11 Comments
Automation Master
Automation Master

can you post configuration of your cascaded dropdowns?

when you moved form (and possibly list too) between environments, have you made sure form definition is valid in target env?

Nintex Newbie

Drop down 1

Drop down 2

The list

I have not done a migration of lists. The configuration is the same in both environments.

Automation Master
Automation Master

what I'd try as very first is to make a small change in both control's configurations and save it. that way configuration should be revalidated.

if that doesn't help then I'd removed both controls and configured them completely anew.

Nintex Newbie

I already did. The filtering by a value is working.

And The lookup function is not working

Automation Master
Automation Master

ok, so let's try to clarify your setup.

could you explain where did you get that XML error message from? it's not quite common...

snapshot of "The List" you posted above is for Provincia or Canton List?

can you place calculated value control on a form and set its formula simply to  'Provincia' (from named controls) to see how does it evaluate?

can you post setup of Canton list?

there should be a  'Provincia' field of type lookup that reference Title field in Provincia list. is it so?

Not applicable

@ Marian Hatala,

I also have the same problem. When I placed a calculated value, It is showing 1;#Name

I guess that is not getting translated into second list 

 

Nintex Newbie

Hello everyone.. I have the same issue,  I did find the solution yet.  Someone has the solucion. pls help me.

Nintex Newbie

Hello members. Same problem here. Anyone has a solution ?

Help. Thx a lot.

Nintex Newbie

Currently experiencing the same thing on 2 different environments. Both SharePoint 2019, one with version 5.1.1.20 and one with version 5.1.2.0 of Nintex Forms.
A form that has 2 lookups. One that points to a countries list. One that points to a regions list with a countries column.
When a country is selected, the dropdown with regions should change and filter on country. Doesn't do that. Even worse... My regions dropdown is completely disabled. When I remove the filtering it shows the values. When I set it to filter on specific value, it also works and the filtering is applied. However, when I set it to filter based on the country dropdown... it does nothing. It's disabled.
In the ULS, I'm seeing the following errors appearing when this happens:

The lookup list 'UARRegions' could not be found in web '/sites/nintex' with error: System.NullReferenceException: Object reference not set to an instance of an object.

UARRegions is the actual Regions lookup list.

Another error from the ULS:

Failed to retrieve form control for canvas. Error: Object reference not set to an instance of an object

When I select a country, a new error appears in the logs:

MultiLookupControlV1 - Filter. fieldName: Country; value: 1;#Luxembourg. Exception: System.NullReferenceException: Object reference not set to an instance of an object.

When I remove the filtering on regions, all errors disappear. Not sure why it complains on a lookup list that cannot be found ONLY when you filter it. Makes no sense.

 

The funny thing is.. on one of these environments, we imported the Legacy List Lookup v1 control and configured that EXACTLY the same and that works perfectly and the filtering is working as it should.

 

Opened a ticket with Nintex Support... they imported the form and the list templates in their environment and there ... it works.
Really annoying. We keep on working on this.

 

Nintex Newbie

Hello everyone,

Found that cascaded  dropdowns not working when there si not root site at thé top of the sites collection (no site at http://domain/ only at http://domain/sites/...). Add an 'enterprise search' as root and WORKS !!

Nintex Newbie

@u1173 ,

 

thank you, thank you, thank you! You are a lifesaver!

Indeed, I didn't have a root site collection. I created one and the filtering is working as expected now!!!