Showing results for 
Search instead for 
Did you mean: 

July 2017 Mission

this document is response to July 2017 Mission - Fix it and run!

so how I proceeded

  1. set up environment by the description in above linked document
  2. imported form and workflow to CommunityMissionSource list as required. so far so good.
  3. created an item.
    no workflow started. so went to check workflow settings whether it is configured to start on item creation. since it wasn't I configured it to do so.
  4. created another item, workflow started automatically.
    however it failed on create item action.
  5. suspected it fails on Lookup field update. so added log history + commit pending changes action before create item action to see what's value of Lookup variable being written to Lookup field
  6. noticed it contains whole repeating section XML in encoded form. so investigated where it is populated.
    found it is populated with Query XML action at the beginning. so added set variable action after first Query XML action  and set it up to XmlDecode parsed out repeater XML
  7. noticed as well incorrect delimiter in create item action between Lookup variable and static lookup reference to Type1. so added missing # sign
  8. ran workflow. it worked already, and created respective items in CommunityMissionDestination list.
    however, still Date field was not correctly copied over.
  9. so investigated how it is processed and found out that dDate text variable picked from collection is not converted into Date datetime variable which is used in create item action.
    so added convert values action to make conversion.
  10. run the workflow once again and luckily it worked as expected
  11. enjoyed it!




Version history
Revision #:
1 of 1
Last update:
‎07-26-2017 04:16 PM
Updated by: