cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Workflow does not start when creating new item using 'Copy to SharePoint'

Jump to solution

I have a process where I use a drop-off SP Document Library for all users to 'park' document. A NINTEX 2013 WF will after approvals 'Copy to SharePoint' the document to another Permanent Document Library. In the Permanent library I use Document Sets and the Copy to SharePoint copies the document successfully from the Drop Off library to the Permanent library.

 

But a workflow I want to start on 'new item create' in the Permanent library does not start when the new item is created using Copy to SharePoint. Inside the Copy to SharePoint action I am using an elevated permission user with (more than) enough permissions to start a workflow in any library in the site. When manually adding a new document directly into the Permanent library the workflow starts fine.

 

Any ideas?

Labels: (1)
0 Kudos
Reply
3 Replies
Workflow Hero

Re: Workflow does not start when creating new item using 'Copy to SharePoint'

Jump to solution

Hi,

 

could you tell which user is the author in the library where you have copied the file? System Account created or modified file will not trigger workflows (also standard SharePoint ones) unless you make a change in the settings of your SharePoint farm (have a look on How can I make a workflow automatically start when an email is received? - SharePoint Stack Exchange...)

 

Giacomo

0 Kudos
Reply
Not applicable

Re: Workflow does not start when creating new item using 'Copy to SharePoint'

Jump to solution

Thank you, that worked. I was using a user with Farm/Admin level permissions. Changed to a 'user' with lower permissions and the workflows now start as expected. Thank you!

0 Kudos
Reply
Workflow Hero

Re: Workflow does not start when creating new item using 'Copy to SharePoint'

Jump to solution

Hi, could you mark my answer as correct?

Thanks and have a good day!

Giacomo

0 Kudos
Reply