cancel
Showing results for 
Search instead for 
Did you mean: 
gunnarreyr
Nintex Newbie

Web Request not populating text field

I have Web Request control in Nintex Forms which I use to call a soap web service. In the run now everything works and I get result I want with my xPath. But doing exactly the same in the actual web request action and wanting the display value from the results showing as text in the field gives me blank text field.

To clarify, my query works in the run now but I get a blank text field running the form.

Anyone that can help with this?

0 Kudos
Reply
4 Replies
nchamid
Nintex Newbie

Re: Web Request not populating text field

Hi,

Would you mind sharing a screenshot of the 'Web Request' control configuration ?

Thanks,

0 Kudos
Reply
gunnarreyr
Nintex Newbie

Re: Web Request not populating text field

Thank you. Here´s what I can send.

Web Reqeust

The xpath for display is: //Level1/Level2/FullName/text()

In the "Run Now" I get the results normal (have tested also with Soap UI) and testing the XPath gets me the results I want.

Shouldn´t the results (which is one row) display in the web request text field in the form?

0 Kudos
Reply
nchamid
Nintex Newbie

Re: Web Request not populating text field

Hi,

Thank you for providing more information.

As you said, you're able to see the results in 'Run Now' mode, this might be the issue. 

Have you copied and pasted XML to 'Request Body', if yes please try this :

Seems like stupid, but this is what me along with Nintex Support did, when I faced similar issue.

Please refer my comments in this thread.

Let me know.

0 Kudos
Reply
gunnarreyr
Nintex Newbie

Re: Web Request not populating text field

Thank you for this but this was one of the first things I tried but without any luck. Actually I need to do this each time I run the "Run now" action. If I don't I get 500 Internal error each time I do a test run. I am thinking if that's something I need to look into?

0 Kudos
Reply