cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

State machine doesn't work

I had to redesign my workflow to add Pending to my outcome task. I added a state machine with two states, approval and pending

under state machine I have assign flexi task and the out comes are approved/declined/pending

under pending I have change state and I move to Pending state

then I have a wait action for a day and I change state to go to approval state and send out the flexi task again

It doesn't work the workflow doesn't trigger the flexi task under state machine, any idea why?

Labels: (1)
0 Kudos
Reply
10 Replies
burkslm
Nintex Newbie

Re: State machine doesn't work

Where in the state machine is the flexi-task?

0 Kudos
Reply
burkslm
Nintex Newbie

Re: State machine doesn't work

Hold up! You said under the 'Pending' state, you change the state to 'Pending' state! Did you type that wrong? Did you mean that you changed the state to 'Approval' state? If it wasn't a mistake, that could be your problem. Can you get me a screen shot of this?

Lisa

0 Kudos
Reply
Not applicable

Re: State machine doesn't work

I think I figure out where is the problem, I added End State and now it is working

but it doesn't change state from pending action to superintendent approval take a look and tell me if you know why

0 Kudos
Reply
Not applicable

Re: State machine doesn't work

sorry wrong screen shot, why "PAuse for" doesn't work?

0 Kudos
Reply
burkslm
Nintex Newbie

Re: State machine doesn't work

Change the pause for 5 min and re-test.

0 Kudos
Reply
Not applicable

Re: State machine doesn't work

ok

0 Kudos
Reply
Not applicable

Re: State machine doesn't work

still not working is there any configuration that has to be done on the server to have the "Pause for" run?

0 Kudos
Reply
burkslm
Nintex Newbie

Re: State machine doesn't work

I've never dealt with the server settings before. Try disabling the pause, and run it again to make sure it is the pause that is not working.

0 Kudos
Reply
Not applicable

Re: State machine doesn't work

I have done that already and it ran, but as soon as I enable the Pause then it gets stuck there

0 Kudos
Reply