cancel
Showing results for 
Search instead for 
Did you mean: 
ndterri
Nintex Newbie

Setting Workflow Task fields from "Assign to-do task" action

When configuring an "Assign to-do task" action, we're permitted to set certain Workflow Task fields.  Specifically "Title", "Predecessors", "Priority", "% Complete", and "Due Date":

00-task.PNG

I would like the capability to set an additional, custom field that I created for the Workflow Task.  Is this possible?  If so, how?

Labels: (2)
Tags (3)
0 Kudos
Reply
8 Replies
andrewg
Nintex Newbie

Re: Setting Workflow Task fields from "Assign to-do task" action

i believe so if you first create a new content type with the parent set as workflow task. With this new content type you can add the custom field.

Then back in the workflow, when configuring the To Do task, set it to use Existing and use the name of with custom content type.

Let me know if you have any issues setting that up.

Reply
ndterri
Nintex Newbie

Re: Setting Workflow Task fields from "Assign to-do task" action

Hi Andrew,

Your description is already what my current set is.  The "new" content type I use is named "SPE Input Required".

Nintex00.PNG

The new field that I added to the Workflow Tasks list is named "Part Request State" and it shows that it's used in the "SPE Input Required" content type.

Nintex01.PNG

That's why I was expecting it to show up in the Fields drop down of the To-Do task setup.  :/

I think we're using Nintex 2010 - would it be a limitation of that particular version?

Reply
andrewg
Nintex Newbie

Re: Setting Workflow Task fields from "Assign to-do task" action

It may matter on what the parent type is to the content type. What is it for SPE Input Required?

0 Kudos
Reply
ndterri
Nintex Newbie

Re: Setting Workflow Task fields from "Assign to-do task" action

The Parent is "Workflow Task".  But interestingly, the SPE Input Required content type also has a list of Columns, and the custom column I created in the parent isn't shown ... even though the "Used In" of the parent workflow task indicates that it's used in SPE Input Required. 

What's the difference between the Columns shown on the "SPE Input Required" content type information (screenshot below), and the Workflow Tasks' columns (partially shown in screenshot of my previous post)?

Capture.PNG

Reply
andrewg
Nintex Newbie

Re: Setting Workflow Task fields from "Assign to-do task" action

The Part Request State field is visible to the Workflow Task list as a part of the SPE Input Required content type because that field was probably added to the list level in list settings. It was not added to the SPE Input Required Site Content type which is required here.

If you go to Site Settings, Site Content Types, and add the Part Request State field to the SPE Input Required content type, then it will appear in the task as you need it to.

To do the same addition from the list itself you will notice one extra click is required. Go to list settings, click on the content type SPE Input Required. This is showing the list level content type which can be different from the site content type. Notice here that the Parent is SPE Input Required. Click on it to then see the site level content type that will match your last screen shot and it not showing the Part Request State.

0 Kudos
Reply
cassymfreeman
Nintex Newbie

Re: Setting Workflow Task fields from "Assign to-do task" action

‌ did you resolve this in the end?

0 Kudos
Reply
ndterri
Nintex Newbie

Re: Setting Workflow Task fields from "Assign to-do task" action

Hi Cassy - Yes I was able to come up with a resolution, but it was by other means.  Since the time I posted this question, we upgraded to a newer version of Nintex which proved more capabilities which me allowed to develop an easier solution.  If you're interested in the actual solution, I'd have to dig through my notes to find it.

Reply
cassymfreeman
Nintex Newbie

Re: Setting Workflow Task fields from "Assign to-do task" action

Yes please when you can just so that we can have a solution on this thread for other users  

0 Kudos
Reply