cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Rules are not working in nintex form 2013

Hello All,

I am using nintex form 2013 with latest version. And I am facing the problem with validation rules. I have made one field mandatory using validation rule. But whenever I click on Save button it gets refreshed and rule does not work.  Please suggest me some solution for this. I have to resolve it as soon as possible.

Thanks in advance.

Tags (1)
0 Kudos
Reply
9 Replies
Automation Master
Automation Master

Re: Rules are not working in nintex form 2013

Which condition have you set for the rule ?

Have you tried using the "Required" (Yes/No) field in the settings of the control, "Validation" part ?

0 Kudos
Reply
Not applicable

Re: Rules are not working in nintex form 2013

Hi Chadni,

Please check whether u give any space in the rule. Also make sure you select column  from  the picker in the Validation rule.

Let me know how it goes..

Arvind

0 Kudos
Reply
mlauer
Nintex Newbie

Re: Rules are not working in nintex form 2013

Please show us the rule.

0 Kudos
Reply
Not applicable

Re: Rules are not working in nintex form 2013

I have used "isNullOrEmpty({Self})" Rule for one control. Whenever I click on button it posts back and give the validation for Title field only. I have made that field required from site setting and it works. But I want to stop post back on Save Button click. Because of that rules are not working.I have some controls which are hidden by default and visible on some condition. We have applied rule on that if it is visible then it is mandatory. But that rule is also not working. I think it happens because of post-back.  Please give some solution of it.

0 Kudos
Reply
Automation Master
Automation Master

Re: Rules are not working in nintex form 2013

Which version of Nintex Forms do you have ?

Which condition have you set for the rule that should make the control mandatory if it is visible ?

0 Kudos
Reply
Not applicable

Re: Rules are not working in nintex form 2013

Hi Caroline,

I am using Nintex Form 2.6.0.0 .  I  have one control named category. It is visible if type of employment is "Secondment". And if It is visible then it should be mandatory. I have used following validation rule for that: (equals(parseLookup(TypeofEmployment),'Secondement')) && isNullOrEmpty(SecondmentCategory)

0 Kudos
Reply
Automation Master
Automation Master

Re: Rules are not working in nintex form 2013

Can you try to put this condition in a calculated value on your form to check if it works ?

0 Kudos
Reply
sjferguson
Nintex Newbie

Re: Rules are not working in nintex form 2013

I'm going to ask something really basic here, because I've done it a couple of times - have you attached the rule to the control?

0 Kudos
Reply
Automation Master
Automation Master

Re: Rules are not working in nintex form 2013

Your two spellings of "Secondment" are not consistent.  This would cause your rule to fail:  see how inside the rule you spelled it "Secondement".  

Thanks

Mike

0 Kudos
Reply