cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Nintex Newbie

Preview View only rendering HTML view not the form

Jump to solution

I recently was editing a form in Nintex Forms Designer and when I went to preview my changes it only brought back the HTML code not the view of the form.

 

4-20-2020 5-18-18 PM.png

I tried opening the preview in different browsers but I still got the same result.  Other forms I have created do not do this.

Does any one know what I might of done to cause this and how I could fix it.

 

When I publish the form I can open it with no issues on the SharePoint site.

 

Thanks

 

Labels: (1)
Tags (1)
0 Kudos
Reply
8 Replies
Highlighted
Nintex Employee
Nintex Employee

Re: Preview View only rendering HTML view not the form

Jump to solution
Hi,

Can't say I have ever seen this before.
My guess is that there is something in the form that is messing up the code during preview.
Could be a calculated value or rule or something in one of the controls.
I would need an export of the form to be more precise.
0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Preview View only rendering HTML view not the form

Jump to solution

I am trying to send the export but I get an error that the contents of the attachment does not match its file type.

When I click export the form I get the the file in the following XML format.

 

4-21-2020 1-23-40 AM.png

 

 

 

I am I doing something wrong?

 

 

Tags (1)
0 Kudos
Reply
Highlighted
Nintex Employee
Nintex Employee

Re: Preview View only rendering HTML view not the form

Jump to solution
Hi,

Zip the xml and attach to a reply post.
Reply
Highlighted
Nintex Newbie

Re: Preview View only rendering HTML view not the form

Jump to solution

Thanks for the suggestion.  Please see attachment.

Tags (1)
0 Kudos
Reply
Highlighted
Nintex Employee
Nintex Employee

Re: Preview View only rendering HTML view not the form

Jump to solution
I imported your form and clicked preview and the form rendered as expected.
It looks like the error you are receiving is coming from the browser.
The browser may not like popups. If you publish the form and then click new from the list does the form work?
0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Preview View only rendering HTML view not the form

Jump to solution

Yes, it works fine.

I have tried opening it in Chrome, Edge and IE and I got the same HTML view.  All my other forms are okay.  Do you think may be if I import the file I sent you it might reset it?

I was thinking of just starting the form all over.

Thanks for all your help.

Tags (1)
0 Kudos
Reply
Highlighted
Nintex Employee
Nintex Employee

Re: Preview View only rendering HTML view not the form

Jump to solution
You could try importing into a new list and testing.
0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Preview View only rendering HTML view not the form

Jump to solution
Hi Simon, I imported the the form to a new list and the preview worked fine. Go figure.
I then took that form and and imported to the list that would render only the HTML and published it.

It is now working fine.

Thanks


View solution in original post

0 Kudos
Reply