cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Post Submission of a Form

Jump to solution

Hi

 

I have now successfully published my form and I am able test my form successfully.

 

However when I test the save & submit on my form, but have a another question to ask!

 

I just need to check if this is normal behaviour or if this is something that is in my form / workflow.

 

Once I click on > Save and Submit > This will start the Nintex workflow >

 

However when this happens I don't have a popup stating "Successful Submission" - I am not sure if I should?  Instead the form goes blank as follows -

 

If I wait for a few minutes the above form disappears and it is submitted successfully as below -

 

Is anybody able to confirm if this is normal behaviour for a form once submitted?  Once the save & submit is clicked the workflow is started -

 

As below -

 

Thanks

 

Karen

Labels: (2)
0 Kudos
Reply
14 Replies
pfudala
Nintex Newbie

Re: Post Submission of a Form

Jump to solution

Hi Karen,

 

I think you got a right behavior... with a poor performance.

I'm on Nintex Forms 2013 but I think it would be the same for 2010. There is no message to let you know when the item is added. SharePoint dialog window just closes.

 

While the form goes blank, did you try to open a new page to see if the item is already added?

View solution in original post

0 Kudos
Reply
Not applicable

Re: Post Submission of a Form

Jump to solution

Hi Pierre

Thanks for confirming that there may not be any message to let us know when the item is added.

I am working with Nintex Forms 2010 with SharePoint 2010.  It is quite slow and as you can see the item does eventually get added but takes a few minutes to do so as the window is blank and is seemingly just hanging with the cancel button. I was concerned it was not working correctly.  But as it as you say it is probably just poor performance and needs further testing because the item arrives eventually.

I did not try to open a new page to see if the item has already been added, while the form is blank.  I will be working on the form again this afternoon and will post the outcome.

Thanks for your help on this.

Karen

0 Kudos
Reply
Automation Master
Automation Master

Re: Post Submission of a Form

Jump to solution

Hi There,

Confirming it sounds like right behavior.  What you could do is set the redirect page after your form is submitted.   Or you could throw your form onto a List Form webpart and set the option Configure List Form WebPart Confirmation Message.

Thanks

0 Kudos
Reply
Not applicable

Re: Post Submission of a Form

Jump to solution

Hi Mike

Thanks for your reply

Sorry I am just getting back to my form again and am only just trying the suggestions above.  You mention a redirect page, which I have not thought about, this may be a good idea perhaps with a confirmation page that the form has been submitted? I have a redirect page for my cancel button, so perhaps I could do this here..

Or perhaps a pop up box with confirmation that the form is successful - presumably this is what you mean by a webpart?

I will have a think.  Thanks for your suggestions.

Karen

0 Kudos
Reply
Not applicable

Re: Post Submission of a Form

Jump to solution

Hi

I have been looking into this and found the following post

Show Popup message on the item creation

This has been helpful as well.  It mentions a confirmation message, which I did not realise was available (I am not sure why!)

I will be trying this today

Also just to confirm that I have changed something on my workflow in the background as it was looking at old email addresses which I had to update, so that may have also been a cause of the window hanging.  I will post an update.

Thanks

Karen

0 Kudos
Reply
Not applicable

Re: Post Submission of a Form

Jump to solution

That's great, Karen Lillystone​, let us know how it goes.

0 Kudos
Reply
Not applicable

Re: Post Submission of a Form

Jump to solution

Progress!  We'll look forward to the update!

0 Kudos
Reply
Not applicable

Re: Post Submission of a Form

Jump to solution

Hi

Despite changing the workflow email I mentioned I am still having the same issue -

Pierre Fudala​ as you suggested I opened a separate/new page to see if the item had already been added, but it had not unfortunately.

I am wondering as you mentioned it is poor performance issue as the server has been very slow today generally rendering pages, so this may not help at all.  I about to look into the admin console to see if there is anything there that may be affecting this?

In respect of the confirmation message I tried this yesterday  it did not quite work due to a validation error.  I found that I needed to change a  required field which I had hidden so will try again with this today.

Thanks

Karen

0 Kudos
Reply
pfudala
Nintex Newbie

Re: Post Submission of a Form

Jump to solution

Hi Karen,

Confirmation message will be prompted once the server returns the result of your submission.

So to my opinion, it won't change anything

If you could connect to the server (I mean opening a session on it), are you able to open the Task Manager and see percents used of memory and CPU ?

In my situation, 95% of memory used could lead to performance degradation.

0 Kudos
Reply