cancel
Showing results for 
Search instead for 
Did you mean: 
kjs
Nintex Newbie

Nintex workflow field with id 50c3f294-1c48-406c-92e9-0f1b985b3aa8 and name IsProduction is not found

I have SharePoint 2013 on prem environment using Nintex workflow , When we save sit as template and try to recreate site from the saved template it is breaking with an exception "field with id 50c3f294-1c48-406c-92e9-0f1b985b3aa8 and name IsProduction is not found or not accessible". When i export the site template and look into the schema file in the nintexworkflows list there is a reference to this field under content type but there is not defination found for the field. 

<FieldRef ID="{50c3f294-1c48-406c-92e9-0f1b985b3aa8}" Name="IsProduction" Required="FALSE" Hidden="FALSE" />

Can any one suggest how to repair so this column shows up. or any piointers. 

Labels: (2)
0 Kudos
Reply
3 Replies
bamaeric
Nintex Newbie

Re: Nintex workflow field with id 50c3f294-1c48-406c-92e9-0f1b985b3aa8 and name IsProduction is not found

I'm actually running into this same issue in Nintex Workflow 2013. Were you able to resolve it?

0 Kudos
Reply
iceman
Nintex Newbie

Re: Nintex workflow field with id 50c3f294-1c48-406c-92e9-0f1b985b3aa8 and name IsProduction is not found

Our team also ran into this issue.  We identified the same issue in the Elements.xml in the WSP.  This seems to be a nintex issue, and we have contacted nintex support with all of our research (2 days worth).  We also provided the WSP.  If they come back with a solution I will add it here. 

0 Kudos
Reply
iceman
Nintex Newbie

Re: Nintex workflow field with id 50c3f294-1c48-406c-92e9-0f1b985b3aa8 and name IsProduction is not found

Solution from Nintex:

Thank you for contacting Nintex support. Do you know if the site template was created before a Nintex update was performed? I ask because I came across another case for this same issue, below is the cause and resolution steps from that case:

 

"The 'IsProduction' Field was introduced in 3.1.7.0 for subscription based Nintex. It was later removed due to few critical bugs that we found. Hence, any of the sites which were created from a site template that was updated to the build had the isproduction field reference in there. Hence, we need to manually remove the references from the wsp file."

 

Here is the resolution : 

 

-"Save Site as Template". 

- Go to  Solution Gallery, download the Solution (.wsp) file.

- Rename to .CAB, unpack the CAB.

- Edit the ListInstances\Files\NintexWorkflows\Schema.xml and remove the line:

<FieldRef ID="{50c3f294-1c48-406c-92e9-0f1b985b3aa8}" Name="IsProduction" Required="FALSE" Hidden="FALSE" /> 

 

Repack the CAB file, rename to .wsp, and re-upload the solution.

 

 - Create a site from this site template and try to publish workflows. 

 

Please let me know if that will work for you and if you have any other questions.

 

Reply