cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Issues while migrating nintext databases to new farm (SP 2013 on prem)

We are trying to migrate Nintex from SharePoint online dedicated to SP 2013 on premise  and below are the steps we followed

1. We received 2 databases (config and content) from SharePoint online dedicated

2. We have restored both the databases on SQL server

3. In config database, we have found a table "databases" which has currently two entries/records (both the entries are showing config and content databases)

4. when we tried to attached config database using central admin - "Nintex Workflow Management" --> "databse Setup" --> Configuration Database, we got error - object reference not initialize

5. To resolve the issue in step #4, we have deleted two entries from "databases" table of config database (mentioned in  #3 )

6. Using central admin, we have attached content database by link Add content database,

7. After step #6, we have checked "databases" table of config database where we found 1 entry/record

Here are my questions,

1. How can we add second entry into the  "databases" table in #3

2. Can we attach config database as a content databases

3. Can we restore the config database again with different name and attached it as a content database

It would be really appreciable fi you could provide answers for above questions and best practice document for these scenario

Thanks,

Pankaj Pawar

Reply
1 Reply
kmaj
Nintex Newbie

Re: Issues while migrating nintext databases to new farm (SP 2013 on prem)

Hi,

hope this helps: Moving Nintex Workflow 2013 databases

Kai

Reply