cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Error from Sharepoint with Workflows Settings?

Jump to solution

Hi All

I recently posted a thread about a three way decision at the start of my form. A great suggestion was made about three separate workflows & changing the start up settings. More details here: Pending / Submit & a reminder 

Anyhoo - i successfully (or so i thought) set up the three (or as it turns out 4) workflows & altered the initial settings to start only when a particular option is picked (Scrap/Heel/Other) The 4th is actually triggered by something later in the form (incident details)

When i run a test on this i get the workflow email but when i click on the link it does this:

This is the same for OTHER, SCRAP or HEEL but interestingly the fourth workflow works fine!

To give you an idea this is how the SCRAP option is set up:

I cant spot anything wrong with this. I even changed the form so that it had a menu (rather than radio buttons) that has SELECT/SCRAP/HEEL/OTHER:

So i am convinced that this is due to the initial settings - but am open to suggestions. As a matter of interest this is the settings for option4 (the one that works)

So as u can see it is asking 5 questions & an option in the flow is started depending on what is picked. I am annoyed this one works & the other three don't!

any ideas what i am missing?

Pete

Labels: (1)
0 Kudos
Reply
8 Replies
Workflow Hero

Re: Error from Sharepoint with Workflows Settings?

Jump to solution

are you able to ask your farm admins for the details logged with that correlation ID?

0 Kudos
Reply
Workflow Hero

Re: Error from Sharepoint with Workflows Settings?

Jump to solution

i might - but it might take days.......

0 Kudos
Reply
Workflow Hero

Re: Error from Sharepoint with Workflows Settings?

Jump to solution

What type of fields are the "Scrap Heel Other Option" in the "Scope" step and the other 5 fields in the "Incident Details" step?  Check the field settings in list settings of each list column for the one that doesn't work vs. the ones that do. Maybe there's something different.

Another thing to check is the values of the form controls.  Easiest way to do that is to create Calculated Columns on the form with the formula set to the control names.  Do this for the control in the "Scope" step and for the 5 controls in the "Incident Details".  Goal here is display the actual values the form controls generates.

Also make sure that the form fields are connected to the right list columns and are saving data to the list when the form is submitted.

For the error, which link are you clicking on in the email?  Do you get this error only when clicking on the link?

Does the workflow actually throw an error or does it run successfully?  Check the Workflow Progress and Workflow Details pages to see if there are any error messages.

Reply
Workflow Hero

Re: Error from Sharepoint with Workflows Settings?

Jump to solution

I quick question

The only difference twixt the non working workflows & the one that does is that there is a condition set. This is the one that works:

So as you can see if batching error is picked & the condition is YES then it moves to the flexitask - which seems to work. As a side question do i need to stop this condition of the answer is no?

so in the ones that dont work i have no conditions set. Other that the workflow settings as described at the top.

So would it work better - or indeed be sensible to do something like this?: & again - do i need to terminate if the answer is no?

0 Kudos
Reply
Workflow Hero

Re: Error from Sharepoint with Workflows Settings?

Jump to solution

Are all of these workflows set to run immediately when the item is created?  There could be an issue with them all trying to run at once.  Try placing a "Pause for" action as the first step in the workflows that don't work and see if that makes a difference.

Reply
Workflow Hero

Re: Error from Sharepoint with Workflows Settings?

Jump to solution

I am presuming that the 3 affected ones will only run depending on the choice made in Heel/Scrap/Other. I have set this up in workflow settings rather than inside the workflow.

I am intrigued by a pause. What am i pausing for bearing in mind the previous statement?

I guess i would put this in right at the top of the workflow as a first action?

0 Kudos
Reply
Workflow Hero

Re: Error from Sharepoint with Workflows Settings?

Jump to solution

You're doing it the right way with the conditional start in the workflow settings.

I suggested using the "Pause for" action as the first step in the uncooperative workflows to make sure that multiple instances of the workflows are not started exactly at the same time.

For the "error" workflows, can you go to the Workflow Progress screen for an item that a workflow errors on?  You mentioned getting the task email.  If so, do you see the "Respond to task" link at the top of the Workflow Progress screen?

0 Kudos
Reply
Workflow Hero

Re: Error from Sharepoint with Workflows Settings?

Jump to solution

I got this to work by changing "Set Conditions" to "RUN IFs" & got it to work just fine

I dunno if this is an internal problem or a problem with Nintex but i have never been able to get a condition box to work in any of the workflows i have worked on

Reply