cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Re: Create Item In Another Site Fails on User Does Not Exist

Jump to solution

You said you were able to get your steps to correctly update; can you provide screenshots of your actions and steps please ?

0 Kudos
Reply
Community Manager Community Manager
Community Manager

Re: Create Item In Another Site Fails on User Does Not Exist

Jump to solution

Kerry,

Here is what I have for the copy to another site actions.  I'm using this to copy the item from a list to a document library just to ensure it works. 

For yours, as I mentioned, I'm not sure what you are trying do with the regex expression.  They work fine, but that may be overkill for what you really need. Its slightly difficult to suggest such without understanding the context of the workflow.

0 Kudos
Reply
Not applicable

Re: Create Item In Another Site Fails on User Does Not Exist

Jump to solution

Ok ... now take that same process in your screenshot and use a "People or Group" field type.

This is where the error is raised !

How do you copy a people type column from the input source to the destination list/library?

The following screenshot errors ... FYI: the default destination file type (see elipses box) is string.

0 Kudos
Reply
Highlighted
Community Manager Community Manager
Community Manager

Re: Create Item In Another Site Fails on User Does Not Exist

Jump to solution

Kerry,

Here's a thought, bring that in as a variable, then use the variable as part of the copy item.  You are setting the field so as long as your original value is good, it should go with no problem.  Also, that field MUST exist in the destination as well for that to work. 

 

Here is what I mean.  Create the variable Primary Legal Rep and set it to People and Group.

Then use the set variable action to set that variable to the correct value from the list item. In my case I use the created by (or Initiator) for example purposes only.

 

Next I modified the copy action and set two fields. The title as title and then foldername (people field) to the workflow data Primary Legal Rep.  I didn't modify anything and allowed Nintex to set those values automatically.

That should do it for you and your values should go over without an error.

 

0 Kudos
Reply
Not applicable

Re: Create Item In Another Site Fails on User Does Not Exist

Jump to solution

Yep; I tried that too but it does not work in this SP 2013 environment. I think the User Profile Service or the AD Mapping is out of whack.

Thanks for the effort.

0 Kudos
Reply