cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Conditional workflow start doesn't work

Hi,

 

I have two workflows, first the workflow works if a item is modified. The second workflow works with a conditional start.

But  the second workflow doesn't run. In the condition I check, which fields are modified.

Condition.jpg

I must defined the rules at the startcondition, because e.g. the filter-function aren't contain the fields with previous value.

 

At an other issue I has use conditional starts and it has work successfully.

 

Kind regards

Labels: (1)
0 Kudos
Reply
3 Replies
burkslm
Nintex Newbie

Re: Conditional workflow start doesn't work

The first step to troubleshooting this is to add a Log History action in the workflow that doesn't work. Make sure it is the very first action. Put any text you want in that action for it to display.

0 Kudos
Reply
eharris04
Nintex Newbie

Re: Conditional workflow start doesn't work

I think you need another condition to add to your conditional start.  Because your second workflow has never run, it doesn't have a previous value to check against.  The item does, but that isn't stored within your workflow to validate against.

Try adding another piece of logic that will be true every time and then use the condition to filter force it to run with only both conditions are true.  This is something I've seen when trying to compare previous values.

0 Kudos
Reply
Not applicable

Re: Conditional workflow start doesn't work

Thanks for your answer.

I have found another question, which are similar to my issue: Conditional Modification WF Not Starting

Now, I have to update my nintex workflow and try it again.

0 Kudos
Reply